Add Belgian e-id middleware [1/2]

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Thomas Danckaert
Owner
unassigned
Submitted by
Thomas Danckaert
Severity
normal
T
T
Thomas Danckaert wrote on 7 Oct 2017 21:35
(address . guix-patches@gnu.org)
20171007.213542.309894121786787748.post@thomasdanckaert.be
Hi Guix,

This adds the middleware for the Belgian electronic id card.

This first patch adds a dependency, libproxy.

Thomas
From 917460cf6764257002c5f4fc5cb11182e87f1804 Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <thomas.danckaert@gmail.com>
Date: Wed, 26 Apr 2017 20:18:56 +0200
Subject: [PATCH 1/2] gnu: Add libproxy.

* gnu/packages/networking.scm (libproxy): New variable.
---
gnu/packages/networking.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 418d11ad0..1a2db007d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -37,6 +37,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -56,6 +57,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages libidn)
@@ -922,6 +924,38 @@ information by IP Address.")
sockets in Perl.")
(license license:perl-license)))
+(define-public libproxy
+ (package
+ (name "libproxy")
+ (version "0.4.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/libproxy/libproxy/"
+ "releases/download/" version "/libproxy-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0kvdrazlzwia876w988cmlypp253gwy6idlh8mjk958c29jb8kb5"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dbus" ,dbus)
+ ("zlib" ,zlib)
+ ("network-manager" ,network-manager)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ctest" "-E" "url-test")))))))
+ (synopsis "Library providing automatic proxy configuration management")
+ (description "Libproxy handles all the details of proxy configuration for
+applications across all scenarios. Applications using libproxy only have to
+specify which proxy to use.")
+ (home-page "https://libproxy.github.io/libproxy")
+ (license license:lgpl2.1+)))
+
(define-public proxychains-ng
(package
(name "proxychains-ng")
--
2.14.2
T
T
Thomas Danckaert wrote on 7 Oct 2017 21:42
[PATCH 2/2] gnu: Add eid-mw.
(address . 28734@debbugs.gnu.org)
20171007.214209.950322502448056392.post@thomasdanckaert.be
This is the middleware package for the Belgian id card.

For this package to actually be useful, we also need a working pcscd
service with the appropriate drivers for card readers... so that's up
next.

Thomas
From 831e8b6572225a71d0c8e85d25a309342e25f975 Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <thomas.danckaert@gmail.com>
Date: Wed, 26 Apr 2017 20:37:10 +0200
Subject: [PATCH 2/2] gnu: Add eid-mw.

* gnu/packages/security-token.scm (eid-mw): New variable.
---
gnu/packages/security-token.scm | 52 ++++++++++++++++++++++++++++++++++++++++-
1 file changed, 51 insertions(+), 1 deletion(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 8ae2dda1c..99b3bd88d 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -25,12 +25,20 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
#:use-module (gnu packages man)
+ #:use-module (gnu packages networking)
+ #:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xml))
(define-public ccid
(package
@@ -70,6 +78,48 @@ readers and is needed to communicate with such devices through the
@command{pcscd} resource manager.")
(license license:lgpl2.1+)))
+(define-public eid-mw
+ (package
+ (name "eid-mw")
+ (version "4.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Fedict/eid-mw/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0s646p19kq27wb160v9b8aaiy30k2shmq4njm471ggd2j7n7a6rs"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gnu-gettext)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
+ (inputs
+ `(("curl" ,curl)
+ ("openssl" ,openssl)
+ ("gtk+" ,gtk+)
+ ("pcsc-lite" ,pcsc-lite)
+ ("p11-kit" ,p11-kit)
+ ("libproxy" ,libproxy)
+ ("libxml2" ,libxml2)
+ ("cyrus-sasl" ,cyrus-sasl)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The github tarball doesn't contain a configure script.
+ (add-before 'configure 'autoreconf
+ (lambda _ (zero? (system* "autoreconf" "-i")))))))
+ (synopsis "Belgian eID Middleware")
+ (description "The Belgian eID Middleware is required to authenticate with
+online services using the Belgian electronic identity card.")
+ (home-page "https://github.com/Fedict/eid-mw")
+ (license license:lgpl3)))
+
(define-public libyubikey
(package
(name "libyubikey")
--
2.14.2
L
L
Ludovic Courtès wrote on 8 Oct 2017 21:59
Re: [bug#28734] Add Belgian e-id middleware [1/2]
(name . Thomas Danckaert)(address . post@thomasdanckaert.be)(address . 28734@debbugs.gnu.org)
87h8v9becv.fsf@gnu.org
Thomas Danckaert <post@thomasdanckaert.be> skribis:

Toggle quote (7 lines)
> From 917460cf6764257002c5f4fc5cb11182e87f1804 Mon Sep 17 00:00:00 2001
> From: Thomas Danckaert <thomas.danckaert@gmail.com>
> Date: Wed, 26 Apr 2017 20:18:56 +0200
> Subject: [PATCH 1/2] gnu: Add libproxy.
>
> * gnu/packages/networking.scm (libproxy): New variable.

[...]

Toggle quote (2 lines)
> + (synopsis "Library providing automatic proxy configuration management")
> + (description "Libproxy handles all the details of proxy configuration for
^
Maybe “of HTTP/HTTPS proxy configuration”?

Otherwise LGTM, thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 8 Oct 2017 22:01
Re: [bug#28734] [PATCH 2/2] gnu: Add eid-mw.
(name . Thomas Danckaert)(address . post@thomasdanckaert.be)(address . 28734@debbugs.gnu.org)
87d15xbe9t.fsf@gnu.org
Thomas Danckaert <post@thomasdanckaert.be> skribis:

Toggle quote (7 lines)
> From 831e8b6572225a71d0c8e85d25a309342e25f975 Mon Sep 17 00:00:00 2001
> From: Thomas Danckaert <thomas.danckaert@gmail.com>
> Date: Wed, 26 Apr 2017 20:37:10 +0200
> Subject: [PATCH 2/2] gnu: Add eid-mw.
>
> * gnu/packages/security-token.scm (eid-mw): New variable.

LGTM, thank you!

Toggle quote (2 lines)
> + (license license:lgpl3)))

Indeed v3-only. :-/

Ludo’.
T
T
Thomas Danckaert wrote on 10 Oct 2017 10:30
Re: [bug#28734] Add Belgian e-id middleware [1/2]
(address . 28734@debbugs.gnu.org)
20171010.103053.1000633603051476806.post@thomasdanckaert.be
From: ludo@gnu.org (Ludovic Courtès)
Subject: Re: [bug#28734] Add Belgian e-id middleware [1/2]
Date: Sun, 08 Oct 2017 21:59:12 +0200
Toggle quote (6 lines)
>> + (synopsis "Library providing automatic proxy configuration
>> management")
>> + (description "Libproxy handles all the details of proxy
>> configuration for
> ^
> Maybe “of HTTP/HTTPS proxy configuration”?
OK, pushed with that change.
Thanks!
Thomas
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28734@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28734
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch