[PATCH] gnu: Add snd.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Ludovic Courtès
Owner
unassigned
Submitted by
宋文武
Severity
normal

Debbugs page

宋文武 wrote 7 years ago
(address . guix-patches@gnu.org)(name . 宋文武)(address . iyzsong@member.fsf.org)
20171003031432.1426-1-iyzsong@member.fsf.org
* gnu/packages/audio.scm (snd): New variable.
---
gnu/packages/audio.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 95a5fdd7c..6c863851e 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -36,6 +36,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -79,6 +80,7 @@
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages maths)
#:use-module (srfi srfi-1))
(define-public alsa-modular-synth
@@ -2926,3 +2928,37 @@ mixers.")
(define-public python2-pyalsaaudio
(package-with-python2 python-pyalsaaudio))
+
+(define-public snd
+ (package
+ (name "snd")
+ (version "17.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ccrma-ftp.stanford.edu/pub/Lisp/"
+ "snd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vm0dy5qlycqkima7y5ajzvazyjybifa803fabjcpncjz08c26vp"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments '(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("fftw" ,fftw)
+ ("gsl" ,gsl)
+ ("gtk+" ,gtk+)
+ ("flac" ,flac)
+ ("mpg123" ,mpg123)
+ ("speex" ,speex)
+ ("timidity++" ,timidity++)
+ ("vorbis-tools" ,vorbis-tools)
+ ("wavpack" ,wavpack)))
+ (synopsis "Sound editor")
+ (home-page "https://ccrma.stanford.edu/software/snd/")
+ (description
+ "Snd is a sound editor modelled loosely after Emacs. It can be
+customized and extended using either s7 (included in the Snd sources), Ruby,
+or Forth.")
+ (license (license:non-copyleft "file://COPYING"))))
--
2.13.3
宋文武 wrote 7 years ago
(address . 28681@debbugs.gnu.org)
87o9posw8o.fsf@member.fsf.org
Add 'install-doc' phase to install its html documentation:
From 3e7378269f85d90d0c4ffb046316d90029d4701e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@member.fsf.org>
Date: Tue, 3 Oct 2017 11:13:05 +0800
Subject: [PATCH] gnu: Add snd.

* gnu/packages/audio.scm (snd): New variable.
---
gnu/packages/audio.scm | 55 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 95a5fdd7c..89032a8e6 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -36,6 +36,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -79,6 +80,7 @@
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages maths)
#:use-module (srfi srfi-1))
(define-public alsa-modular-synth
@@ -2926,3 +2928,56 @@ mixers.")
(define-public python2-pyalsaaudio
(package-with-python2 python-pyalsaaudio))
+
+(define-public snd
+ (package
+ (name "snd")
+ (version "17.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ccrma-ftp.stanford.edu/pub/Lisp/"
+ "snd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vm0dy5qlycqkima7y5ajzvazyjybifa803fabjcpncjz08c26vp"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:out-of-source? #f ; for the 'install-doc' phase
+ #:configure-flags
+ (let* ((out (assoc-ref %outputs "out"))
+ (docdir (string-append out "/share/doc/snd")))
+ (list (string-append "--with-doc-dir=" docdir)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (docdir (string-append out "/share/doc/snd")))
+ (mkdir-p docdir)
+ (for-each
+ (lambda (f)
+ (install-file f docdir))
+ (find-files "." "\\.html$|COPYING"))
+ (copy-recursively "pix" (string-append docdir "/pix"))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("fftw" ,fftw)
+ ("gsl" ,gsl)
+ ("gtk+" ,gtk+)
+ ("flac" ,flac)
+ ("mpg123" ,mpg123)
+ ("speex" ,speex)
+ ("timidity++" ,timidity++)
+ ("vorbis-tools" ,vorbis-tools)
+ ("wavpack" ,wavpack)))
+ (synopsis "Sound editor")
+ (home-page "https://ccrma.stanford.edu/software/snd/")
+ (description
+ "Snd is a sound editor modelled loosely after Emacs. It can be
+customized and extended using either s7 (included in the Snd sources), Ruby,
+or Forth.")
+ (license (license:non-copyleft "file://COPYING"))))
--
2.13.3
Ludovic Courtès wrote 7 years ago
(name . 宋文武)(address . iyzsong@member.fsf.org)(address . 28681@debbugs.gnu.org)
87d16445xh.fsf@gnu.org
iyzsong@member.fsf.org (宋文武) skribis:

Toggle quote (9 lines)
> Add 'install-doc' phase to install its html documentation:
>
> From 3e7378269f85d90d0c4ffb046316d90029d4701e Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@member.fsf.org>
> Date: Tue, 3 Oct 2017 11:13:05 +0800
> Subject: [PATCH] gnu: Add snd.
>
> * gnu/packages/audio.scm (snd): New variable.


Toggle quote (6 lines)
> + (synopsis "Sound editor")
> + (home-page "https://ccrma.stanford.edu/software/snd/")
> + (description
> + "Snd is a sound editor modelled loosely after Emacs. It can be
> +customized and extended using either s7 (included in the Snd sources), Ruby,

“using the s7 Scheme implementation” maybe?

Otherwise LGTM, thanks! :-)

Ludo’.
宋文武 wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28681-done@debbugs.gnu.org)
87poa3u1vw.fsf@member.fsf.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (7 lines)
>> [...]
>> +customized and extended using either s7 (included in the Snd sources), Ruby,
>
> “using the s7 Scheme implementation” maybe?
>
> Otherwise LGTM, thanks! :-)

Done, thank you for the review!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28681@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28681
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help