[PATCH] gnu: Add gnucobol.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 13 Sep 2017 21:38
E1dsDXs-0007iA-Ac@eggs.gnu.org
* gnu/packages/cobol.scm (gnucobol): New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/cobol.scm | 59 ++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 60 insertions(+)
create mode 100644 gnu/packages/cobol.scm

Toggle diff (79 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 1f55e52bfd..f8d285b83a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -88,6 +88,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/chez.scm \
%D%/packages/ci.scm \
%D%/packages/cmake.scm \
+ %D%/packages/cobol.scm \
%D%/packages/code.scm \
%D%/packages/commencement.scm \
%D%/packages/compression.scm \
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
new file mode 100644
index 0000000000..f8f35928a7
--- /dev/null
+++ b/gnu/packages/cobol.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cobol)
+ #:use-module (gnu packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages ncurses))
+
+(define-public gnucobol
+ (package
+ (name "gnucobol")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/gnucobol/gnucobol-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1814s1n95xax2dz938cf4fkcp0q94nkj1gjbdblbzpk9q92zq66w"))))
+ (arguments
+ '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (inputs
+ `(("bdb" ,bdb)
+ ("gmp" ,gmp)
+ ("ncurses" ,ncurses)))
+ (build-system gnu-build-system)
+ (home-page "https://savannah.gnu.org/projects/gnucobol/")
+ (synopsis "A modern COBOL compiler")
+ (description "GnuCOBOL is a free, modern COBOL compiler. GnuCOBOL
+implements a substantial part of the COBOL 85, COBOL 2002 and COBOL 2014
+standards and X/Open COBOL, as well as many extensions included in other
+COBOL compilers (IBM COBOL, MicroFocus COBOL, ACUCOBOL-GT and others).
+GnuCOBOL translates COBOL into C and compiles the translated code using
+a native C compiler.")
+ (license gpl3+)))
--
2.14.1
E
E
Efraim Flashner wrote on 13 Sep 2017 21:53
control
(address . request@debbugs.gnu.org)
20170913195324.GA28792@macbook42.flashner.co.il
reassign 28449 guix-patches
close 28116
close 28419
close 28447
thanks
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlm5jLAACgkQQarn3Mo9
g1EulBAAjngH3sKFQ7ebNb9Y1ILr8lW34mCpRhmzJ/ltPfMdZDf+SNJlX+4ZO0E9
MOQM6unFbXPbYPwMqcnSt4OaNdhtPIVJQde9R8aD44GAqFbCmBYhzBor2lG+fm+X
IYSk5lrXOwsrMZ/mDdtinicfKOEfaQm0YplfL34cuOBUxDoCHyh1STkrRYbWITNa
l5VZQ4GubliEoHVRQNzuNJRqi7NIk44XBg3E/hgtjcwuT74tKvWA7Eg7gISoq9Oa
MAro1t1m17zhhZTBtM8+gX+3dHBkNr+qmx5xdhTk3CMuzXrYaofVdZDhBDt6M86B
+3NrT2i+2+/3sdWUjrFwBVnUvz0Yxfp/F1BTFBD7mgU/H8aJoTkzCFw6jyXbSddk
zdwZtPMEXrQd7zUVuxvxRGgqOiEk9/GHlJv5lsXYvp/JyUgXaDYfMOZNGAhZU4C1
5/lB6dohM6cBdbg8tDPFCXFFjoHRyq+l15cnF9WuAE8QDG6S0VPCfvOQacvnnv/j
3937Rp7nsX+QoSCtgWLvTaikCfpMeztMrzQAm4D8BSt6G8YEGnhSj2QzgkIPxJV6
WEZsIg37rrYHvuSrKuLxQRGz9k7Dg49jHUsW7h92uZh6QN2PZQC8iKkmkj7TL3RN
hKipg/c4LrQc/t7XlGcwHyMChsWse8YureoLxoyoTTjhs7qMV8c=
=xtm7
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 14 Sep 2017 13:48
Re: bug#28449: [PATCH] gnu: Add gnucobol.
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 28449@debbugs.gnu.org)
87fubpa4bf.fsf@gnu.org
Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (3 lines)
> * gnu/packages/cobol.scm (gnucobol): New variable.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

LGTM!

COBOL, AT LAST! :-)

THANK YOU.

LUDO’.
L
L
Ludovic Courtès wrote on 16 Sep 2017 17:47
control message for bug #28449
(address . control@debbugs.gnu.org)
87shfmk5ma.fsf@gnu.org
tags 28449 fixed
close 28449
?