[PATCH] gnu: Fix build failures caused by commit.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20170907164340.32328-1-kkebreau@posteo.net
* gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
* gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
---
gnu/packages/bioinformatics.scm | 2 ++
gnu/packages/ci.scm | 6 +++++-
2 files changed, 7 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bf8eb2e69..699c463bf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4488,6 +4488,8 @@ distribution, coverage uniformity, strand specificity, etc.")
(modify-phases %standard-phases
(add-after 'unpack 'bootstrap
(lambda _
+ (substitute* "gen_tools_am"
+ (("/usr/bin/env perl") (which "perl")))
(zero? (system* "bash" "gen_auto"))))
(add-after 'build 'build-additional-tools
(lambda* (#:key make-flags #:allow-other-keys)
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index c449754be..3b182b826 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -216,7 +216,11 @@ their dependencies.")
(substitute* "Makefile.am"
(("tests/repo.scm \\\\") "\\"))
#t))
- (add-after 'disable-repo-tests 'bootstrap
+ (add-after 'disable-repo-tests 'patch-/bin/sh
+ (lambda _
+ (substitute* "build-aux/git-version-gen"
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))))
+ (add-after 'patch-/bin/sh 'bootstrap
(lambda _ (zero? (system* "sh" "bootstrap"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.14.1
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 28384@debbugs.gnu.org)
87o9ql9oxa.fsf@gnu.org
Hi Kei,

The subject is truncated. :-) Caused by which commit?

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (3 lines)
> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.

This is weird, normally the ‘patch-source-shebangs’ phase, which happens
right before ‘configure’, should take care of these, no?

Toggle quote (14 lines)
> diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
> index c449754be..3b182b826 100644
> --- a/gnu/packages/ci.scm
> +++ b/gnu/packages/ci.scm
> @@ -216,7 +216,11 @@ their dependencies.")
> (substitute* "Makefile.am"
> (("tests/repo.scm \\\\") "\\"))
> #t))
> - (add-after 'disable-repo-tests 'bootstrap
> + (add-after 'disable-repo-tests 'patch-/bin/sh
> + (lambda _
> + (substitute* "build-aux/git-version-gen"
> + (("#!/bin/sh") (string-append "#!" (which "sh"))))))

This phase should return #t.

Thanks,
Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28384@debbugs.gnu.org)
87377xdtwy.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (13 lines)
> Hi Kei,
>
> The subject is truncated. :-) Caused by which commit?
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>
> This is weird, normally the ‘patch-source-shebangs’ phase, which happens
> right before ‘configure’, should take care of these, no?
>

Normally the 'patch-source-shebangs' does just that, but in this case
the script needs to be patched because the bootstrapping phase depends
on perl.

Toggle quote (16 lines)
>> diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
>> index c449754be..3b182b826 100644
>> --- a/gnu/packages/ci.scm
>> +++ b/gnu/packages/ci.scm
>> @@ -216,7 +216,11 @@ their dependencies.")
>> (substitute* "Makefile.am"
>> (("tests/repo.scm \\\\") "\\"))
>> #t))
>> - (add-after 'disable-repo-tests 'bootstrap
>> + (add-after 'disable-repo-tests 'patch-/bin/sh
>> + (lambda _
>> + (substitute* "build-aux/git-version-gen"
>> + (("#!/bin/sh") (string-append "#!" (which "sh"))))))
>
> This phase should return #t.

Thanks for catching that.

Toggle quote (3 lines)
>
> Thanks,
> Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlmyyE4ACgkQ5qXuPBlG
eg0XvBAAnUVFCgZ9PL7ZahNRd9oIK4VSSRxt/Zw1dvWuBYv/1AeqoTR4aLqcGj0R
HTDv/D4THvudnhBmcB+tU5gZUjWAg7r5p2ymgc8jlSjUt1e5GdtvDjR2AUCP6Z/W
/GxKemQBLtBcchz1VhGQgtsACa9c/VeOjZp9q4UEWZI1ElrCHmjQQUOYPRXjAGIC
F5DQHmnOxO2A4qyMl4DWS0D514noqOo77tN8SNdhuldRfRqYohBirMOn+9brLbCe
c0NjNw6frSYDNjJFSELxOW1us6baB1UZZbDAoR88ukk7IlpqCD5mSASGoNw/aXu5
V5+/+T1I2NInXBKnRGuoQYXRLFYH8b/RHxiBaukRoDjPB9/zFzFwipEeHv3BALof
LR6WKfbfAuHUpKg0hWnVUJBXkaYPvWqcsICpBt2F7lGHXsPMnhxhFqRBlmUs7Yfc
79uEsqr44u8mQjr+7xZlyJ9CVHl0K/AWI4o4gnUd/yoGmpWtottWHNn2Yw9npCBb
XmLWC2ihMTM8BB1YdWS9hk+3qUdtPC9f7BAsLIJwqgx2Ib5pha9pKF3lAK2abVZY
vrFyD6WVYMaZYlSykGu7ORpm/whlOVQhRagJJ8Y7pzmI/SgVk+640xIUMIg1bW+G
DGXzeO+EeIlY65iYyqgvx77uMUcHmyb7mb1ddw6kHCPWLQgQIpU=
=a8Xj
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 28384@debbugs.gnu.org)
87efrh9bhk.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (19 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Hi Kei,
>>
>> The subject is truncated. :-) Caused by which commit?
>>
>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>
>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>
>> This is weird, normally the ‘patch-source-shebangs’ phase, which happens
>> right before ‘configure’, should take care of these, no?
>>
>
> Normally the 'patch-source-shebangs' does just that, but in this case
> the script needs to be patched because the bootstrapping phase depends
> on perl.

OK. I don’t understand at what point this became necessary though.

Toggle quote (6 lines)
> From 87ea8addad973568d8599fb93c8df9766b96b6a1 Mon Sep 17 00:00:00 2001
> From: Kei Kebreau <kkebreau@posteo.net>
> Date: Sat, 29 Jul 2017 11:28:42 -0400
> Subject: [PATCH] gnu: Use 'modify-phases' syntax.
> To: guix-patches@gnu.org

Wrong patch. :-)

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28384@debbugs.gnu.org)
87y3podepl.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (24 lines)
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> ludo@gnu.org (Ludovic Courtès) writes:
>>
>>> Hi Kei,
>>>
>>> The subject is truncated. :-) Caused by which commit?
>>>
>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>
>>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>>
>>> This is weird, normally the ‘patch-source-shebangs’ phase, which happens
>>> right before ‘configure’, should take care of these, no?
>>>
>>
>> Normally the 'patch-source-shebangs' does just that, but in this case
>> the script needs to be patched because the bootstrapping phase depends
>> on perl.
>
> OK. I don’t understand at what point this became necessary though.
>

It's probably a result of moving the 'bootstrap' phase before the
'patch-source-shebangs' phase. Without this change, the seek package
builds fine. I have no preference either way, though I notice that the
same thing is done for guile-for-guile-emacs.

Toggle quote (10 lines)
>> From 87ea8addad973568d8599fb93c8df9766b96b6a1 Mon Sep 17 00:00:00 2001
>> From: Kei Kebreau <kkebreau@posteo.net>
>> Date: Sat, 29 Jul 2017 11:28:42 -0400
>> Subject: [PATCH] gnu: Use 'modify-phases' syntax.
>> To: guix-patches@gnu.org
>
> Wrong patch. :-)
>
> Ludo’.

Fixed!
From d9eee184cf80252092c34864d492527ee768a7fb Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kkebreau@posteo.net>
Date: Thu, 7 Sep 2017 09:36:28 -0400
Subject: [PATCH] gnu: Fix build failures caused by commit
d10092b849153dc27cfed0a9601fde6c7bdec918.

* gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
* gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
---
gnu/packages/bioinformatics.scm | 2 ++
gnu/packages/ci.scm | 7 ++++++-
2 files changed, 8 insertions(+), 1 deletion(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bf8eb2e69..699c463bf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4488,6 +4488,8 @@ distribution, coverage uniformity, strand specificity, etc.")
(modify-phases %standard-phases
(add-after 'unpack 'bootstrap
(lambda _
+ (substitute* "gen_tools_am"
+ (("/usr/bin/env perl") (which "perl")))
(zero? (system* "bash" "gen_auto"))))
(add-after 'build 'build-additional-tools
(lambda* (#:key make-flags #:allow-other-keys)
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index c449754be..f3259bfcd 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -216,7 +216,12 @@ their dependencies.")
(substitute* "Makefile.am"
(("tests/repo.scm \\\\") "\\"))
#t))
- (add-after 'disable-repo-tests 'bootstrap
+ (add-after 'disable-repo-tests 'patch-/bin/sh
+ (lambda _
+ (substitute* "build-aux/git-version-gen"
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))
+ #t))
+ (add-after 'patch-/bin/sh 'bootstrap
(lambda _ (zero? (system* "sh" "bootstrap"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.14.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlmzFUYACgkQ5qXuPBlG
eg1DnQ/+P+l6Ef2VGjPZqWZP0q1s6WKPjHQc98hg2aqcRmKQxVkX2TrL6JiLJot9
Y9tOnamoyQ9zBF0DEfQBd8Tz0kIE4h/P2xNS4koWn7lTty+Mqkly2ayvMAuAE+4N
8VLpj5YmzX/ekbLl1k2ic3hcP0qvjSsenoLYj5hjxPaVVjzra/wCZhFRtm+Fo8Rn
62oqrHAmpGbGV+Q7S84Rkdo93bc5LW9UPivluF+TXPlWcRir6jFUFOJe32mX4djK
TRlfxI6O6huImun//tAARm/wppP5xdKGJqUaSEdwuqmBFBAGvbngghJwD1dfxRs9
NCN4R7faefywvbrqCrGwhvcREpfA1jOZ4ux1JTkUJKfrkljTR9r4s1DC+mCGWrpd
6Ogi0XVE57kXTQIJlP4p5MWskv8BJ3CvX4fRyRU2uZF4cdeaQ5hbnH3bEVMgrjkj
WeWPgg+Eku6u3CA2bg4RMmorUsUitnqa/r7bED0K+7gs83nRrXMUB/geV81t1yem
qonzj4dYCgY776u96WBcqyWpnyqRtQnqO5sjPR2QW4pGXivFPsl8+pQVP27rRC26
T6lch4a0Q9iAxXvzwpUiSQaqNb2tbTHDeKjl88PyAjwLQU8Y6gU9vxmAjAGenXIz
ziFSFwK5MIeMk15M1pK7wYOwpAi/5qzEY3kM65whzPEKkiL4jMs=
=fZrf
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 28384@debbugs.gnu.org)
87mv6290kz.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (31 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>
>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>
>>>> Hi Kei,
>>>>
>>>> The subject is truncated. :-) Caused by which commit?
>>>>
>>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>>
>>>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>>>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>>>
>>>> This is weird, normally the ‘patch-source-shebangs’ phase, which happens
>>>> right before ‘configure’, should take care of these, no?
>>>>
>>>
>>> Normally the 'patch-source-shebangs' does just that, but in this case
>>> the script needs to be patched because the bootstrapping phase depends
>>> on perl.
>>
>> OK. I don’t understand at what point this became necessary though.
>>
>
> It's probably a result of moving the 'bootstrap' phase before the
> 'patch-source-shebangs' phase. Without this change, the seek package
> builds fine. I have no preference either way, though I notice that the
> same thing is done for guile-for-guile-emacs.

Since this commit was just about changing the syntax, not the semantics,
I would expect it to keep phases in the same order. That would be more
concise than adding custom code to patch things here and there, no?

WDYT?

Toggle quote (21 lines)
>>> From 87ea8addad973568d8599fb93c8df9766b96b6a1 Mon Sep 17 00:00:00 2001
>>> From: Kei Kebreau <kkebreau@posteo.net>
>>> Date: Sat, 29 Jul 2017 11:28:42 -0400
>>> Subject: [PATCH] gnu: Use 'modify-phases' syntax.
>>> To: guix-patches@gnu.org
>>
>> Wrong patch. :-)
>>
>> Ludo’.
>
> Fixed!
>
> From d9eee184cf80252092c34864d492527ee768a7fb Mon Sep 17 00:00:00 2001
> From: Kei Kebreau <kkebreau@posteo.net>
> Date: Thu, 7 Sep 2017 09:36:28 -0400
> Subject: [PATCH] gnu: Fix build failures caused by commit
> d10092b849153dc27cfed0a9601fde6c7bdec918.
>
> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.

That’s fine with me, even though I have a slight preference for simply
restoring the order of phases as it was before.

Thanks!

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28384@debbugs.gnu.org)
87tw0ad6hk.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (40 lines)
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> ludo@gnu.org (Ludovic Courtès) writes:
>>
>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>
>>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>>
>>>>> Hi Kei,
>>>>>
>>>>> The subject is truncated. :-) Caused by which commit?
>>>>>
>>>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>>>
>>>>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>>>>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>>>>
>>>>> This is weird, normally the ‘patch-source-shebangs’ phase, which happens
>>>>> right before ‘configure’, should take care of these, no?
>>>>>
>>>>
>>>> Normally the 'patch-source-shebangs' does just that, but in this case
>>>> the script needs to be patched because the bootstrapping phase depends
>>>> on perl.
>>>
>>> OK. I don’t understand at what point this became necessary though.
>>>
>>
>> It's probably a result of moving the 'bootstrap' phase before the
>> 'patch-source-shebangs' phase. Without this change, the seek package
>> builds fine. I have no preference either way, though I notice that the
>> same thing is done for guile-for-guile-emacs.
>
> Since this commit was just about changing the syntax, not the semantics,
> I would expect it to keep phases in the same order. That would be more
> concise than adding custom code to patch things here and there, no?
>
> WDYT?
>

I agree in the case of seek.

Toggle quote (25 lines)
>>>> From 87ea8addad973568d8599fb93c8df9766b96b6a1 Mon Sep 17 00:00:00 2001
>>>> From: Kei Kebreau <kkebreau@posteo.net>
>>>> Date: Sat, 29 Jul 2017 11:28:42 -0400
>>>> Subject: [PATCH] gnu: Use 'modify-phases' syntax.
>>>> To: guix-patches@gnu.org
>>>
>>> Wrong patch. :-)
>>>
>>> Ludo’.
>>
>> Fixed!
>>
>> From d9eee184cf80252092c34864d492527ee768a7fb Mon Sep 17 00:00:00 2001
>> From: Kei Kebreau <kkebreau@posteo.net>
>> Date: Thu, 7 Sep 2017 09:36:28 -0400
>> Subject: [PATCH] gnu: Fix build failures caused by commit
>> d10092b849153dc27cfed0a9601fde6c7bdec918.
>>
>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>
> That’s fine with me, even though I have a slight preference for simply
> restoring the order of phases as it was before.
>

I'm most comfortable reverting seek to its last successful state without
the substitute* call and patch leave the cuirass patch as is. If that's
okay with you I can push this to master.

Toggle quote (4 lines)
> Thanks!
>
> Ludo’.

Thanks for helping to sort this out!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlm1PucACgkQ5qXuPBlG
eg3gYQ//S/P+cKC/QyQwo+pNt/+xd4EJvD7TWXZk0qwMaZp3fhrpIQrqkY/Yzijq
iUOytQs2gBUFPmsQzC4cthI1dM5PPulrDbHwdFwL0jyeXBN5hpP5F/WlC7ZHHrM0
tIbGi8bijTmPdQ5dvikKqWyUCrt9KCC2Jk6f2YW3DB+52jzKrfFATI/V/SrjzqoK
ggF6KtTQCglaFk9/DCN0+gXubn69AbDnQVPDB2DrP0Cm/6baIiZ56PuVKUlUGYdV
VJyu7cHZ5zyD8njwjT+IK1f4g6gYSZI0BTyQeR34MhF+3IpPSqW7Rwlf8yw3QO/l
miLgeFPvaaY6zgdP964p3w9CjvZcOh/LpZiWHCAS2nGG4688mc8xWqx7LVXZfiG2
P2VlqSgcoBBjz+lSZxRCLRri3/skO+ZECId+gg0bgQQ/4VODV7D4nl9RxqRfmgPs
K/vN0VyH3gvGMel74fYpfrUi96A6bIA0LUFojGrIbwdddT5a+oovV+ppHisJlIAv
lxCMptCwH0s2dcIiayuX8aCKj2h3O089RdWM1wiswC+DbfX4KkY4pg6+4VofG8st
BjBWMidCGdpGjN6POwUZNmLwloKic/45BOeRQvOe2iIzpXZ9GlgFhWWOFGCuoGXb
GmCcRw1vVw0wz8yZkIGzBpN8Fck+HKVEp426LjWz1n8MNBduPa4=
=W16G
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 28384@debbugs.gnu.org)
87o9qi5lvj.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (73 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>
>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>
>>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>>
>>>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>>>
>>>>>> Hi Kei,
>>>>>>
>>>>>> The subject is truncated. :-) Caused by which commit?
>>>>>>
>>>>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>>>>
>>>>>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>>>>>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>>>>>
>>>>>> This is weird, normally the ‘patch-source-shebangs’ phase, which happens
>>>>>> right before ‘configure’, should take care of these, no?
>>>>>>
>>>>>
>>>>> Normally the 'patch-source-shebangs' does just that, but in this case
>>>>> the script needs to be patched because the bootstrapping phase depends
>>>>> on perl.
>>>>
>>>> OK. I don’t understand at what point this became necessary though.
>>>>
>>>
>>> It's probably a result of moving the 'bootstrap' phase before the
>>> 'patch-source-shebangs' phase. Without this change, the seek package
>>> builds fine. I have no preference either way, though I notice that the
>>> same thing is done for guile-for-guile-emacs.
>>
>> Since this commit was just about changing the syntax, not the semantics,
>> I would expect it to keep phases in the same order. That would be more
>> concise than adding custom code to patch things here and there, no?
>>
>> WDYT?
>>
>
> I agree in the case of seek.
>
>>>>> From 87ea8addad973568d8599fb93c8df9766b96b6a1 Mon Sep 17 00:00:00 2001
>>>>> From: Kei Kebreau <kkebreau@posteo.net>
>>>>> Date: Sat, 29 Jul 2017 11:28:42 -0400
>>>>> Subject: [PATCH] gnu: Use 'modify-phases' syntax.
>>>>> To: guix-patches@gnu.org
>>>>
>>>> Wrong patch. :-)
>>>>
>>>> Ludo’.
>>>
>>> Fixed!
>>>
>>> From d9eee184cf80252092c34864d492527ee768a7fb Mon Sep 17 00:00:00 2001
>>> From: Kei Kebreau <kkebreau@posteo.net>
>>> Date: Thu, 7 Sep 2017 09:36:28 -0400
>>> Subject: [PATCH] gnu: Fix build failures caused by commit
>>> d10092b849153dc27cfed0a9601fde6c7bdec918.
>>>
>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>
>> That’s fine with me, even though I have a slight preference for simply
>> restoring the order of phases as it was before.
>>
>
> I'm most comfortable reverting seek to its last successful state without
> the substitute* call and patch leave the cuirass patch as is. If that's
> okay with you I can push this to master.

Sounds good, thanks!

Ludo'.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28384-done@debbugs.gnu.org)
87h8wachr4.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (80 lines)
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> ludo@gnu.org (Ludovic Courtès) writes:
>>
>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>
>>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>>
>>>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>>>
>>>>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>>>>
>>>>>>> Hi Kei,
>>>>>>>
>>>>>>> The subject is truncated. :-) Caused by which commit?
>>>>>>>
>>>>>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>>>>>
>>>>>>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify
>>>>>>>> unpack phase.
>>>>>>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>>>>>>
>>>>>>> This is weird, normally the ‘patch-source-shebangs’ phase, which happens
>>>>>>> right before ‘configure’, should take care of these, no?
>>>>>>>
>>>>>>
>>>>>> Normally the 'patch-source-shebangs' does just that, but in this case
>>>>>> the script needs to be patched because the bootstrapping phase depends
>>>>>> on perl.
>>>>>
>>>>> OK. I don’t understand at what point this became necessary though.
>>>>>
>>>>
>>>> It's probably a result of moving the 'bootstrap' phase before the
>>>> 'patch-source-shebangs' phase. Without this change, the seek package
>>>> builds fine. I have no preference either way, though I notice that the
>>>> same thing is done for guile-for-guile-emacs.
>>>
>>> Since this commit was just about changing the syntax, not the semantics,
>>> I would expect it to keep phases in the same order. That would be more
>>> concise than adding custom code to patch things here and there, no?
>>>
>>> WDYT?
>>>
>>
>> I agree in the case of seek.
>>
>>>>>> From 87ea8addad973568d8599fb93c8df9766b96b6a1 Mon Sep 17 00:00:00 2001
>>>>>> From: Kei Kebreau <kkebreau@posteo.net>
>>>>>> Date: Sat, 29 Jul 2017 11:28:42 -0400
>>>>>> Subject: [PATCH] gnu: Use 'modify-phases' syntax.
>>>>>> To: guix-patches@gnu.org
>>>>>
>>>>> Wrong patch. :-)
>>>>>
>>>>> Ludo’.
>>>>
>>>> Fixed!
>>>>
>>>> From d9eee184cf80252092c34864d492527ee768a7fb Mon Sep 17 00:00:00 2001
>>>> From: Kei Kebreau <kkebreau@posteo.net>
>>>> Date: Thu, 7 Sep 2017 09:36:28 -0400
>>>> Subject: [PATCH] gnu: Fix build failures caused by commit
>>>> d10092b849153dc27cfed0a9601fde6c7bdec918.
>>>>
>>>> * gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
>>>> * gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
>>>
>>> That’s fine with me, even though I have a slight preference for simply
>>> restoring the order of phases as it was before.
>>>
>>
>> I'm most comfortable reverting seek to its last successful state without
>> the substitute* call and patch leave the cuirass patch as is. If that's
>> okay with you I can push this to master.
>
> Sounds good, thanks!
>
> Ludo'.

Pushed to master as 4561498e1f207e83ecc4a9fe1a08935c2807160f. Thanks again!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28384@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28384
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help