Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
* gnu/packages/bioinformatics.scm (seek)[arguments]: Modify unpack phase.
* gnu/packages/ci.scm (cuirass)[arguments]: Add patch-/bin/sh phase.
---
gnu/packages/bioinformatics.scm | 2 ++
gnu/packages/ci.scm | 6 +++++-
2 files changed, 7 insertions(+), 1 deletion(-)
Toggle diff (32 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bf8eb2e69..699c463bf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4488,6 +4488,8 @@ distribution, coverage uniformity, strand specificity, etc.")
(modify-phases %standard-phases
(add-after 'unpack 'bootstrap
(lambda _
+ (substitute* "gen_tools_am"
+ (("/usr/bin/env perl") (which "perl")))
(zero? (system* "bash" "gen_auto"))))
(add-after 'build 'build-additional-tools
(lambda* (#:key make-flags #:allow-other-keys)
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index c449754be..3b182b826 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -216,7 +216,11 @@ their dependencies.")
(substitute* "Makefile.am"
(("tests/repo.scm \\\\") "\\"))
#t))
- (add-after 'disable-repo-tests 'bootstrap
+ (add-after 'disable-repo-tests 'patch-/bin/sh
+ (lambda _
+ (substitute* "build-aux/git-version-gen"
+ (("#!/bin/sh") (string-append "#!" (which "sh"))))))
+ (add-after 'patch-/bin/sh 'bootstrap
(lambda _ (zero? (system* "sh" "bootstrap"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.14.1