[PATCH] gnu: Add heimdall.

  • Done
  • quality assurance status badge
Details
4 participants
  • Danny Milosavljevic
  • Julien Lepiller
  • Ludovic Courtès
  • Mekeor Melire
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
Merged with

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170906223653.15420-1-dannym@scratchpost.org
* gnu/packages/android.scm (heimdall): New variable.
---
gnu/packages/android.scm | 53 ++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index be3f50add..20bd21bdf 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -22,13 +22,18 @@
(define-module (gnu packages android)
#:use-module (guix packages)
+ #:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages libusb)
#:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages ssh)
#:use-module (gnu packages version-control)
#:use-module (gnu packages tls))
@@ -399,3 +404,51 @@ parts of the development workflow. Repo is not meant to replace Git, only to
make it easier to work with Git. The repo command is an executable Python
script that you can put anywhere in your path.")
(license license:asl2.0)))
+
+(define-public heimdall
+ (package
+ (name "heimdall")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Benjamin-Dobell/Heimdall/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append "heimdall-" version ".tar.gz"))
+ (sha256
+ (base32 "1y7gwg3lipyp2zcysm2vid1qg5nwin9bxbvgzs28lz2rya4fz6sq"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
+ #:tests? #f ; No tests exist.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-invocations
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("heimdall-frontend/source/aboutform.cpp"
+ "heimdall-frontend/source/mainwindow.cpp")
+ (("start[(]\"heimdall\"")
+ (string-append "start(\"" (assoc-ref outputs "out")
+ "/bin/heimdall\"")))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (out-bin (string-append out "/bin"))
+ (out-lib (string-append out "/lib")))
+ (mkdir-p out-bin)
+ (mkdir-p out-lib)
+ (install-file "../build/bin/heimdall" out-bin)
+ (install-file "../build/bin/heimdall-frontend" out-bin)
+ (install-file "../build/libpit/libpit.a" out-lib)
+ #t))))))
+ (inputs
+ `(("libusb" ,libusb)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
+ (home-page "http://glassechidna.com.au/heimdall/")
+ (synopsis "Samsung Flashing Tool")
+ (description
+ "@command{heimdall} can be used to flash firmware onto Samsung mobile
+devices.")
+ (license license:expat)))
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28378@debbugs.gnu.org)
87shfzylum.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/android.scm (heimdall): New variable.

Could you team up with Julien on https://bugs.gnu.org/28285 to merge
the two submissions?

Thanks in advance!

Ludo’.
Ludovic Courtès wrote 8 years ago
control message for bug #28378
(address . control@debbugs.gnu.org)
87r2vjylu7.fsf@gnu.org
merge 28378 28285
Julien Lepiller wrote 7 years ago
Re: [bug#28378] [PATCH] gnu: Add heimdall.
(address . 28378@debbugs.gnu.org)
20170920220902.21333ec3@lepiller.eu
Le Thu, 07 Sep 2017 10:05:53 +0200,
ludo@gnu.org (Ludovic Courtès) a écrit :

Toggle quote (8 lines)
> Hi Danny,
>
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> > * gnu/packages/android.scm (heimdall): New variable.
>
> Could you team up with Julien on <https://bugs.gnu.org/28285> to merge
> the two submissions?
Hi,

here is the result of the merge of the two patches. I'm not sure we need
the static library?

Danny, what do you think of it?

Toggle quote (7 lines)
>
> Thanks in advance!
>
> Ludo’.
>
>
>
Ludovic Courtès wrote 7 years ago
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 28378@debbugs.gnu.org)
8760cdrtww.fsf@gnu.org
Hi Julien,

Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (9 lines)
> From 0cd2378f5aa2626f8118d607a6b3558c212d80ec Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Tue, 29 Aug 2017 23:54:16 +0200
> Subject: [PATCH] gnu: Add heimdall.
>
> * gnu/packages/flashing-tools.scm (heimdall): New variable.
>
> Co-Authored-By: Danny Milosavljevic <dannym@scratchpost.org>

It LGTM. I don’t see why libpit.a is needed, but I’ll let you decide. :-)

Toggle quote (4 lines)
> + (build-system cmake-build-system)
> + (arguments
> + `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")

Why not keep the default “RelWithDebInfo”?

Thanks!

Ludo’.
Julien Lepiller wrote 7 years ago
(address . 28378-done@debbugs.gnu.org)
20171003214627.74bd788a@lepiller.eu
Le Wed, 20 Sep 2017 22:34:23 +0200,
ludo@gnu.org (Ludovic Courtès) a écrit :

Toggle quote (21 lines)
> Hi Julien,
>
> Julien Lepiller <julien@lepiller.eu> skribis:
>
> > From 0cd2378f5aa2626f8118d607a6b3558c212d80ec Mon Sep 17 00:00:00
> > 2001 From: Julien Lepiller <julien@lepiller.eu>
> > Date: Tue, 29 Aug 2017 23:54:16 +0200
> > Subject: [PATCH] gnu: Add heimdall.
> >
> > * gnu/packages/flashing-tools.scm (heimdall): New variable.
> >
> > Co-Authored-By: Danny Milosavljevic <dannym@scratchpost.org>
>
> It LGTM. I don’t see why libpit.a is needed, but I’ll let you
> decide. :-)
>
> > + (build-system cmake-build-system)
> > + (arguments
> > + `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
>
> Why not keep the default “RelWithDebInfo”?
That's what was documented in this package.

Pushed as f282aa530b91c8fecb910bc0a3323fcbd4d39ffb.

Toggle quote (4 lines)
>
> Thanks!
>
> Ludo’.
Closed
Mekeor Melire wrote 7 years ago
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 28378@debbugs.gnu.org)
87mv56txh7.fsf@gmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (1 lines)
> Julien Lepiller <julien@lepiller.eu> skribis:
[…]
Toggle quote (1 lines)
>> * gnu/packages/flashing-tools.scm (heimdall): New variable.
[…]
Toggle quote (6 lines)
>> + (build-system cmake-build-system)
>> + (arguments
>> + `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
>
> Why not keep the default “RelWithDebInfo”?

BUMP. This seems to be the only last remark on this nice new package
definition.
Mekeor Melire wrote 7 years ago
(address . 28378@debbugs.gnu.org)
87lgkqtxa0.fsf@gmail.com
Sorry, I just saw that it's already pushed to master now. Thank you very
much for your effort!
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28378@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28378
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help