[PATCH] gnu: Add emacs-go-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170905070147.30876-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-go-mode): New variable.
---
gnu/packages/emacs.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5d9fd728a..bc01d5777 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1193,6 +1193,26 @@ Using emacs-direnv means that programs started from Emacs will use the
environment set through Direnv.")
(license license:gpl3+)))
+(define-public emacs-go-mode
+ (package
+ (name "emacs-go-mode")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/dominikh/go-mode.el/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1adngbjyb8qnwg7n6r2y31djw9j6qf3b9fi63zd85035q7x4ljnm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/dominikh/go-mode.el")
+ (synopsis "Go mode for Emacs")
+ (description
+ "This package provides go-mode, an Emacs mode for working with software
+written in the Go programming language.")
+ (license license:bsd-3)))
+
(define-public emacs-google-maps
(package
(name "emacs-google-maps")
--
2.14.1
Ludovic Courtès wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28353@debbugs.gnu.org)
87o9qpqnu3.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-go-mode): New variable.

Looks alright to me!

Ludo’.
Christopher Baines wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28353-done@debbugs.gnu.org)
20170906085235.273170eb@cbaines.net
On Tue, 05 Sep 2017 15:25:40 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (6 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/packages/emacs.scm (emacs-go-mode): New variable.
>
> Looks alright to me!

Great :) I've pushed this now. Thanks for reviewing Ludo.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlmvqUNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeiQBAArDLaGQ88upzLUDA51MeBK1GdhPTePDtnW5MnUlDOyKRtqHgdCpHxT4us
RdnI2M43EIYmWiRv4ISKXm90gc8JKmknYKM48Aq9SfVY1Vyy9GAjL8hb2B4fkl/Y
hvkLiL0Dy4CAUGafSb4U45OPVwpdPHsvsH3CSfUwu9pAXordC1vFgmHX8fn88DZy
lRWMAhpwLejKS0uCj9jDCL00S2vBcOK4O7nDb08ixl5R70X0MkyDkAERju94GlG6
dyZXqJwGo9EPaS4igrtQqznaYepcmyExCIVJxPL/bWGof3N8DA426+aOa5y4iChD
AdJWwHJnXtx1KAWzFMmgW0CaTUBk8mghTkHPiNJA+FufDZgBFIS2bE9gGKByQC/t
7UVjyZmkhLxK9il3GmAfK6A1JZLEUSGzwzsf1dBG5zOhFa/IdHxxS/rZRSgnZnNJ
vvA71z0Qd55V3KVuM7/sEy22Pc9MiziAnkINn1ITppmkx64JZw7IhLLAbpks6mCj
KxW4v5e+xvgblb8+et3vZp75Hl6JZqhxDv2nY2tXO/vhKH4KF8kAJRv9HEfAZibM
EjKSwuirGBPrNkoxSalNlisEqVYz+UuxDrDlFf64tWoSKIJDBcr3GVsALFqA6T7W
/CaXYHlfaMzsXLribb+GM4WI9zQgcPr+D1H5NypNiK6Ib1dAt6s=
=qhvQ
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28353@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28353
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help