[PATCH] vm: Remove redundant conditional in system-disk-image.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170903105902.3961-1-mail@cbaines.net
* gnu/system/vm.scm (system-disk-image): Remove redundant conditional for
#:file-system-type when calling qemu-image.
---
gnu/system/vm.scm | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index 4494af003..b3da11876 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -403,10 +403,7 @@ to USB sticks meant to be read-only."
(operating-system-bootloader os))
#:disk-image-size disk-image-size
#:disk-image-format "raw"
- #:file-system-type (if (string=? "iso9660"
- file-system-type)
- "ext4"
- file-system-type)
+ #:file-system-type file-system-type
#:file-system-label root-label
#:copy-inputs? #t
#:register-closures? #t
--
2.14.1
Ludovic Courtès wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28335@debbugs.gnu.org)
87efrm4or1.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (3 lines)
> * gnu/system/vm.scm (system-disk-image): Remove redundant conditional for
> #:file-system-type when calling qemu-image.

OK!

Ludo’.
Christopher Baines wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28335-done@debbugs.gnu.org)
20170904223557.11ba9cb0@cbaines.net
On Mon, 04 Sep 2017 14:44:34 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (7 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/system/vm.scm (system-disk-image): Remove redundant
> > conditional for #:file-system-type when calling qemu-image.
>
> OK!

Pushed as 4138e782dcfea675ebc2347cbd4ea9abeb9dff36 :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlmtxz1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xfvcg//X9yPHGyL1PfdURoK1GUt8C1wtTHWKC1RWnRYqu9BE46dAfRp581iSGsB
UJgEs0aLnZiHkLBoQuTbp2KhbE4c4LAJ6rNigzTrEoNticTU62lm5FljdCgysXTn
Gh1MQ5oNZCzi/KmZIqBfYDE0/M//RCvpA7ZG1ui0IW2EvzorOYpgL3KZooGire5F
NoApOqmqCQXqj3wEmQSm06Rz/y7/LO4wbZKeoZdTkLhXI9xCoGqXt2q7juhsLgEb
mcw0uddeGRQh27pHvv/WWKmX59wkO/T7z1i+dRIUjBjEbc531QEQXYa5/V41Ol6g
0Bj7ltR58PMo1O3qWVC+wDPuw+posx609mjge137oKyMD26G/Cmjx7FXfJY81c3m
PwXwA0TUjSGJNHk5yipRVFrqn8NImO7zN5VTdzZGFRPBOacpb3q3uvCpstBPGMcQ
/tqUuwWu4b1Xb1CCdg88WsKUGuLfU715vzJjasg8XYNpf+NrVtCfFOPfa2MCkCz9
oFnoQg9dZpyu4MsbNPDeg6kDB7Jm6s4Q/XTZt5CWkH4WfOmgHz/xyhqSXdZSmk5g
SAP+DxNBA3EkJEjNqp9697xOObvo0s1AytVEmJeo7hG38ZBZOxPk/FMwFvsZETiB
7JDK47YUt67Jkd4lWVYvKaY0+bZNdSmvY8/nOzD8r5Zt8lsn0Z4=
=pz+P
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28335@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28335
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help