[PATCH] Update CSound to 6.0.9.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal

Debbugs page

Nicolas Goaziou wrote 8 years ago
(address . guix-patches@gnu.org)
87fuc51mkn.fsf@nicolasgoaziou.fr
Hello,

The following patch updates CSound, which currently fails to build, to
6.0.9.1.

There is apparently only one dependency on it: solfege.

Regards,

--
Nicolas Goaziou 0x80A93738
From b08ce3884e5f89b1680d533af34998a4690f83ad Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Sat, 2 Sep 2017 11:18:31 +0200
Subject: [PATCH] gnu: csound: Update to 6.09.1.

* gnu/packages/audio.scm (csound): Update to 6.09.1. Change source URI.
* gnu/packages/patches/csound-header-ordering.patch: Remove patch.
* gnu/local.mk (dist_patch_DATA): Remove reference to patch above.
---
gnu/local.mk | 1 -
gnu/packages/audio.scm | 16 +++++-----------
gnu/packages/patches/csound-header-ordering.patch | 20 --------------------
3 files changed, 5 insertions(+), 32 deletions(-)
delete mode 100644 gnu/packages/patches/csound-header-ordering.patch

Toggle diff (73 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 8c683b8e4..10754ad04 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -567,7 +567,6 @@ dist_patch_DATA = \
%D%/packages/patches/crawl-upgrade-saves.patch \
%D%/packages/patches/crda-optional-gcrypt.patch \
%D%/packages/patches/crossmap-allow-system-pysam.patch \
- %D%/packages/patches/csound-header-ordering.patch \
%D%/packages/patches/clucene-contribs-lib.patch \
%D%/packages/patches/curl-bounds-check.patch \
%D%/packages/patches/cursynth-wave-rand.patch \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 16bca3b6b..d89d2a253 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -568,23 +568,17 @@ emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
(define-public csound
(package
(name "csound")
- (version "6.05")
+ (version "6.09.1")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://sourceforge/csound/csound6/Csound"
- version "/Csound" version ".tar.gz"))
+ "https://github.com/csound/csound/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0a1sni6lr7qpwywpggbkp0ia3h9bwwgf9i87gsag8ra2h30v82hd"))
- (patches (search-patches "csound-header-ordering.patch"))))
+ "0f67vyy3r29hn26qkkcwnizrnzzy8p7gmg3say5q3wjhxns3b5yl"))))
(build-system cmake-build-system)
- (arguments
- ;; Work around this error on x86_64 with libc 2.22+:
- ;; libmvec.so.1: error adding symbols: DSO missing from command line
- (if (string-prefix? "x86_64" (or (%current-target-system) (%current-system)))
- '(#:configure-flags '("-DCMAKE_EXE_LINKER_FLAGS=-lmvec"))
- '()))
(inputs
`(("alsa-lib" ,alsa-lib)
("boost" ,boost)
diff --git a/gnu/packages/patches/csound-header-ordering.patch b/gnu/packages/patches/csound-header-ordering.patch
deleted file mode 100644
index 3640d123d..000000000
--- a/gnu/packages/patches/csound-header-ordering.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Prevent compilation issues with boost-1.60.0.
-
-Reported upstream at https://github.com/csound/csound/issues/570
-
---- Csound6.05/Opcodes/chua/ChuaOscillator.cpp 2015-04-25 14:06:22.995646234 -0500
-+++ Csound6.05/Opcodes/chua/ChuaOscillator.cpp 2015-12-21 10:31:58.182362640 -0600
-@@ -117,11 +117,12 @@
- // d = sys_variables(12);
- // gnor = a*(x.^3) + b*(x.^2) + c*x + d;
-
--#include <OpcodeBase.hpp>
- #include <boost/numeric/ublas/vector.hpp>
- using namespace boost::numeric;
- #include <cmath>
-
-+#include <OpcodeBase.hpp>
-+
- #undef CS_KSMPS
- #define CS_KSMPS (opds.insdshead->ksmps)
-
--
2.14.1
Ludovic Courtès wrote 8 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 28328@debbugs.gnu.org)
87bmmps2yy.fsf@gnu.org
Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

Toggle quote (9 lines)
>>From b08ce3884e5f89b1680d533af34998a4690f83ad Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Sat, 2 Sep 2017 11:18:31 +0200
> Subject: [PATCH] gnu: csound: Update to 6.09.1.
>
> * gnu/packages/audio.scm (csound): Update to 6.09.1. Change source URI.
> * gnu/packages/patches/csound-header-ordering.patch: Remove patch.
> * gnu/local.mk (dist_patch_DATA): Remove reference to patch above.

LGTM, thanks!

Ludo'.
Nicolas Goaziou wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28328-done@debbugs.gnu.org)
877exc14b5.fsf@nicolasgoaziou.fr
Hello,

ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (13 lines)
> Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:
>
>>>From b08ce3884e5f89b1680d533af34998a4690f83ad Mon Sep 17 00:00:00 2001
>> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
>> Date: Sat, 2 Sep 2017 11:18:31 +0200
>> Subject: [PATCH] gnu: csound: Update to 6.09.1.
>>
>> * gnu/packages/audio.scm (csound): Update to 6.09.1. Change source URI.
>> * gnu/packages/patches/csound-header-ordering.patch: Remove patch.
>> * gnu/local.mk (dist_patch_DATA): Remove reference to patch above.
>
> LGTM, thanks!

Pushed. Thank you for the review.

Regards,

--
Nicolas Goaziou 0x80A93738
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28328@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28328
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help