[PATCH] gnu: pt-scotch32: use keyword arguments from "scotch32"

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Paul Garlick
Owner
unassigned
Submitted by
Paul Garlick
Severity
normal

Debbugs page

Paul Garlick wrote 8 years ago
(address . guix-patches@gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
20170901161948.20538-1-pgarlick@tourbillion-technology.com
*gnu/packages/maths.scm (pt-scotch32) [arguments]: substitute keyword
arguments from "scotch32" package, ensuring that the INTSIZE32 macro is
set
---
gnu/packages/maths.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7481636fa..cb2d09414 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2024,9 +2024,9 @@ YACC = bison -pscotchyy -y -b y
(propagated-inputs
`(("openmpi" ,openmpi))) ;headers include MPI headers
(arguments
- (substitute-keyword-arguments (package-arguments scotch)
- ((#:phases scotch-phases)
- `(modify-phases ,scotch-phases
+ (substitute-keyword-arguments (package-arguments scotch32)
+ ((#:phases scotch32-phases)
+ `(modify-phases ,scotch32-phases
(replace 'build
(lambda _
(and
--
2.13.0
Ludovic Courtès wrote 8 years ago
(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)(address . 28318-done@debbugs.gnu.org)
87a82a4oe2.fsf@gnu.org
Hi Paul,

Paul Garlick <pgarlick@tourbillion-technology.com> skribis:

Toggle quote (4 lines)
> *gnu/packages/maths.scm (pt-scotch32) [arguments]: substitute keyword
> arguments from "scotch32" package, ensuring that the INTSIZE32 macro is
> set

Good catch. Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28318@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28318
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help