Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
Add a more flexible variant of the fold-packages procedure, that takes a list
of the modules to work with. The existing fold-packages procedure then calls
fold-packages-in-modules with the result of the all-modules procedure.
I wrote this when looking at how to get the packages in a specific set of
modules, to create jobs for cuirass.
* gnu/packages.scm (fold-packages-in-modules): New procedure.
(fold-packages): Change to use fold-packages-in-modules.
---
gnu/packages.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
Toggle diff (37 lines)
diff --git a/gnu/packages.scm b/gnu/packages.scm
index 562906178..3f0ff56b8 100644
--- a/gnu/packages.scm
+++ b/gnu/packages.scm
@@ -47,6 +47,7 @@
%bootstrap-binaries-path
%package-module-path
+ fold-packages-in-modules
fold-packages
find-packages-by-name
@@ -144,13 +145,21 @@ for system '~a'")
"Call (PROC PACKAGE RESULT) for each available package, using INIT as
the initial value of RESULT. It is guaranteed to never traverse the
same package twice."
+ (fold-packages-in-modules (all-modules (%package-module-path))
+ proc
+ init))
+
+(define (fold-packages-in-modules modules proc init)
+ "Call (PROC PACKAGE RESULT) for each available package within any of the
+modules in MODULES, using INIT as the initial value of RESULT. It is
+guaranteed to never traverse the same package twice."
(fold-module-public-variables (lambda (object result)
(if (and (package? object)
(not (hidden-package? object)))
(proc object result)
result))
init
- (all-modules (%package-module-path))))
+ modules))
(define find-packages-by-name
(let ((packages (delay
--
2.14.1