[PATCH core-updates] gnu: groff: Make build reproducible.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170829055836.27037-1-dannym@scratchpost.org
* gnu/packages/groff.scm (groff)[arguments]: Add phase "setenv".
---
gnu/packages/groff.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 67dd1dbfa..6e1a60e9b 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -56,7 +56,14 @@
("perl" ,perl)
("psutils" ,psutils)
("texinfo" ,texinfo)))
- (arguments '(#:parallel-build? #f)) ; parallel build fails
+ (arguments
+ `(#:parallel-build? #f ; parallel build fails
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "GS_GENERATE_UUIDS" "0")
+ #t)))))
(synopsis "Typesetting from plain text mixed with formatting commands")
(description
"Groff is a typesetting package that reads plain text and produces
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28271@debbugs.gnu.org)
87r2vsuizh.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (23 lines)
> * gnu/packages/groff.scm (groff)[arguments]: Add phase "setenv".
> ---
> gnu/packages/groff.scm | 9 ++++++++-
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
> index 67dd1dbfa..6e1a60e9b 100644
> --- a/gnu/packages/groff.scm
> +++ b/gnu/packages/groff.scm
> @@ -56,7 +56,14 @@
> ("perl" ,perl)
> ("psutils" ,psutils)
> ("texinfo" ,texinfo)))
> - (arguments '(#:parallel-build? #f)) ; parallel build fails
> + (arguments
> + `(#:parallel-build? #f ; parallel build fails
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'setenv
> + (lambda _
> + (setenv "GS_GENERATE_UUIDS" "0")
> + #t)))))

OK for the brand new ‘core-updates’ branch.

Thank you!

Ludo’.
Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170831150618.6efeaca6@scratchpost.org
close 28271
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28271@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28271
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help