[PATCH] gnu: Add emacs-wgrep.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alex Kost
  • Kyle Meyer
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170823093605.8868-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-wgrep): New variable.
---
gnu/packages/emacs.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 140a53205..2a3914770 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3447,6 +3447,33 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(home-page "http://web-mode.org/")
(license license:gpl3+)))
+(define-public emacs-wgrep
+ (package
+ (name "emacs-wgrep")
+ (version "2.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mhayashi1120/Emacs-wgrep/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2bpypar70xg6dsx12x1k74f39ww930rday7rgqpyknzsx1k4l1"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
+ (synopsis "Edit a grep buffer and apply those changes to the files")
+ (description
+ "Emacs wgrep allows you to edit a grep buffer and apply those changes to
+the file buffer.
+
+Activate by using:
+
+@example
+(require 'wgrep)
+@end example")
+ (license license:gpl3+)))
+
(define-public emacs-helm
(package
(name "emacs-helm")
--
2.14.1
Kyle Meyer wrote 8 years ago
871so2jssi.fsf@kyleam.com
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-wgrep): New variable.

Thanks, wgrep is very useful.

Toggle quote (3 lines)
> gnu/packages/emacs.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)

[...]

Toggle quote (10 lines)
> + (description
> + "Emacs wgrep allows you to edit a grep buffer and apply those changes to
> +the file buffer.
> +
> +Activate by using:
> +
> +@example
> +(require 'wgrep)
> +@end example")

I'm not sure the description should include information on activating
the package (especially when it involves fairly standard steps).
Quickly scanning emacs.scm, I didn't spot any other descriptions that
have similar instructions.

Also, "(require 'wgrep)" shouldn't be needed here because Guix sets up
the autoloads. Calling wgrep-change-to-wgrep-mode from a grep-mode
buffer is the common entry point, I think, and wgrep autoloads that
command.

--
Kyle
Christopher Baines wrote 8 years ago
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 28201@debbugs.gnu.org)
20170828115852.4cbb5429@cbaines.net
On Wed, 23 Aug 2017 09:51:57 -0400
Kyle Meyer <kyle@kyleam.com> wrote:

Toggle quote (31 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
> > * gnu/packages/emacs.scm (emacs-wgrep): New variable.
>
> Thanks, wgrep is very useful.
>
> > gnu/packages/emacs.scm | 27 +++++++++++++++++++++++++++
> > 1 file changed, 27 insertions(+)
>
> [...]
>
> > + (description
> > + "Emacs wgrep allows you to edit a grep buffer and apply those
> > changes to +the file buffer.
> > +
> > +Activate by using:
> > +
> > +@example
> > +(require 'wgrep)
> > +@end example")
>
> I'm not sure the description should include information on activating
> the package (especially when it involves fairly standard steps).
> Quickly scanning emacs.scm, I didn't spot any other descriptions that
> have similar instructions.
>
> Also, "(require 'wgrep)" shouldn't be needed here because Guix sets up
> the autoloads. Calling wgrep-change-to-wgrep-mode from a grep-mode
> buffer is the common entry point, I think, and wgrep autoloads that
> command.

That makes sense. I've tested the package, and it does indeed work
without running (require 'wgrep). I'll send an updated patch without
this.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlmj92xfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfjFw//aWfL0KMFenzG+6qsaF8/Qlo5Jt3gCRbh7T9vJPxss7IueFSV6W+chrmH
VNxwXzhN+yOVfhpKZSck5+8XbMWw7WTErPuJ2ZWSzsplZ2jryw4EpLa5XXgbSwCK
DPG9CRLhlBOSos8zaYhg4pXjcyAVvubX+Nnq6nbsPolcd2ux1DBOul5ZwyTkRQNp
5E31chOGuwcmsCMI3Hp0u2yRujKb+iyVCHNF/uGkdOYedNJ4agJj4fOmMYhB1TF6
nU4BzCVe/0ZbJ4i82uA0wLury+1JNb+noSaWYrI/KaCdPPqLwK22JVyxlYRd1iTG
uTxn/zQB1UseGD2yT94cmp/EJ4IrgyjHgsDweD5RGVYEOqEe6nNPxMdIMkjakY3m
cBFgsUqAgMk32jS/K0A6aiJcKMwU947DiAucdddWJp/3gEoYcN3nTCgPfVnnpOjH
ucVX2MUG1VbvKVlP/OW31/ckq2JohinCRBSsUJenjR9frU30CxWNd5VeB4yPzS+0
lcuYaaJvNIEVbGz4+oHGAdtge229FESQDswEJmdNCwwvTNztbre2Mdj4YCI8DaUg
bU3EdBRUhif9+eSX216GGgUXZMyEsKpgeJrt9zJb3xY+xRM6RZmoKotu1N5PQHHv
bSUqGm6IiGDVybtjtUN2Ih4RAY4reUbq9wsEyJHz6tzlIbZq4PA=
=m/o6
-----END PGP SIGNATURE-----


Christopher Baines wrote 8 years ago
[PATCH] gnu: Add emacs-wgrep.
(address . 28201@debbugs.gnu.org)
20170828105927.28246-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-wgrep): New variable.
---
gnu/packages/emacs.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 140a53205..66eca3aab 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3447,6 +3447,27 @@ Dust.js, React/JSX, Angularjs, ejs, etc.")
(home-page "http://web-mode.org/")
(license license:gpl3+)))
+(define-public emacs-wgrep
+ (package
+ (name "emacs-wgrep")
+ (version "2.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mhayashi1120/Emacs-wgrep/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r2bpypar70xg6dsx12x1k74f39ww930rday7rgqpyknzsx1k4l1"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mhayashi1120/Emacs-wgrep")
+ (synopsis "Edit a grep buffer and apply those changes to the files")
+ (description
+ "Emacs wgrep allows you to edit a grep buffer and apply those changes to
+the file buffer.")
+ (license license:gpl3+)))
+
(define-public emacs-helm
(package
(name "emacs-helm")
--
2.14.1
Alex Kost wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28201@debbugs.gnu.org)
87zia3r55z.fsf@gmail.com
Christopher Baines (2017-08-28 11:59 +0100) wrote:

Toggle quote (5 lines)
> * gnu/packages/emacs.scm (emacs-wgrep): New variable.
> ---
> gnu/packages/emacs.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)

Looks good to me, thank you!

--
Alex
Christopher Baines wrote 8 years ago
(name . Alex Kost)(address . alezost@gmail.com)(address . 28201-done@debbugs.gnu.org)
20170910193304.29c25ed2@cbaines.net
On Sat, 09 Sep 2017 23:24:56 +0300
Alex Kost <alezost@gmail.com> wrote:

Toggle quote (9 lines)
> Christopher Baines (2017-08-28 11:59 +0100) wrote:
>
> > * gnu/packages/emacs.scm (emacs-wgrep): New variable.
> > ---
> > gnu/packages/emacs.scm | 21 +++++++++++++++++++++
> > 1 file changed, 21 insertions(+)
>
> Looks good to me, thank you!

Great, thanks for reviewing, I've now pushed this :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlm1hWBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfHgw//YV4neTMTqbI2ANa9qNlfBEiYoWOGGugnxX6gMlFOo6CQirALma7eXpsi
D4o0pkUSNZqjNNPteoLeqqR6f0P4/MYTy6zFUD6egRZkoXEuBG9hjGgfPBO6KTkI
pfZyF2tmLY8kvn4M9WZ2CzZqFfM2e+QNwUFeNnphi/LMLtnwQFGHOlBJY9loqw+r
a63rOUUKmYzXbtFVHyubT91BgxXGb4j8YWKsjQYTlEp0xeJ857hkuAmR3x1Yhhxp
a23BkldrCUKU3kHZQRwCVkXtoK05JhcJO3iSlIKBTy2hZywMbwWMuhsMzj321JMr
xAXJSb7o2pIXBAPRxJsYxFgY5zCaHeKx1E/s99LlfxfmRGhUzO4dX/J9cWvxvNwa
r73X+X8DGb5QwJwntVobUmzTOe9oAheG5vS6lAhPDvEKzhu6s0bn7mfyf9dwGRIf
LicsE2eLHsmFPB0GDS0lzqzAX8LQt8Ai5vbZmcsPQRrvKNDS8aAMLlsZ/6jgQ3/U
GEOMYhjwLJS/x7JxPnKmweZbyPNWD9MaOwzUpSRHTBhLlez6gFGhDu+y1cGRH/M1
0E7MSWO9HuJz5x7/HWzKEdrsj3aKbJTT6pcJUXkkOsLvCl3OxO7JEV/3sG016BjL
fx6htmBS9tAz2ss9actR5MghrEwWOxjZ4Wmv2o/5rt+4CGXtPq8=
=L03u
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28201@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28201
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help