[PATCH] gnu: Add emacs-rspec.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Kost
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170823093521.8514-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-rspec): New variable.
---
gnu/packages/emacs.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 140a53205..536726f03 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1967,6 +1967,43 @@ tables.")
mode-line.")
(license license:gpl2+)))
+(define-public emacs-rspec
+ (package
+ (name "emacs-rspec")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pezra/rspec-mode/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j0a7ms5516nlg60qfyn730pfxys6acm0rgyxh5xfkpi6jafgpvw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/pezra/rspec-mode")
+ (synopsis "Provides a rspec mode for working with RSpec")
+ (description
+ "The Emacs RSpec mode provides keybindings for Ruby source files, e.g. to
+verify the spec associated with the current buffer, or entire project, as well
+as moving between the spec files, and coresponding code files.
+
+There are also keybindings for spec files and Dired buffers.
+
+To enable, use:
+
+@example
+(require 'rspec-mode)
+@end example
+
+Provided you have yasnippet installed, you can load relevant snippets:
+
+@example
+(eval-after-load 'rspec-mode
+ '(rspec-install-snippets))
+@end example")
+ (license license:gpl3+)))
+
(define-public emacs-smart-mode-line
(package
(name "emacs-smart-mode-line")
--
2.14.1
Christopher Baines wrote 8 years ago
(address . 28200@debbugs.gnu.org)
20170904061254.24476-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-rspec): New variable.
---
gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8955313e5..efb9e42a0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1968,6 +1968,31 @@ tables.")
mode-line.")
(license license:gpl2+)))
+(define-public emacs-rspec
+ (package
+ (name "emacs-rspec")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pezra/rspec-mode/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j0a7ms5516nlg60qfyn730pfxys6acm0rgyxh5xfkpi6jafgpvw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/pezra/rspec-mode")
+ (synopsis "Provides a rspec mode for working with RSpec")
+ (description
+ "The Emacs RSpec mode provides keybindings for Ruby source files, e.g. to
+verify the spec associated with the current buffer, or entire project, as well
+as moving between the spec files, and coresponding code files.
+
+Also included are keybindings for spec files and Dired buffers, as well as
+snippets for yasnippet.")
+ (license license:gpl3+)))
+
(define-public emacs-smart-mode-line
(package
(name "emacs-smart-mode-line")
--
2.14.1
Alex Kost wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28200@debbugs.gnu.org)
874lsbsjsl.fsf@gmail.com
Christopher Baines (2017-09-04 07:12 +0100) wrote:

Toggle quote (5 lines)
> * gnu/packages/emacs.scm (emacs-rspec): New variable.
> ---
> gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)

This patch looks good to me, I think you may commit it, thank you! And
sorry for this long delay without reviewing :-)

--
Alex
Christopher Baines wrote 8 years ago
(name . Alex Kost)(address . alezost@gmail.com)(address . 28200-done@debbugs.gnu.org)
20170910193239.64cff275@cbaines.net
On Sat, 09 Sep 2017 23:23:38 +0300
Alex Kost <alezost@gmail.com> wrote:

Toggle quote (10 lines)
> Christopher Baines (2017-09-04 07:12 +0100) wrote:
>
> > * gnu/packages/emacs.scm (emacs-rspec): New variable.
> > ---
> > gnu/packages/emacs.scm | 25 +++++++++++++++++++++++++
> > 1 file changed, 25 insertions(+)
>
> This patch looks good to me, I think you may commit it, thank you!
> And sorry for this long delay without reviewing :-)

No problem, thanks for reviewing Alex :)

I've now pushed this.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlm1hUdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xe2ng/9GT9FVBWFH6skPDJsTIQIZPUbT9a67PkAdBLWst9Y9dPDRtf+hV8u6m9h
UtX/ep7VYNBofS1MHIsEgXd9xJdPBsxBUHdCesePmqIxOcGZDmlyxVJCEuHCTsfD
/Qv1MLW1NTsR49LmahYzFGbYY4qpcZjxRrkig/6irnZZ1YWZEOjFgYK9oOsXcx3A
IDn7rPws8+vLnulo/+XM0UqXWMskK5oMFEtd8lMgdQ8zlmZzvDPlcknuXtMF0t4S
IWlI6FppyFJboH9Wm/MA7hCCV0LLYVoYhlAIQtoQ3NM3QtTV9umOKm6BEhkMQY4I
rPhxsPPgca0rvkBrCyTd/IN8eeS2yGuHUcqIx6i62xpNk9hjfFCe+hAs9s0y4PjZ
lqtBKkFx7tzB852iSgtU5z4p8xZ/bkH24+GCjOTuTaJm53vlyEWybswynNQUVOFh
o6mynFcrpfTxWFkIa+eSfxBOXVEEmPxLqzgFeo3m/vwbSloZV34vJE6puHf7vua0
JLtMVF05Wtet7PDfZ1TuCKa5/fOeRlj0FnYuK5GOEIFoF9Bu1a7DWasuM16yfQoT
yYYRje53TU2S7NiVnoeTZ9jg5QrjmYL/izvam6ExSvOGdD7QIO5HZTZJn6IIuP+p
Zi+DemDB7obzS5F8SzihDhGm5gdvOnmn34NgfiTVs4bNPGzWssk=
=rllg
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28200@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28200
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help