[PATCH] gnu: Add emacs-minitest.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170823093433.8118-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-minitest): New variable.
---
gnu/packages/emacs.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 140a53205..bb4375fa6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1628,6 +1628,47 @@ display and behaviour is easily customisable.")
of files under Git version control from within Emacs.")
(license license:gpl3+)))
+(define-public emacs-minitest
+ (package
+ (name "emacs-minitest")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/arthurnn/minitest-emacs/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dsb7kzvs1x6g4sgqmq73jqacb7wzm0wfkiq5m9dqdzq8mppgiqs"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include (cons "^snippets\\/minitest-mode\\/" %default-include)
+ #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)))
+ (home-page "https://github.com/arthurnn/minitest-emacs")
+ (synopsis "Emacs minitest mode")
+ (description
+ "The minitest mode provides commands to run the tests for the current
+file or line, as well as rerunning the previous tests, or all the tests for a
+project.
+
+To enable minitest mode on ruby files, use:
+
+@example
+(add-hook 'ruby-mode-hook 'minitest-mode)
+@end example
+
+If you hava yasnippet installed, you can load snippets relevent to minitest:
+
+@example
+(eval-after-load 'minitest
+ '(minitest-install-snippets))
+@end example")
+ (license license:expat)))
+
(define-public emacs-el-mock
(package
(name "emacs-el-mock")
--
2.14.1
Christopher Baines wrote 8 years ago
(address . 28199@debbugs.gnu.org)
20170904060647.23514-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-minitest): New variable.
---
gnu/packages/emacs.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b3d5fc97e..5c40fda24 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1629,6 +1629,36 @@ display and behaviour is easily customisable.")
of files under Git version control from within Emacs.")
(license license:gpl3+)))
+(define-public emacs-minitest
+ (package
+ (name "emacs-minitest")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/arthurnn/minitest-emacs/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1dsb7kzvs1x6g4sgqmq73jqacb7wzm0wfkiq5m9dqdzq8mppgiqs"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include (cons "^snippets\\/minitest-mode\\/" %default-include)
+ #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)))
+ (home-page "https://github.com/arthurnn/minitest-emacs")
+ (synopsis "Emacs minitest mode")
+ (description
+ "The minitest mode provides commands to run the tests for the current
+file or line, as well as rerunning the previous tests, or all the tests for a
+project.
+
+This package also includes relevant snippits for yasnippet.")
+ (license license:expat)))
+
(define-public emacs-el-mock
(package
(name "emacs-el-mock")
--
2.14.1
Maxim Cournoyer wrote 8 years ago
FCF20D54-B4A4-4BF6-8C11-452D5125DF84@gmail.com
On September 4, 2017 2:06:47 AM EDT, Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (47 lines)
>* gnu/packages/emacs.scm (emacs-minitest): New variable.
>---
> gnu/packages/emacs.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
>diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>index b3d5fc97e..5c40fda24 100644
>--- a/gnu/packages/emacs.scm
>+++ b/gnu/packages/emacs.scm
>@@ -1629,6 +1629,36 @@ display and behaviour is easily customisable.")
> of files under Git version control from within Emacs.")
> (license license:gpl3+)))
>
>+(define-public emacs-minitest
>+ (package
>+ (name "emacs-minitest")
>+ (version "0.8.0")
>+ (source (origin
>+ (method url-fetch)
>+ (uri (string-append
>+
>"https://github.com/arthurnn/minitest-emacs/archive/v"
>+ version ".tar.gz"))
>+ (file-name (string-append name "-" version ".tar.gz"))
>+ (sha256
>+ (base32
>+
>"1dsb7kzvs1x6g4sgqmq73jqacb7wzm0wfkiq5m9dqdzq8mppgiqs"))))
>+ (build-system emacs-build-system)
>+ (arguments
>+ '(#:include (cons "^snippets\\/minitest-mode\\/"
>%default-include)
>+ #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
>+ (propagated-inputs
>+ `(("emacs-dash" ,emacs-dash)
>+ ("emacs-f" ,emacs-f)))
>+ (home-page "https://github.com/arthurnn/minitest-emacs")
>+ (synopsis "Emacs minitest mode")
>+ (description
>+ "The minitest mode provides commands to run the tests for the
>current
>+file or line, as well as rerunning the previous tests, or all the
>tests for a
>+project.
>+
>+This package also includes relevant snippits for yasnippet.")

s/snippits/snippets


Toggle quote (6 lines)
>+ (license license:expat)))
>+
> (define-public emacs-el-mock
> (package
> (name "emacs-el-mock")

Thanks!

Hi,
Christopher Baines wrote 8 years ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 28199-done@debbugs.gnu.org)
20170904223655.27f775b9@cbaines.net
On Mon, 04 Sep 2017 11:22:29 +0000
Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (52 lines)
> On September 4, 2017 2:06:47 AM EDT, Christopher Baines
> <mail@cbaines.net> wrote:
> >* gnu/packages/emacs.scm (emacs-minitest): New variable.
> >---
> > gnu/packages/emacs.scm | 30 ++++++++++++++++++++++++++++++
> > 1 file changed, 30 insertions(+)
> >
> >diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> >index b3d5fc97e..5c40fda24 100644
> >--- a/gnu/packages/emacs.scm
> >+++ b/gnu/packages/emacs.scm
> >@@ -1629,6 +1629,36 @@ display and behaviour is easily
> >customisable.")
> > of files under Git version control from within Emacs.")
> > (license license:gpl3+)))
> >
> >+(define-public emacs-minitest
> >+ (package
> >+ (name "emacs-minitest")
> >+ (version "0.8.0")
> >+ (source (origin
> >+ (method url-fetch)
> >+ (uri (string-append
> >+
> >"https://github.com/arthurnn/minitest-emacs/archive/v"
> >+ version ".tar.gz"))
> >+ (file-name (string-append name "-" version ".tar.gz"))
> >+ (sha256
> >+ (base32
> >+
> >"1dsb7kzvs1x6g4sgqmq73jqacb7wzm0wfkiq5m9dqdzq8mppgiqs"))))
> >+ (build-system emacs-build-system)
> >+ (arguments
> >+ '(#:include (cons "^snippets\\/minitest-mode\\/"
> >%default-include)
> >+ #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
> >+ (propagated-inputs
> >+ `(("emacs-dash" ,emacs-dash)
> >+ ("emacs-f" ,emacs-f)))
> >+ (home-page "https://github.com/arthurnn/minitest-emacs")
> >+ (synopsis "Emacs minitest mode")
> >+ (description
> >+ "The minitest mode provides commands to run the tests for the
> >current
> >+file or line, as well as rerunning the previous tests, or all the
> >tests for a
> >+project.
> >+
> >+This package also includes relevant snippits for yasnippet.")
>
> s/snippits/snippets

Good spot :)

Toggle quote (8 lines)
> >+ (license license:expat)))
> >+
> > (define-public emacs-el-mock
> > (package
> > (name "emacs-el-mock")
>
> Thanks!

Pushed now as 26361de404c48a3378fc828eaa36d23dfacca3f1
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlmtx3dfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfnUQ/+JQjvRFFsBcitKMa4IVCXvyYK+Z0DTk83GMkfznv0/+tVPSXto4QHds7x
kOYgBBWxr3rzunViQWmfBEsUhQXTEpY+gP+jXhwgYuPY0TWFNyo09GgvcEq/wpte
aIJj6eOHSfIHtZkKy4kAp7fISaL4W6vrlf/brJPAx4yE865GOJhCx/h5/M/DX7cZ
QSJTqBkRmGK6PC2EdAu1uLMml2F5OQfdz5ClkcdA3oZIGcZ1U090aGhZAH7wiqHD
Zs5vVBjOF6jb5DNrT06LjLdF7nHa9yn08woSJ3AvX3Bahwuf+FTRkIsSQGEzPG8m
X4n/lK2YEo++iYPY2k8fybMCPkuZU6+NoNu745WrMrw6X1G4wuv+z1jlGD5101qP
So+lG/N9l4/nGnTYwtJNum0diXp9YqmnSFm6i4r6bzgd7L0MaqyCNto0cv8pCnma
3+y2rIC/ojmSEFDb0Io2hhEVMvQEo5IF+8EunTgejI0WGUG3uCJ0+m9BHpN1mBM1
ANDsOgGFpNyWugSAcnjNfjU5pfDhz+NpYUV27FITxxQ6E0JmtFdn2pUCTpPukiRA
pYIQxWtlTiqzoJOhroSlSYNzr52pV6qOzFWVYsGY/OGX2nsVjiU9crcEaV6bI+vB
i8ZWq7oPGKKArJfcVd40sjVg55BLU+P60oXY3kmtMn2vUhfHfyY=
=AKwg
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28199@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28199
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help