[PATCH] build: Do not store two copies of the ISO-9660 superblock anymore.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170819024656.17036-1-dannym@scratchpost.org
* gnu/build/vm.scm (make-iso9660-image): Do not store two copies of the
ISO-9660 superblock anymore.
---
gnu/build/vm.scm | 13 -------------
1 file changed, 13 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/build/vm.scm b/gnu/build/vm.scm
index 727494ad9..409320b1a 100644
--- a/gnu/build/vm.scm
+++ b/gnu/build/vm.scm
@@ -379,19 +379,6 @@ GRUB configuration and OS-DRV as the stuff in it."
"var=/tmp/root/var"
"run=/tmp/root/run"
"--"
- ;; Store two copies of the headers.
- ;; The resulting ISO-9660 image has a DOS MBR and
- ;; one protective partition (with type 0xCD).
- ;; Because GuixSD only uses actual partitions
- ;; rather than what /proc/partitions returns, work
- ;; around it by storing the primary volume
- ;; descriptor twice, once where it should be and
- ;; once in the partition.
- ;; Allegedly, otherwise, many other GNU tools
- ;; (automounters etc) would also be confused by
- ;; the extra partition so it makes sense to
- ;; store two copies in any case.
- "-boot_image" "any" "partition_offset=16"
"-volid" ,(string-upcase volume-id)
,@(if volume-uuid
`("-volume_date" "uuid"
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28145@debbugs.gnu.org)
877exv699r.fsf@gnu.org
Hello Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (3 lines)
> * gnu/build/vm.scm (make-iso9660-image): Do not store two copies of the
> ISO-9660 superblock anymore.

Why is it no longer needed? Otherwise fine with me. :-)

Ludo’.
Danny Milosavljevic wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28145@debbugs.gnu.org)
20170829074902.1688b3c5@scratchpost.org
Hi Ludo,

On Tue, 22 Aug 2017 15:07:28 +0200
ludo@gnu.org (Ludovic Courtès) wrote:
Toggle quote (7 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> > * gnu/build/vm.scm (make-iso9660-image): Do not store two copies of the
> > ISO-9660 superblock anymore.
>
> Why is it no longer needed? Otherwise fine with me. :-)

Because we went ahead and now we just read it from the whole disk on boot (previously, it only accepted superblocks on partitions, remember?).

Previously on master:

- DVD
+ ISO9660 superblock
+ partition table
+ partition
+ ISO9660 superblock copy <--- GuixSD sees this

Now on master:

- DVD
+ ISO9660 superblock <--- GuixSD sees this
+ partition table
+ partition
+ ISO9660 superblock copy <--- what's this for now?

With the patch:

- DVD
+ ISO9660 superblock <--- GuixSD sees this
+ partition table
+ partition
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28145@debbugs.gnu.org)
87val6qclh.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (36 lines)
> Hi Ludo,
>
> On Tue, 22 Aug 2017 15:07:28 +0200
> ludo@gnu.org (Ludovic Courtès) wrote:
>> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>>
>> > * gnu/build/vm.scm (make-iso9660-image): Do not store two copies of the
>> > ISO-9660 superblock anymore.
>>
>> Why is it no longer needed? Otherwise fine with me. :-)
>
> Because we went ahead and now we just read it from the whole disk on boot (previously, it only accepted superblocks on partitions, remember?).
>
> Previously on master:
>
> - DVD
> + ISO9660 superblock
> + partition table
> + partition
> + ISO9660 superblock copy <--- GuixSD sees this
>
> Now on master:
>
> - DVD
> + ISO9660 superblock <--- GuixSD sees this
> + partition table
> + partition
> + ISO9660 superblock copy <--- what's this for now?
>
> With the patch:
>
> - DVD
> + ISO9660 superblock <--- GuixSD sees this
> + partition table
> + partition

Thanks for the explanation, got it now.

Ludo’.
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28145@debbugs.gnu.org)
877ewuv0ky.fsf@gnu.org
Hi Danny,

Just a reminder that this patch hasn’t been applied. TIA! :-)

Ludo’.

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (10 lines)
> Hello Danny,
>
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> * gnu/build/vm.scm (make-iso9660-image): Do not store two copies of the
>> ISO-9660 superblock anymore.
>
> Why is it no longer needed? Otherwise fine with me. :-)
>
> Ludo’.
Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170922040310.278b8262@scratchpost.org
close 28145
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28145@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28145
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help