[PATCH] Add documentation for NGinx

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170817194235.20b7e1a0@cbaines.net
Christopher Baines (2):
perl: Add perl-parse-recdescent.
web: Add NGinx documentation.

gnu/packages/perl.scm | 25 +++++++++++++
gnu/packages/web.scm | 98 +++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 123 insertions(+)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlmV45tfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfGdhAAmGqo8fLjkHkInbW/FHZifpRuw3Q+NG/g+32Qj3FyefTp6ABYbWwCZsJb
3OszLTniCqrGqUCm6oYIMU4bd2T3FEc0MkW36eRvbp1c9HaTe2nOfdL+LRn/GUCR
HAkbGWbA5S5c5sRjasqiliKTCnGA5085dl/BeAorVm2WsQm/+EsihQuMuVXECJzl
ejGzAL1fTf/YJjOk+aiuGlGDu8G/QsG3eqzIjFrE8l4O5a8dWXKIutihVZMdYa7s
GtTh6I9SEToUpu7fLNNxqPj1mudBZBVSmgnR2QVCQ4T2pVN6yoHJs5K1qwyQ7GZp
6jOwOYSHcvc8LwlR6bDsYOiUffRzaQ6piFzCWVAF5tCw9pN/BOZG8vCJKzHhODHB
m+qhfWgMIt19sdMnVh5CQzEZE/AzYtZ5/iDYYyAkTcCAcT0weU/ExjH3ERyWnfYr
pRUA2cr0ZAPMWf3ARLyVa8CROD1WI5lnreb7mBUwS+VZjirbKRxTbt8JWYfprPlX
/XELY6UQeN2wHwOonzlwQspM8+KSIR02/g/Nq1wZxHsqq3jbSHyLX5iyaBxYPQbZ
5TE+CUhE7+8w1D/3N3g7UX6GYJgwPwm8IFRAFzmVqRhIzpXgZFAxKrwcTzqV42Ma
+5OJpFJfjhSH9vBB/3BTQ8xw/GkUQTzQ84pfMeJqHQEReWBtt1Q=
=2/Mu
-----END PGP SIGNATURE-----


Christopher Baines wrote 8 years ago
[PATCH 1/2] perl: Add perl-parse-recdescent.
(address . 28127@debbugs.gnu.org)
20170817184404.18517-1-mail@cbaines.net
* gnu/packages/perl.scm (perl-parse-recdescent): New variable.
---
gnu/packages/perl.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3265a55f0..b05b4d8bc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8375,3 +8375,28 @@ interface to File::Find::Object.")
(description "Test::TrailingSpace tests for trailing spaces
in Perl source files.")
(license x11)))
+
+(define-public perl-parse-recdescent
+ (package
+ (name "perl-parse-recdescent")
+ (version "1.967015")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JT/JTBRAUN/Parse-RecDescent-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dvfcn2xvj9r4ra5xqgasl847nsm1iy85w1kly41fkxm9im36hqr"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "http://search.cpan.org/dist/Parse-RecDescent")
+ (synopsis "Generate Recursive-Descent Parsers")
+ (description
+ "Parse::RecDescent can incrementally generate top-down recursive-descent
+text parsers from simple yacc-like grammar specifications.")
+ (license (package-license perl))))
--
2.14.1
Christopher Baines wrote 8 years ago
[PATCH 2/2] web: Add NGinx documentation.
(address . 28127@debbugs.gnu.org)
20170817184404.18517-2-mail@cbaines.net
* gnu/packages/web.scm (nginx): Add comment about deleting the documentation.
(nginx-xslscript): New variable.
(nginx-docs): New variable.
---
gnu/packages/web.scm | 98 ++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 98 insertions(+)

Toggle diff (125 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6eb9833f2..5e58ad3f8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -43,6 +43,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix cvs-download)
+ #:use-module (guix hg-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
@@ -134,6 +135,8 @@ and its related documentation.")
(define-public nginx
(package
(name "nginx")
+ ;; Consider updating the nginx-docs package if the nginx package is
+ ;; updated.
(version "1.12.1")
(source (origin
(method url-fetch)
@@ -212,6 +215,101 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
;; except for two source files which are bsd-4 licensed.
(license (list l:bsd-2 l:expat l:bsd-3 l:bsd-4))))
+(define nginx-xslscript
+ (let ((revision 11)
+ (changeset "01dc9ba12e1b"))
+ (package
+ (name "nginx-xslscript")
+ (version
+ (simple-format #f "2014-03-31-~A-~A" revision changeset))
+ (source (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "http://hg.nginx.org/xslscript")
+ (changeset changeset)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0am8zvdx3jmiwkg5q07qjaw5r26r4i2v5i4yr8a1k0jgib6ii08g"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out-bin (string-append
+ (assoc-ref outputs "out")
+ "/bin")))
+ (mkdir-p out-bin)
+ (copy-file "xslscript.pl"
+ (string-append
+ out-bin
+ "/xslscript.pl"))
+ #t))))))
+ (home-page "http://hg.nginx.org/xslscript")
+ (synopsis "XSLScript with NGinx specific modifications")
+ (description
+ "XSLScript is a terse notation for writing complex XSLT stylesheets.
+This is modified version, specifically intended for use with the NGinx
+documentation.")
+ (license l:bsd-2))))
+
+(define-public nginx-docs
+ ;; This documentation should be relevant for nginx-1.12.0
+ (let ((revision 1961)
+ (changeset "dd4b6c564e10"))
+ (package
+ (name "nginx-docs")
+ (version
+ (simple-format #f "2017-04-12-~A-~A" revision changeset))
+ (source
+ (origin (method hg-fetch)
+ (uri (hg-reference
+ (url "http://hg.nginx.org/nginx.org")
+ (changeset changeset)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0rycfnnm2xkm777769h1zib428q45j64mx8nzzfzs4v07jbfc8m5"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((output (assoc-ref outputs "out")))
+ (substitute* "umasked.sh"
+ ((" /bin/sh") (string-append " " (which "sh"))))
+ ;; The documentation includes a banner, which makes sense on
+ ;; the NGinx website, but doesn't make much sense when
+ ;; viewing locally. Therefore, modify the CSS to remove the
+ ;; banner.
+ (substitute* "xslt/style.xslt"
+ (("#banner \\{ background: black;")
+ "#banner { background: black;
+ display: none;"))
+ (zero? (system* "make")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((output (assoc-ref outputs "out")))
+ (mkdir-p output)
+ (copy-recursively "libxslt" output)
+ #t))))))
+ (native-inputs
+ `(("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("nginx-xslscript" ,nginx-xslscript)))
+ (home-page "https://nginx.org")
+ (synopsis "Documentation for NGinx")
+ (description
+ "The documentation for the NGinx web server.")
+ (license l:bsd-2))))
+
(define-public fcgi
(package
(name "fcgi")
--
2.14.1
Christopher Baines wrote 7 years ago
control message for bug #28127
(address . control@debbugs.gnu.org)
87o9ps79is.fsf@cbaines.net
severity 28127 normal
Ludovic Courtès wrote 7 years ago
Re: [bug#28127] [PATCH 1/2] perl: Add perl-parse-recdescent.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28127@debbugs.gnu.org)
87a8176kfa.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/perl.scm (perl-parse-recdescent): New variable.

[...]

Toggle quote (4 lines)
> + (home-page
> + "http://search.cpan.org/dist/Parse-RecDescent")
> + (synopsis "Generate Recursive-Descent Parsers")

Title-case.

Toggle quote (3 lines)
> + (description
> + "Parse::RecDescent can incrementally generate top-down recursive-descent

@code{Parse::RecDescent}.

Toggle quote (2 lines)
> + (license (package-license perl))))

license:perl-license

OK with these changes, thank you!

Ludo’.
Ludovic Courtès wrote 7 years ago
Re: [bug#28127] [PATCH 2/2] web: Add NGinx documentation.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28127@debbugs.gnu.org)
8760bv6kb6.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/web.scm (nginx): Add comment about deleting the documentation.
> (nginx-xslscript): New variable.
> (nginx-docs): New variable.

That’s a good idea!

Toggle quote (7 lines)
> +(define-public nginx-docs
> + ;; This documentation should be relevant for nginx-1.12.0
> + (let ((revision 1961)
> + (changeset "dd4b6c564e10"))
> + (package
> + (name "nginx-docs")

Maybe “nginx-doc” (singular)?

Toggle quote (5 lines)
> + (home-page "https://nginx.org")
> + (synopsis "Documentation for NGinx")
> + (description
> + "The documentation for the NGinx web server.")

“This package provides HTML documentation for the NGINX web server.” (?)

Also, s/NGinx/NGINX/ if I’m not mistaken.

Thanks!

Ludo’.
Christopher Baines wrote 7 years ago
[PATCH 2/2] web: Add nginx-documentation.
(address . 28127@debbugs.gnu.org)
20171005204013.24889-2-mail@cbaines.net
* gnu/packages/web.scm (nginx): Add comment about updating the documentation.
(nginx-xslscript): New variable.
(nginx-docs): New variable.
---
gnu/packages/web.scm | 98 ++++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 98 insertions(+)

Toggle diff (125 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a2af98da5..a612be013 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -43,6 +43,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix cvs-download)
+ #:use-module (guix hg-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
@@ -139,6 +140,8 @@ and its related documentation.")
(define-public nginx
(package
(name "nginx")
+ ;; Consider updating the nginx-docs package if the nginx package is
+ ;; updated.
(version "1.12.1")
(source (origin
(method url-fetch)
@@ -225,6 +228,101 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
;; except for two source files which are bsd-4 licensed.
(license (list l:bsd-2 l:expat l:bsd-3 l:bsd-4))))
+(define nginx-xslscript
+ (let ((revision 11)
+ (changeset "01dc9ba12e1b"))
+ (package
+ (name "nginx-xslscript")
+ (version
+ (simple-format #f "2014-03-31-~A-~A" revision changeset))
+ (source (origin
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "http://hg.nginx.org/xslscript")
+ (changeset changeset)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0am8zvdx3jmiwkg5q07qjaw5r26r4i2v5i4yr8a1k0jgib6ii08g"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out-bin (string-append
+ (assoc-ref outputs "out")
+ "/bin")))
+ (mkdir-p out-bin)
+ (copy-file "xslscript.pl"
+ (string-append
+ out-bin
+ "/xslscript.pl"))
+ #t))))))
+ (home-page "http://hg.nginx.org/xslscript")
+ (synopsis "XSLScript with NGinx specific modifications")
+ (description
+ "XSLScript is a terse notation for writing complex XSLT stylesheets.
+This is modified version, specifically intended for use with the NGinx
+documentation.")
+ (license l:bsd-2))))
+
+(define-public nginx-documentation
+ ;; This documentation should be relevant for nginx-1.12.0
+ (let ((revision 1961)
+ (changeset "dd4b6c564e10"))
+ (package
+ (name "nginx-documentation")
+ (version
+ (simple-format #f "2017-04-12-~A-~A" revision changeset))
+ (source
+ (origin (method hg-fetch)
+ (uri (hg-reference
+ (url "http://hg.nginx.org/nginx.org")
+ (changeset changeset)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0rycfnnm2xkm777769h1zib428q45j64mx8nzzfzs4v07jbfc8m5"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((output (assoc-ref outputs "out")))
+ (substitute* "umasked.sh"
+ ((" /bin/sh") (string-append " " (which "sh"))))
+ ;; The documentation includes a banner, which makes sense on
+ ;; the NGinx website, but doesn't make much sense when
+ ;; viewing locally. Therefore, modify the CSS to remove the
+ ;; banner.
+ (substitute* "xslt/style.xslt"
+ (("#banner \\{ background: black;")
+ "#banner { background: black;
+ display: none;"))
+ (zero? (system* "make")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((output (assoc-ref outputs "out")))
+ (mkdir-p output)
+ (copy-recursively "libxslt" output)
+ #t))))))
+ (native-inputs
+ `(("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("nginx-xslscript" ,nginx-xslscript)))
+ (home-page "https://nginx.org")
+ (synopsis "Documentation for nginx web server")
+ (description
+ "This package provides HTML documentation for the nginx web server.")
+ (license l:bsd-2))))
+
(define-public fcgi
(package
(name "fcgi")
--
2.14.2
Christopher Baines wrote 7 years ago
[PATCH 1/2] perl: Add perl-parse-recdescent.
(address . 28127@debbugs.gnu.org)
20171005204013.24889-1-mail@cbaines.net
* gnu/packages/perl.scm (perl-parse-recdescent): New variable.
---
gnu/packages/perl.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 09d679817..815a212d1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8885,6 +8885,31 @@ YAML-style files, written with as little code as possible, reducing load time
and memory overhead.")
(license (package-license perl))))
+(define-public perl-parse-recdescent
+ (package
+ (name "perl-parse-recdescent")
+ (version "1.967015")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JT/JTBRAUN/Parse-RecDescent-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dvfcn2xvj9r4ra5xqgasl847nsm1iy85w1kly41fkxm9im36hqr"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "http://search.cpan.org/dist/Parse-RecDescent")
+ (synopsis "Generate recursive-descent parsers")
+ (description
+ "@code{Parse::RecDescent} can incrementally generate top-down
+recursive-descent text parsers from simple yacc-like grammar specifications.")
+ (license perl-license)))
+
(define-public perl-parse-yapp
(package
(name "perl-parse-yapp")
--
2.14.2
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28127@debbugs.gnu.org)
20171005214053.579dc9a8@cbaines.net
On Wed, 04 Oct 2017 16:45:45 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (24 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/packages/perl.scm (perl-parse-recdescent): New variable.
>
> [...]
>
> > + (home-page
> > + "http://search.cpan.org/dist/Parse-RecDescent")
> > + (synopsis "Generate Recursive-Descent Parsers")
>
> Title-case.
>
> > + (description
> > + "Parse::RecDescent can incrementally generate top-down
> > recursive-descent
>
> @code{Parse::RecDescent}.
>
> > + (license (package-license perl))))
>
> license:perl-license
>
> OK with these changes, thank you!

I've sent an updated patch with these changes now, thanks for
reviewing :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnWmNVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xfbyg//UmnIBtb+RuCnHtyRPBRdvRclSa6OncPLsQ72J+zMqj64JRGHRUELwuCw
dpgXyW40R6X6F7kVVrNMN5amyXMtJ+ssQ4HS2Ck5655ysh4utXxRduGkdz8Iaj0V
tjfnN5yE4+fmyGc0hu62sf+2p3dB4SMfP42JlA/2NtxtWR0NF6xU3WvDmxgJrKg2
y0/EVJp3ZYU3393aDqSwVi95ZTdjSiLxBEkUcqa6uClWszoqwbqWQvMFE4CA2z18
/17Jwx9b77y/KCdK9HZTxHJhNYjGSybwY3lh8eOHr3cMr1SRsgrnOcvzddDxS7kn
4QJF6nayPOKKcJL3FwJpdccc4A8TLTgKTf42t/FXGXvIXwdVeCyDs/tk5PGlMM7q
qawW6d/eStd0zXHwYxpSJgy4gHmsl2ZLcQT8d+BousLhOKc32nwwTbSbmcz1yQbX
d3qfu5CMimKxBdrWa7uT1JtZeQT7QmiVRA1LFUQHdE8X96pGC/MRNHXecfBGLtBx
o4SB0EUO9K9fpgjgyiMLaJeaq7m43/9pw1rPJ93IOSacRrXTPKW08GFyIFAHykRs
cTihb+i7m5CD6zIUT4SDiIvSs1JIggzdYccHVIAX+7JwJhM5lN1gX7UcQgRRJ/be
msX+23rhFXaMUwsImqP87J7YxuL7VlQTG3ivOrgodyv2BITKQvA=
=HShl
-----END PGP SIGNATURE-----


Christopher Baines wrote 7 years ago
Re: [bug#28127] [PATCH 2/2] web: Add NGinx documentation.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28127@debbugs.gnu.org)
20171005214309.5c7e8f49@cbaines.net
On Wed, 04 Oct 2017 16:48:13 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (17 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/packages/web.scm (nginx): Add comment about deleting the
> > documentation. (nginx-xslscript): New variable.
> > (nginx-docs): New variable.
>
> That’s a good idea!
>
> > +(define-public nginx-docs
> > + ;; This documentation should be relevant for nginx-1.12.0
> > + (let ((revision 1961)
> > + (changeset "dd4b6c564e10"))
> > + (package
> > + (name "nginx-docs")
>
> Maybe “nginx-doc” (singular)?

I wasn't sure about nginx-doc, so I have sent an updated patch using
nginx-documentation.

Toggle quote (10 lines)
> > + (home-page "https://nginx.org")
> > + (synopsis "Documentation for NGinx")
> > + (description
> > + "The documentation for the NGinx web server.")
>
> “This package provides HTML documentation for the NGINX web
> server.” (?)
>
> Also, s/NGinx/NGINX/ if I’m not mistaken.

I haven't seen any guidance on this, but the documentation itself uses
nginx (all lower case) as far as I can see, so I've switched to using
that.

I've sent an updated patch, thanks for your review :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnWmV1fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XecNQ/+KJuXR1XFB4tp0J7lJ2DdaVmhHyF7M92rCC8bt3BETli7kn6FRfnFmz3w
Bzwi+PdO296Bs4eFI+mMX0tjTrOkHLNWvC7s9i0ay1SGX0vbyGV8qV4eMqcmoAD0
A+JBoKHczVWC3b8UjSfiq+mGPTqH8HspmTDm7D/06GVUwUm5E9KwpFmRgEXjEbPY
BYgdsm4kaKvVwTwM4Nn+yUPire2F4BMQSI0uFGbMZ7dPA1x0A3bB8StHAl4qSS6f
m/EOO9Vo05PWF+zVJCndmqN4rfcTotEYT0LLv8kNu1LKUdJJV2qAMQ9YttnpQzmY
Az6C7ZaWshGmf5udY3LqhEr84V2v3ghuciaY2dl/8a6It+1xcUrbk9YZFGX3yaaS
YgZJhs1anDy1NMORy6QqLDTTkZl15L6QIqImPxkQpdp28xqxuUgJqbW4NWY4d9MG
CYIf48S+A5Gn0Q9PfJAEDhCzYrkOd4ku3f6F/XjAImQTPxcwh22Kgy5obf9idtqa
ksGUcQ/80V8deOVWRe/5vtrXTp318mYB5HNqAUQb1x1pwxSlK7zer/oReWBKX2Sa
Ccz+H1V/MVx4TCSgZ42C/FQgLwbWn29a9zB2s2b5d0VgY+YhTsjNVWtMTz0y2xR5
hkF/Hb3Kx6gUEaggQl8Q6l42JLKOkVgzkUJL+/wqgDEsuc+Mns8=
=MEbF
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 7 years ago
Re: [bug#28127] [PATCH 1/2] perl: Add perl-parse-recdescent.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28127@debbugs.gnu.org)
87h8vak8et.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/perl.scm (perl-parse-recdescent): New variable.

OK!
Ludovic Courtès wrote 7 years ago
Re: [bug#28127] [PATCH 2/2] web: Add nginx-documentation.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 28127@debbugs.gnu.org)
87d15yk8d9.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (3 lines)
> * gnu/packages/web.scm (nginx): Add comment about updating the documentation.
> (nginx-xslscript): New variable.
> (nginx-docs): New variable.
^^
nginx-documentation

OK!
Christopher Baines wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 28127-done@debbugs.gnu.org)
20171008143842.23a748f2@cbaines.net
On Sat, 07 Oct 2017 22:31:30 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (10 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/packages/web.scm (nginx): Add comment about updating the
> > documentation. (nginx-xslscript): New variable.
> > (nginx-docs): New variable.
> ^^
> nginx-documentation
>
> OK!

I've fixed the commit message now, and pushed this. Thanks again for
reviewing :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlnaKmJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeNNg//X1JIbO5a80aQGIZ9K3/vLYZloo5CBKjEQqr/t1YKrSmGcZke8kewCalS
RIQBco67+vS84LTI/O502uSHcS9UF+SmNDOLNMCeq2VsKKQTK7hJgoWCfyLqOV5j
t0HLRznmPINuKdpbxzYMP2NyOzF9wC3oReG/evaHlF/akcz5OB3+YJMmcDKb0OOv
pmmhr7G5gjiSwPumrR8bxtJen9EJVGCwIorl/0/YW6F1Utg9UG1ufk0wPC1tTbLW
2V8p49rFPBCSmNAyFBRh6Thehu5WN9zgTXnaoHcsRsoKJPK+UTYLKlP1geghQfdy
1d6qqa22P0VBCD079p8a8iYC0Tfa0nVcvHLBwKNvlCOvif0Hu6nVyB83xcTuvg8I
7su/qnlB3lvNeDGyMT6TxtKQdCPkLNKlTzeWx9qapSRPQmMWpaiKSZ5cMIydCFKT
of31ikWOmjloRV4LRM0KVsAsaqWWXQJgDEWctVf4qrsFpxX8xDGhRzUj3mOCeo29
Oe+MpW8PEh9JVgIu/lXtqHmTUoqKzDO27FXy766exiEoUwSCuB1RYoVMpsV95iHe
snbJRDPY5u0EBlFFFTZ6ee4gFvPU2b0v4XIN8OsUEvllNOpnLUGC1yMKs5QOFjFr
156wJ4KoQ34koDmbKFDYlZqyVyEdPaZD6jjcs+1QiGYHjjPTI2w=
=8Ws2
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28127@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28127
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help