[PATCH] gnu: Add rosegarden.

  • Done
  • quality assurance status badge
Details
One participant
  • Danny Milosavljevic
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170816203057.28633-1-dannym@scratchpost.org
* gnu/packages/music.scm (rosegarden): New variable.
---
gnu/packages/music.scm | 94 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 94 insertions(+)

Toggle diff (102 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6d0b3aeff..9068a1661 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3205,3 +3205,97 @@ specification and header.")
;; The DSSI interface is LGPL2.1+, some tests and examples are GPL2+.
;; The vast majority of examples are in the public domain.
(license (list license:lgpl2.1+ license:gpl2+))))
+
+(define-public rosegarden
+ (package
+ (name "rosegarden")
+ (version "17.04")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/rosegarden/rosegarden/"
+ version "/rosegarden-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1khfcj22asdhjh0jvhkqsz200wgmigkhsrcz09ffia5hqm0n32lq"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DUSE_QT5=1") ; "-DCMAKE_BUILD_TYPE=Release"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("BUILD_TESTING OFF") "BUILD_TESTING ON")
+ ;; Make tests work.
+ ((" -fvisibility=hidden") ""))
+ #t))
+ (add-after 'unpack 'fix-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/gui/general/ProjectPackager.cpp"
+ (("\"flac\\>")
+ (string-append "\"" (assoc-ref inputs "flac") "/bin/flac"))
+ (("\"wavpack\\>")
+ (string-append "\"" (assoc-ref inputs "wavpack") "/bin/wavpack"))
+ (("\"wvunpack\\>")
+ (string-append "\"" (assoc-ref inputs "wavpack") "/bin/wvunpack"))
+ (("\"bash\\>")
+ (string-append "\"" (assoc-ref inputs "bash") "/bin/bash"))
+ (("\"tar\\>")
+ (string-append "\"" (assoc-ref inputs "tar") "/bin/tar")))
+ (substitute* "src/gui/general/LilyPondProcessor.cpp"
+ (("\"convert-ly\\>")
+ (string-append "\"" (assoc-ref inputs "lilypond") "/bin/convert-ly"))
+ (("\"lilypond\\>")
+ (string-append "\"" (assoc-ref inputs "lilypond") "/bin/lilypond")))
+ #t))
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ ;; Prevent Last-Modified from being written.
+ ;; The "*.qm" files that are used in locale.qrc would have a new
+ ;; mtime otherwise that is written into qrc_locale.cpp in the
+ ;; end - except when we disable it.
+ (substitute* "src/CMakeLists.txt"
+ (("COMMAND [$][{]QT_RCC_EXECUTABLE[}]")
+ "COMMAND ${QT_RCC_EXECUTABLE} --format-version 1")
+ ;; Extraneous.
+ ;(("qt5_add_resources[(]rg_SOURCES ../data/data.qrc[)]")
+ ; "qt5_add_resources(rg_SOURCES ../data/data.qrc OPTIONS --format-version 1)")
+ )
+ ;; Make hashtable traversal order predicable.
+ (setenv "QT_RCC_TEST" "1") ; important
+ #t))
+ (add-before 'check 'prepare-check
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ ;; Tests create files in $HOME/.local/share/rosegarden .
+ (mkdir-p "/tmp/foo")
+ (setenv "HOME" "/tmp/foo")
+ #t)))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("bash" ,bash)
+ ("dssi" ,dssi)
+ ("flac" ,flac)
+ ("fftwf" ,fftwf)
+ ("jack-2" ,jack-2)
+ ("ladspa" ,ladspa)
+ ("liblo" ,liblo)
+ ("libsamplerate" ,libsamplerate)
+ ("lilypond" ,lilypond)
+ ("lrdf" ,lrdf)
+ ("qtbase" ,qtbase)
+ ("tar" ,tar)
+ ("lirc" ,lirc)
+ ("wavpack" ,wavpack)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qtlinguist" ,qttools)))
+ (synopsis "Music composition and editing environment based around a MIDI
+sequencer")
+ (description "Rosegarden is a music composition and editing environment
+based around a MIDI sequencer that features a rich understanding of music
+notation and includes basic support for digital audio.")
+ (home-page "http://www.rosegardenmusic.com/")
+ (license license:gpl2)))
Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170902142933.4a8de970@scratchpost.org
close 28115
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28115@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28115
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help