[PATCH 0/2] Add FBReader.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal
D
D
Danny Milosavljevic wrote on 15 Aug 2017 20:44
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170815184452.18629-1-dannym@scratchpost.org
Danny Milosavljevic (2):
gnu: Add liblinebreak.
gnu: Add fbreader.

gnu/packages/ebook.scm | 67 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 67 insertions(+)
D
D
Danny Milosavljevic wrote on 15 Aug 2017 20:47
[PATCH 1/2] gnu: Add liblinebreak.
(address . 28100@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170815184709.18690-1-dannym@scratchpost.org
* gnu/packages/ebook.scm (liblinebreak): New variable.
---
gnu/packages/ebook.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 32f4f3b2d..187d1ed63 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -195,3 +195,23 @@ ebooks for convenient reading.")
license:public-domain
license:silofl1.1
license:cc-by-sa3.0))))
+
+(define-public liblinebreak
+ (package
+ (name "liblinebreak")
+ (version "2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/vimgadgets"
+ "/liblinebreak/" version
+ "/liblinebreak-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f36dbq7nc77lln1by2n1yl050g9dc63viawhs3gc3169mavm36x"))))
+ (build-system gnu-build-system)
+ (home-page "http://vimgadgets.sourceforge.net/liblinebreak/")
+ (synopsis "Library for detecting where linebreaks are allowed in text")
+ (description "@code{liblinebreak} is a library that can be used to detect
+where linebreaks are allowed in a given text.")
+ (license license:zlib)))
D
D
Danny Milosavljevic wrote on 15 Aug 2017 20:47
[PATCH 2/2] gnu: Add fbreader.
(address . 28100@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170815184709.18690-2-dannym@scratchpost.org
* gnu/packages/ebook.scm (fbreader): New variable.
---
gnu/packages/ebook.scm | 47 +++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 187d1ed63..bca91ecb7 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -28,10 +28,14 @@
#:use-module (gnu packages)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages fribidi)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
#:use-module (gnu packages glib)
#:use-module (gnu packages icu4c)
@@ -44,6 +48,7 @@
#:use-module (gnu packages serialization)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
(define-public chmlib
@@ -215,3 +220,45 @@ ebooks for convenient reading.")
(description "@code{liblinebreak} is a library that can be used to detect
where linebreaks are allowed in a given text.")
(license license:zlib)))
+
+(define-public fbreader
+ (package
+ (name "fbreader")
+ (version "0.99.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/geometer/FBReader/"
+ "archive/" version "-freebsdport.tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gf1nl562fqkwlzcn6rgkp1j8jcixzmfsnwxbc0sm49zh8n3zqib"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("expat" ,expat)
+ ("fribidi" ,fribidi)
+ ("glib" ,glib)
+ ("gtk+-2" ,gtk+-2)
+ ("libjpeg" ,libjpeg)
+ ("liblinebreak" ,liblinebreak)
+ ("libxft" ,libxft)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f ; No tests exist.
+ #:make-flags `("CC=gcc" "TARGET_ARCH=desktop" "UI_TYPE=gtk"
+ "TARGET_STATUS=release"
+ ,(string-append "INSTALLDIR="
+ (assoc-ref %outputs "out"))
+ ,(string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://fbreader.org/")
+ (synopsis "E-Book reader")
+ (description "@code{fbreader} is an E-Book reader.")
+ (license license:gpl2+)))
R
R
Ricardo Wurmus wrote on 16 Aug 2017 11:00
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28100@debbugs.gnu.org)
87wp63khv0.fsf@elephly.net
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (2 lines)
> * gnu/packages/ebook.scm (fbreader): New variable.
> ---
[…]
Toggle quote (3 lines)
> + (synopsis "E-Book reader")
> + (description "@code{fbreader} is an E-Book reader.")

Could you expound a bit? You could mention, for example, what kind of
formats it supports. Other than that the patch is fine.

Thank you!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 16 Aug 2017 11:03
Re: [bug#28100] [PATCH 1/2] gnu: Add liblinebreak.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 28100@debbugs.gnu.org)
87valnkhoi.fsf@elephly.net
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (25 lines)
> * gnu/packages/ebook.scm (liblinebreak): New variable.
> ---
> gnu/packages/ebook.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
> index 32f4f3b2d..187d1ed63 100644
> --- a/gnu/packages/ebook.scm
> +++ b/gnu/packages/ebook.scm
> @@ -195,3 +195,23 @@ ebooks for convenient reading.")
> license:public-domain
> license:silofl1.1
> license:cc-by-sa3.0))))
> +
> +(define-public liblinebreak
> + (package
> + (name "liblinebreak")
> + (version "2.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "mirror://sourceforge/vimgadgets"
> + "/liblinebreak/" version
> + "/liblinebreak-" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))

this “file-name” field is not necessary. The tarball is already
properly named.

Toggle quote (9 lines)
> + (sha256
> + (base32
> + "1f36dbq7nc77lln1by2n1yl050g9dc63viawhs3gc3169mavm36x"))))
> + (build-system gnu-build-system)
> + (home-page "http://vimgadgets.sourceforge.net/liblinebreak/")
> + (synopsis "Library for detecting where linebreaks are allowed in text")
> + (description "@code{liblinebreak} is a library that can be used to detect
> +where linebreaks are allowed in a given text.")

“allowed” is a bit vague. The description on the website is better, in
my opinion:

Liblinebreak is an implementation of the line breaking algorithm as
described in Unicode 6.0.0 Standard Annex 14, Revision 26. It breaks
lines that contain Unicode characters. It is designed to be used in a
generic text renderer.

Could you use that instead?

It’s good with these changes.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
D
D
Danny Milosavljevic wrote on 17 Aug 2017 02:01
(no subject)
(address . control@debbugs.gnu.org)
20170817020133.0b825cbb@scratchpost.org
close 28100
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28100@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28100
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch