[PATCH] gnu: python-pylint: Use Python2 variant system.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170811184949.11693-1-dannym@scratchpost.org
* gnu/packages/python.scm (python-pylint): Use Python2 variant system.
(python2-pylint): Strip Python2 variant system.
---
gnu/packages/python.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 731fee633..13e1ce5bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14322,10 +14322,12 @@ Pylint has many rules enabled by default, way too much to silence them
all on a minimally sized program. It's highly configurable and handle
pragmas to control it from within your code. Additionally, it is
possible to write plugins to add your own checks.")
+ (properties `((python2-variant . ,(delay python2-pylint))))
(license license:gpl2+)))
(define-public python2-pylint
- (let ((pylint (package-with-python2 python-pylint)))
+ (let ((pylint (package-with-python2
+ (strip-python2-variant python-pylint))))
(package (inherit pylint)
(propagated-inputs
`(("python2-backports-functools-lru-cache"
Marius Bakke wrote 8 years ago
87mv752dbo.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (3 lines)
> * gnu/packages/python.scm (python-pylint): Use Python2 variant system.
> (python2-pylint): Strip Python2 variant system.

Good catch, LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlmO8QsACgkQoqBt8qM6
VPrzoggArd/DXilCB6LopPBdpiaB9gcje6h+mE8YER11zKRfZGusF9oMU3BiGKKy
ssBvH3OLfqv4VpWayHF9Rpt51Nh0OvlmF0Jd5v1qgdLdPcxBpJeUKBok/RSA/RMK
9/wS58eLRCFNp+U/DYJBhhGRceVmHibWycmH2qbL6AsxK7lBuDEOZli+VFIEA4mB
lEI4xUcKLdGdZNmXcomMmpUTU6tdUIIZu/n90z6ar35wH2QwLibKeBBHlYIPLUFI
3o8I0HpXC1RR4+2QnhPPydZznC+kNKTkZusuZaaOuC90gV42r/eoyMpGxBQswxoD
Go/129VP0ct9mffztJDsBvweqRaCMg==
=3QYt
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170812163047.7ef67f26@scratchpost.org
close 28052
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28052@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28052
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help