[PATCH] gnu: Add dssi.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170811000442.21345-1-dannym@scratchpost.org
* gnu/packages/music.scm (dssi): New variable.
---
gnu/packages/music.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 40996b11b..10a93a940 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3170,3 +3170,35 @@ MuseScore can also play back scores through the built-in sequencer and SoundFont
sample library.")
(home-page "https://musescore.org")
(license license:gpl2)))
+
+(define-public dssi
+ (package
+ (name "dssi")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/dssi/dssi/" version
+ "/dssi-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kl1hzhb7cykzkrqcqgq1dk4xcgrcxv0jja251aq4z4l783jpj7j"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack-2" ,jack-2)
+ ("ladspa" ,ladspa)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("liblo" ,liblo)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Audio plugin API for soft synths and effects")
+ (description "DSSI is a plugin API for software instruments with user
+interfaces, permitting them to be hosted in-process by audio applications.
+It is intended to be simple, GUI-toolkit-agnostic, and slightly biased
+towards familiarity with MIDI. The DSSI distribution package contains
+a JACK/ALSA-sequencer reference host and some plugins as well as the
+specification and header.")
+ (home-page "http://dssi.sourceforge.net/")
+ (license license:gpl2+))) ; and lgpl-2.1+
Marius Bakke wrote 8 years ago
87a8301y7f.fsf@fastmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (2 lines)
> * gnu/packages/music.scm (dssi): New variable.

[...]

Toggle quote (4 lines)
> + (description "DSSI is a plugin API for software instruments with user
> +interfaces, permitting them to be hosted in-process by audio applications.
> +It is intended to be simple, GUI-toolkit-agnostic, and slightly biased
> +towards familiarity with MIDI. The DSSI distribution package contains
^^^
missing space

Toggle quote (5 lines)
> +a JACK/ALSA-sequencer reference host and some plugins as well as the
> +specification and header.")
> + (home-page "http://dssi.sourceforge.net/")
> + (license license:gpl2+))) ; and lgpl-2.1+

Can you be a little more verbose? I'm guessing some parts are LGPL2.1+,
but interface with the stricter GPL2+, so the result is effectively the
latter?

The rest LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlmTPZQACgkQoqBt8qM6
VPruPQgA0UeksptZxWaZcBEb68J/BPskWCk/P8f/zKKpOhmGJSOkvNW/nlKzI+uk
afnNIZ+WKaJnGtyPvT/1eumfSANqo7a085ofcikDM+0DQzighqLRSUxwh7GV6BtI
Bv+9Nx4yJteGPDTtPyr7rQSDaxv6oTDCEx3Q+kE3j5N4mLFyuRYVhef0PzdARvIQ
AM3WVcFSRiIqxF7BVMD9SLDTrmFRjaILTh92zg7DuGuUBytRBs+WGrcb5HDnn1ER
ZbGiWD8564lYzJfSHWR9B+ro3QO64GBx4wsSdp1tKep98qn1cH3rb7DKjQVcD9v+
X2dUnl1jautsVkkso95n6FKoN8WMjA==
=c6qJ
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170815205830.595cbbd8@scratchpost.org
close 28041
?
Your comment

This issue is archived.

To comment on this conversation send an email to 28041@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 28041
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help