(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
texinfo is required for the built-in documentation.
* gnu/packages/maths.scm (octave)[inputs]: Add texinfo.
[native-inputs]: Remove texinfo.
---
gnu/packages/maths.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (31 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e19c8edc8..44de8a4e6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1026,7 +1026,7 @@ can solve two kinds of problems:
(license license:bsd-3)))
;; For a fully featured Octave, users are strongly recommended also to install
-;; the following packages: texinfo, less, ghostscript, gnuplot.
+;; the following packages: less, ghostscript, gnuplot.
(define-public octave
(package
(name "octave")
@@ -1058,6 +1058,7 @@ can solve two kinds of problems:
("glu" ,glu)
("zlib" ,zlib)
("curl" ,curl)
+ ("texinfo" ,texinfo)
("graphicsmagick" ,graphicsmagick)))
(native-inputs
`(("lzip" ,lzip)
@@ -1072,7 +1073,6 @@ can solve two kinds of problems:
;; will still run without them, albeit without the features they
;; provide.
("less" ,less)
- ("texinfo" ,texinfo)
("ghostscript" ,ghostscript)
("gnuplot" ,gnuplot)))
(arguments
--
2.13.4