[PATCH] gnu: Add tklib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170803065443.19330-1-dannym@scratchpost.org
* gnu/packages/tcl.scm (tklib): New variable.
---
gnu/packages/tcl.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index de888891c..67e04f7dd 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -247,6 +247,51 @@ interfaces (GUIs) in the Tcl language.")
utility functions and modules all written in high-level Tcl.")
(license (package-license tcl))))
+(define-public tklib
+ (package
+ (name "tklib")
+ (version "0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://core.tcl.tk/tklib/tarball/tklib-"
+ version ".tar.gz?uuid=tklib-0-6"))
+ (sha256
+ (base32
+ "03y0bzgwbh7nnyqkh8n00bbkq2fyblq39s3bdb6mawna0bbn0wwg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("tcl" ,tcl)))
+ (propagated-inputs
+ `(("tcllib" ,tcllib)
+ ("tk" ,tk))) ; for "wish"
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TCLLIBPATH")
+ (separator " ")
+ (files (list (string-append "lib/tklib" version))))))
+ (home-page "https://www.tcl.tk/software/tklib/")
+ (synopsis "Tk utility modules for Tcl")
+ (description "Tklib is a collection of common utility functions and
+modules for Tk, all written in high-level Tcl. Examples of provided widgets:
+@enumerate
+@item @code{chatwidget}
+@item @code{datefield}
+@item @code{tooltip
+@item @code{cursor}
+@item @code{ipentry}
+@item @code{tablelist}
+@item @code{history}
+@item @code{tkpiechart}
+@item @code{ico}
+@item @code{crosshair}
+@item @code{ntext}
+@item @code{plotchart}
+@item @code{ctext}
+@item @code{autosscroll}
+@item @code{canvas}
+#end enumerate")
+ (license (package-license tcl))))
+
(define-public tclxml
(package
(name "tclxml")
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27928@debbugs.gnu.org)
87378238mn.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/tcl.scm (tklib): New variable.

LGTM! Thanks, and sorry for the delay!

Ludo'.
Ludovic Courtès wrote 7 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27928@debbugs.gnu.org)
87a81h26vy.fsf@gnu.org
Ping! :-)

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (7 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> * gnu/packages/tcl.scm (tklib): New variable.
>
> LGTM! Thanks, and sorry for the delay!
>
> Ludo'.
Danny Milosavljevic wrote 7 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170926195447.7cb35526@scratchpost.org
close 27928
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27928@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27928
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help