[PATCH] gnu: qemu: Build with support for Linux AIO

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170727175247.25897-1-mail@cbaines.net
Add libaio as an input, such that QEMU is built with support for Asynchronous
I/O (AIO).

* gnu/packages/virtualization.scm (qemu)[inputs]: Uncomment libaio.
---
gnu/packages/virtualization.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index d999d16e3..0ac76a72d 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -145,7 +145,7 @@
`(("alsa-lib" ,alsa-lib)
("attr" ,attr)
("glib" ,glib)
- ;; ("libaio" ,libaio)
+ ("libaio" ,libaio)
("libattr" ,attr)
("libcap" ,libcap) ; virtfs support requires libcap & libattr
("libjpeg" ,libjpeg-8)
--
2.13.3
Leo Famulari wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 27854@debbugs.gnu.org)
20170727202706.GA27574@jasmine.lan
On Thu, Jul 27, 2017 at 06:52:47PM +0100, Christopher Baines wrote:
Toggle quote (3 lines)
> Add libaio as an input, such that QEMU is built with support for Asynchronous
> I/O (AIO).

Assuming this new QEMU can still boot the 0.13.0 VM image, LGTM!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAll6TJoACgkQJkb6MLrK
fwj1gxAAmmBw8C9IdJ5FIoVZrd2Qab9YbifE4uXhKj+k3TkqwEt5c7i3YJ/p3O4M
WM4Mx5l8bLPhQKQbLtw5KT79DTh51gxL0U1tbyzRgr/d9pO4FL7/kGpA04Cp2Vgj
pAmnjJw7bZmkbyhJCaUTg9WOuSzZv8UGbfQXENUf+ePQluTZwLwRJAp1zPnKyGwh
oE2JFJPSO/UuDP6f4ypnRFbKvycyWGvpzvZBVefwa68LlLmH9TgpGmcmwUQh9NCK
9XJ8dd1kKhR8bCvZAKU4tA8j4xxN+fp7pseo3hHjkU6igvaZQ3tTQdnxMhELL4AN
/biQxGyG7Qn0x0rSmppd+HuOVyrW8cKQ+jnDR18PlF/c4i5FaDdglgklvUj09HBN
imdZs9Qi0w2STBSmbtkYTKUuDWM42udiRKls6ErDGZHRtTwAlQw9zGhqyNWxY+YQ
e5AgVp1+grS94U+fWdkzfdzkWab55GN5YoE+8s2JpzD6/zyaiL6bdupettGkHoHy
CqOVb0wovK+lj3+QE2rlfWomAu/mE96LYc6j5WtUCBAc2hJwYF3zBNHb3RYnmx1a
yrJkO9sGt9Mcli8RhS6txQ/KOUEcmcticuyUAR72EDmz7QF9DOFkSqGiIFVncGUM
/zKM7ECuzEsCQ3s3T3rjgSU4Dkxl+s/E0Ia1fnkns0yH+tSlG74=
=Y4Xz
-----END PGP SIGNATURE-----


Christopher Baines wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 27854-done@debbugs.gnu.org)
20170730095646.23752dba@cbaines.net
On Thu, 27 Jul 2017 16:27:06 -0400
Leo Famulari <leo@famulari.name> wrote:

Toggle quote (6 lines)
> On Thu, Jul 27, 2017 at 06:52:47PM +0100, Christopher Baines wrote:
> > Add libaio as an input, such that QEMU is built with support for
> > Asynchronous I/O (AIO).
>
> Assuming this new QEMU can still boot the 0.13.0 VM image, LGTM!

Yep, it works for me. Pushed!
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAll9n05fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xcbpw/+ItJPKIS27SrS/UEt0xMS4747ppD/wI/6wvasOEAy6iO6EdHPPcTv9rbQ
Rot9tck02551OJMbB9U+ZHnLfykwmO//TDrHmVOayQZ8KLuw6eRvVLbt2WiQPZn7
4lXYdyBK95WVuNFCpGTEH6lEA9SY99Q0v3VajF3KJeVyy/7yXJhPFKYIxDxq60Bx
VkJg6rCzrPQctUDfZQKV+bmywWoxtZaSRXYMJP72ByPjqPacDhg4msARTppqGyFJ
0+FIrKwtl0x9hRxnTgenMbbT7d4vww48D66HS+YIBnTPRXHIYueAGCf8VHocyBnx
E6U4paTu/STyl9G+zQkWN2G/xpdhCM7+dDJAYb4KuNb9CfsuuuMqYsBlWvyviIlS
GeNOOIRi+jrA6vuHWNe3yjzAfZtlL9HCCID/IctDI6/f1JO6LGPnKwBeap4O3JkE
MMUrM2DujRvRz6haPJ0wJ6fhl0CMZ80ZuHQbXkXtR7cabqMREVkoeuv2XNLO9yqe
uH/eX+h/KNZfw3SiGsO0GrC9yqQRIwypREpg2RqDR9bksTyA8xs86gxcIVrdxh/n
3bv01ttHQF3YBALxC1WuoQOVRyJJzRvPkd3L4ssHMtZN+NLxPivz7esJisaAWrpC
NnyHiW0FdzRxpyCGWpRgJDHAsJcX/O6eG5MZe9S5NGBUJhWxNfs=
=26sc
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27854@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27854
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help