[PATCH] gnu: python2-urwid: Actually build urwid for Python 2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170725185016.21695-1-kei@openmailbox.org
* gnu/packages/python.scm (python2-urwid)[arguments]: Add #:python.
---
gnu/packages/python.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 89c2de63b..03f813411 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5871,7 +5871,11 @@ features useful for text console applications.")
(inherit python2-urwid)
(arguments
(append
- '(#:phases
+ `(;; Explicitly using Python 2 is necessary due the argument list being
+ ;; built from only the 'delete-test_vterm.py' phase and python-urwid's
+ ;; package arguments, which by default assumes the use of Python 3.
+ #:python ,python-2
+ #:phases
(modify-phases %standard-phases
;; Disable the vterm tests because of non-deterministic failures
;; with Python 2. See https://github.com/urwid/urwid/issues/230.
--
2.13.3
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27827@debbugs.gnu.org)
20170725192158.GA7295@jasmine.lan
On Tue, Jul 25, 2017 at 02:50:16PM -0400, Kei Kebreau wrote:
Toggle quote (2 lines)
> * gnu/packages/python.scm (python2-urwid)[arguments]: Add #:python.

Good catch! I didn't test this change with `guix gc --references`, but
if that shows the right thing your end, please push!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAll3mlMACgkQJkb6MLrK
fwi2BxAAmEzv/GX01Z7doCYic1HY8NxowVQ6ykkLcTDE7V/hMYe/zf8T40s2viAc
/DHbUuDJbzVJm71UB5DtOpjB7W7po7xus8MeaUCv0YtnXESj5jmLPaYvya4XpAcQ
aHt10KjIU244txmGRcshM7T/Xtnlr+gbUE7Z2zySAAB0VvZGW/vMDu8gzifE/bKZ
MWEGpFZpCq+vyKINYLbviOUB+km+TNMnBnq0vHmQf2SpsLOAZZUlUSOPdOu/ErnL
ZzZPN05boPYM72JfT/lTj6TKbQ99PLFjtgbim71X1wqaNo5COw2EwlYsNLtFUghE
508jea/OjEZaamkOTCi9bRSa/2HC1YUzwRng1xdNCgyrVHHzFBfLE7HGy0JcJWOL
u09Ve2zjVwx5rIpozNZyxWfJ/Ib7hZRvXt19YnfxBiFVbfYx95Vv7EzUHy61vEi7
NvWg9AHSL/U5VmBmXrh3/3phu9vmxfRzT+++mbRhzfHCZQrIsnVPRQgasB0XZpcL
cUY1Rf9/28w3vjF4BHC+VTdTotKz5dm2N7ctiFGfeAqNGqzc6bppS87Tt7+anRGc
Bf8e/0Q1/ZPNZGME+X/jM9P0+3Zii9Ees+07BQPUWGQWvvu/QOMXt7IHkK5ZNZfF
r300GZRJxPAuWAwAkYpipFecPRoVWSzpZdNL3MMGFQs1rDvZXrc=
=9Q2k
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 27827-done@debbugs.gnu.org)
87h8y05n6c.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (6 lines)
> On Tue, Jul 25, 2017 at 02:50:16PM -0400, Kei Kebreau wrote:
>> * gnu/packages/python.scm (python2-urwid)[arguments]: Add #:python.
>
> Good catch! I didn't test this change with `guix gc --references`, but
> if that shows the right thing your end, please push!

Yes, python2-urwid shows up now. Prior to the patch it did not.

Pushed to master! Thanks again for the review.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAll3nGsACgkQ5qXuPBlG
eg2ixA/+IY++S6pYKGoTk6Z3L0Xa4LLTgG0rVjFy6lvG0wzGkNp6A1N0HB+CBJD/
Trm2UwXeaqJo7liXfg+iLwhag/Lw+PtmN2tFo3irYNKGRi522CB8isd7JXKDT678
X9AkS0bM2ikEHUFXNdhLVer96TFkZobYUdr1htxfMndyp3XPVIjBiJU2scUSVtDR
H5X/54mOo/utP4jm6lX8Q5bs291lfo4qn/USzh2NX79M4j9Epd+r0Cv3vj9zMDfM
hZ48dQqSkSlOe6tyhh9EQPsZh2lqAWbCz5f5FZ5JPIxQVYXOi/Js1AhnmEL/3JpI
LzXo2qLVpPqRBNTXj/JHW5fJCE5+N569vvl+XBwBikLv5zvFDkk+f0/XLX5zPdBv
EqCDETqW+7r4CkCQDBBXN00EpwyOSrR4xdDRet8uk7stmAGEJ/oWncTlAl1L9r0q
M5wA6SUrhBcnJVS6eqn5+qcGjAFwb142mS8mJFcVjjPZRRKkpQxqAXJYLmsiGeai
aec8a50n/NJ7z+VCU7V+xEynhMhr41waVPSEe0iXZsZ+HkBEUSdarb5dROz8iFtv
8qJcbQjIgCJ0g6F0yhFqs4ozDlFt56hwmASiDc8T3JUJl0srQSeR/uOhO5ZMU8Ga
Ppq/eXqs5OGLXjDJlr2zSrHE4cLCv06LXX2ddky+QLzG3dplXb8=
=9xVa
-----END PGP SIGNATURE-----

Closed
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27827-done@debbugs.gnu.org)
20170725194250.GA28267@jasmine.lan
On Tue, Jul 25, 2017 at 03:30:51PM -0400, Kei Kebreau wrote:
Toggle quote (12 lines)
> Leo Famulari <leo@famulari.name> writes:
>
> > On Tue, Jul 25, 2017 at 02:50:16PM -0400, Kei Kebreau wrote:
> >> * gnu/packages/python.scm (python2-urwid)[arguments]: Add #:python.
> >
> > Good catch! I didn't test this change with `guix gc --references`, but
> > if that shows the right thing your end, please push!
>
> Yes, python2-urwid shows up now. Prior to the patch it did not.
>
> Pushed to master! Thanks again for the review.

I just tested it, and it fails to build for me. But, I've noticed the
urwid test suite is pretty flaky. Let's see if it builds on Hydra.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAll3nzoACgkQJkb6MLrK
fwh8BA//UBvAthGiQIcuBeRwPAR54cznCTiZ5G1XayMTYbdwUG7W1xV5RHvOGFrB
+tSiWC/y431P9VkHGmadVw2N6LkdxXbQVDXr/c6JoHVEiDsV2XvXJnhhKGgWZsOx
V6osuKSWmLx8f9vq6PR+AFOq6/BXA2sbbEDqY4LA7A9v53RDceZi9GmI5JUNe331
sK2O7n3tKnMbrHZ5wEoAxzV47u2nLfDT9CLAdUIJ74rwy/hRj2nHuPiQRlhQtLQ8
ZgC1gVYvYb78X3PoQFe5cqLxMnWKajLu+N1VPDEHNFhxNGOaOuaQGe9/L/B9nJH6
o6G5LUTPXRhdvloUz6o7hqwEajaMeuqxaLYO7e3HDIPf1Vp5otlEUmhSTCAaTWFn
J5/nKxhcoiqrh3YgCCDVMCKgUXURyQOAeyvzcDbyWHMeYiz8X/zWXMzLEQlDPEs3
z200PCyylZo/VN/JjeEwO+fwka0lBRyWa0XU6Dva3JlZ8rxIFVRIWvDpyylOV3E1
yVcrbTfkEvp4/sIwNAxF2+vFNGIKZAQ2TnB9W8DuS2AsYu5HSjQUrihvYbCwFeWZ
73wiS/Tdsyhfj7E0Dnx42GBqtfYGTTunAe9SCcubKpBoHm5ntgF9uKpUzPebIOnJ
KTNICE1hv3R/bjSesco75lyWPQ404r8Gz2jwA92WS3vJ9avvXok=
=m2Xv
-----END PGP SIGNATURE-----


Closed
Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 27827-done@debbugs.gnu.org)
87bmnx4s2m.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (16 lines)
> On Tue, Jul 25, 2017 at 03:30:51PM -0400, Kei Kebreau wrote:
>> Leo Famulari <leo@famulari.name> writes:
>>
>> > On Tue, Jul 25, 2017 at 02:50:16PM -0400, Kei Kebreau wrote:
>> >> * gnu/packages/python.scm (python2-urwid)[arguments]: Add #:python.
>> >
>> > Good catch! I didn't test this change with `guix gc --references`, but
>> > if that shows the right thing your end, please push!
>>
>> Yes, python2-urwid shows up now. Prior to the patch it did not.
>>
>> Pushed to master! Thanks again for the review.
>
> I just tested it, and it fails to build for me. But, I've noticed the
> urwid test suite is pretty flaky. Let's see if it builds on Hydra.

I've since updated my system and wicd-curses still works. Does it build
on Hydra? I haven't been able to check because of 504 HTTP response
codes from https://hydra.gnu.orgmost of the time.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlmCOeIACgkQ5qXuPBlG
eg3YsQ//emMsjsX1aADUCXcYBLNgdpBA9yZCrzZiwb2FPlPJV1EzhNJMSZgCoEmE
+ZEYow/qjBVixoHxdqDghytAci4oaTo30cxLTZVcvqIHeW4L+/X67LQ1nuhfy4R3
OQzr5HchFU1PiZX+PVlUZdswjMHV1KyjJWg5EcCp8oYqsWmptLyUyqEv42L1tVT2
WlEqYgeg+CbUF9KNXJAAbzBMnscNwdATMidsjcuiYXtBc8mgv28SHyldUFvhNiTc
xtTs5Bzb4CPhg8JC0AAzYfQOT4eIbJEJyL5mt6UzRGQOUjZCUVrdBgH771Qmfjkk
qjppeFgHv+qDGjcMHde8sxDtAr7SaoTFc7OQ4yVYxIobmuSqffJR5IHR5ow3n8+H
wOrr2FE/EBgogkMq1FyK7RtBHnKIjW0H98MT1HLkBBJZ0j1hCVAplVGkcnB6R/B1
ulte0Q1ipkyBZGsc3yih4OfSh6iDNwIviYr64MWmn2DiDBLpcz4JMjA4aG5kfovj
pJYhRtHAdkKLL2oaYvkaaB+pA1YFpkngOi/0QNe9qVjxeSTrzPwkUeGsHHCZl4PV
iiBWokCd+7QKyhWBxzzSqzJWlRCoS/ub/v/WXFI3a2qfksKQ/BQnv9h8kQ2RTDnV
dwCbTdHnRPigVcxVchN0LojCdBUnXWbNNVlrQbLIU9ptmW182BE=
=h9gX
-----END PGP SIGNATURE-----

Closed
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27827-done@debbugs.gnu.org)
20170802224745.GD14798@jasmine.lan
On Wed, Aug 02, 2017 at 04:45:21PM -0400, Kei Kebreau wrote:
Toggle quote (8 lines)
> Leo Famulari <leo@famulari.name> writes:
> > I just tested it, and it fails to build for me. But, I've noticed the
> > urwid test suite is pretty flaky. Let's see if it builds on Hydra.
>
> I've since updated my system and wicd-curses still works. Does it build
> on Hydra? I haven't been able to check because of 504 HTTP response
> codes from https://hydra.gnu.org most of the time.

I just got a substitute for it, so it must have worked :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlmCVpEACgkQJkb6MLrK
fwj7JBAA3Y6nJ8tOgkji1j9e1xo8OrUXRTLNVqqE5rKzo0tiRmq7UYI8b4drCgvk
f0v8bBMofjjx1AkJIXxEJPfVVw4/7yEdBo7PJUJ7eMNRlcP8ePNtsiVY8QJoNFFP
v6DbM5hNusoeGPL995GzAU/AMg8h/M+8nLjeO8McHajuOtF+ij6kMmC7QU+5yAqZ
KVIp8Wsq6shu+MbjTUNpUwlgidOxS2plEVJcqbRdmvUhzkc9al+hmSl1TnYhRjer
px38y8d+3hX+EQf7amDx75gFq4Ei38BdvFKlbeE40svhsIWVw4Dpr8qw/RTSl81X
RjP8RhBO9I/m1u7weOov7D6ia7B7rJ7846oENcxprt99+UT+DT7fgEFjGL7Fb9gA
lgcQZNzSNuflwOibqZxFp6iJfNl9HqlAjjR8KBV01mo7Cj913e78X6Vnlhou6TGu
e53cgJdr457Pe/kJsDJxe4S5NND4cgeql7LPnlwEWquWWbx3yveEzaaWDZlkGWsg
ASxWbOmFNKyDXFb8r0UMkCBekS3umU5YZn0zFgBHzAH1HVDBXU2ExfcSVGqAqn9F
cIfzMSUarc8xtcEfLud+L9E0q59BC/vfVx8N3jnhBUbnS+/r9itiM6jAOYhVYSvO
3+wSkt9w/b9wY19LgZuFDvfb7fGUg3ipYkECoHm2jm5SjzziZQ8=
=V9H8
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27827@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27827
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help