[PATCH 0/2] Remove let-alist and emacs-seq.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Kost
  • Kyle Meyer
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170724234100.10486-1-kyle@kyleam.com
These packages were added when the current Emacs version was 24.5. As
of 25.1, both packages are now included with Emacs.

--
2.13.3
Kyle Meyer wrote 8 years ago
[PATCH 1/2] gnu: Remove let-alist.
(address . 27812@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170724234424.10650-1-kyle@kyleam.com
The let-alist package has been included with Emacs since version 25.1.

* gnu/packages/emacs.scm (let-alist): Remove variable.
(flycheck, emacs-pdf-tools, emacs-sx)[propagated-inputs]: Remove let-alist.
---
gnu/packages/emacs.scm | 30 +-----------------------------
1 file changed, 1 insertion(+), 29 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 43de13057..45cf6aec6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -641,30 +641,6 @@ process, passing on the arguments as command line arguments.")
programs.")
(license license:gpl3+)))
-(define-public let-alist
- (package
- (name "emacs-let-alist")
- (version "1.0.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/let-alist-"
- version ".el"))
- (sha256
- (base32
- "07312bvvyz86lf64vdkxg2l1wgfjl25ljdjwlf1bdzj01c4hm88x"))))
- (build-system emacs-build-system)
- (home-page "https://elpa.gnu.org/packages/let-alist.html")
- (synopsis "Easily let-bind values of an assoc-list by their names")
- (description
- "This package offers a single Emacs Lisp macro, @code{let-alist}. This
-macro takes a first argument, whose value must be an alist (association list),
-and a body.
-
-The macro expands to a let form containing the body, where each dotted symbol
-inside body is let-bound to their cdrs in the alist. Only those present in
-the body are let-bound and this search is done at compile time.")
- (license license:gpl3+)))
-
(define-public flycheck
(package
(name "emacs-flycheck")
@@ -680,7 +656,6 @@ the body are let-bound and this search is done at compile time.")
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-dash" ,emacs-dash)
- ("emacs-let-alist" ,let-alist)
("emacs-seq" ,emacs-seq)))
(home-page "https://www.flycheck.org")
(synopsis "On-the-fly syntax checking")
@@ -1326,8 +1301,6 @@ single buffer.")
("automake" ,automake)
("pkg-config" ,pkg-config)
("emacs" ,emacs-minimal)))
- (propagated-inputs
- `(("let-alist" ,let-alist)))
(inputs `(("poppler" ,poppler)
("cairo" ,cairo)
("glib" ,glib)
@@ -1579,8 +1552,7 @@ strings.")
"1w0xghfljqg31axcnv8gzlrd8pw25nji6idnrhflq0af9qh1dw03"))))
(build-system emacs-build-system)
(propagated-inputs
- `(("emacs-markdown-mode" ,emacs-markdown-mode)
- ("let-alist" ,let-alist)))
+ `(("emacs-markdown-mode" ,emacs-markdown-mode)))
(home-page "https://github.com/vermiculus/sx.el/")
(synopsis "Emacs StackExchange client")
(description
--
2.13.3
Kyle Meyer wrote 8 years ago
[PATCH 2/2] gnu: Remove emacs-seq.
(address . 27812@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20170724234424.10650-2-kyle@kyleam.com
The seq.el library has been included with Emacs since version 25.1.

* gnu/packages/emacs.scm (emacs-seq): Remove variable.
(flycheck, emacs-cider)[propagated-inputs]: Remove emacs-seq.
---
gnu/packages/emacs.scm | 26 ++------------------------
1 file changed, 2 insertions(+), 24 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 45cf6aec6..93d005cb5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -655,8 +655,7 @@ programs.")
"1rxzkaqsj48z3nska5wsgwafvwkam014dzqd32baycmxjl0jxvy7"))))
(build-system emacs-build-system)
(propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-seq" ,emacs-seq)))
+ `(("emacs-dash" ,emacs-dash)))
(home-page "https://www.flycheck.org")
(synopsis "On-the-fly syntax checking")
(description
@@ -3007,26 +3006,6 @@ be removed from the front. This type of data structure is sometimes called an
ongoing operations.")
(license license:gpl3+)))
-(define-public emacs-seq
- (package
- (name "emacs-seq")
- (version "2.19")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/seq-"
- version ".tar"))
- (sha256
- (base32
- "11hb7is6a4h1lscjcfrzh576j0g3m5yjydn16s6x5bxp5gsr6zha"))))
- (build-system emacs-build-system)
- (home-page "https://elpa.gnu.org/packages/seq.html")
- (synopsis "Sequence manipulation functions for Emacs")
- (description
- "This Emacs library provides sequence-manipulation functions that
-complement basic functions provided by @code{subr.el}. All provided functions
-work on lists, strings and vectors.")
- (license license:gpl3+)))
-
(define-public emacs-sparql-mode
(package
(name "emacs-sparql-mode")
@@ -3530,8 +3509,7 @@ for search-based navigation of buffers.")
`(("emacs-clojure-mode" ,emacs-clojure-mode)
("emacs-spinner" ,emacs-spinner)
("emacs-pkg-info" ,emacs-pkg-info)
- ("emacs-queue" ,emacs-queue)
- ("emacs-seq" ,emacs-seq)))
+ ("emacs-queue" ,emacs-queue)))
(home-page "https://cider.readthedocs.org/")
(synopsis "Clojure development environment for Emacs")
(description
--
2.13.3
Alex Kost wrote 8 years ago
Re: [bug#27812] [PATCH 0/2] Remove let-alist and emacs-seq.
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 27812-done@debbugs.gnu.org)
87h8xvm1lx.fsf@gmail.com
Kyle Meyer (2017-07-24 19:41 -0400) wrote:

Toggle quote (3 lines)
> These packages were added when the current Emacs version was 24.5. As
> of 25.1, both packages are now included with Emacs.

Oh, indeed; applied, thanks!

--
Alex
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27812@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27812
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help