[PATCH] gnu: perl-dbd-mysql: Fix CVE-2017-10788.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170724183144.18241-1-kei@openmailbox.org
* gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/databases.scm (perl-dbd-mysql)[source]: Use it.
---
gnu/local.mk | 1 +
gnu/packages/databases.scm | 3 +-
.../patches/perl-dbd-mysql-CVE-2017-10788.patch | 51 ++++++++++++++++++++++
3 files changed, 54 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch

Toggle diff (85 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 3eccc879b..4292d705c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -902,6 +902,7 @@ dist_patch_DATA = \
%D%/packages/patches/pcre2-CVE-2017-8786.patch \
%D%/packages/patches/perl-file-path-CVE-2017-6512.patch \
%D%/packages/patches/perl-autosplit-default-time.patch \
+ %D%/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch \
%D%/packages/patches/perl-deterministic-ordering.patch \
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
%D%/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch \
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ee340505e..7e62452ea 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1015,7 +1015,8 @@ columns, primary keys, unique constraints and relationships.")
"DBD-mysql-" version ".tar.gz"))
(sha256
(base32
- "16bg7l28n65ngi1abjxvwk906a80i2vd5vzjn812dx8phdg8d7v2"))))
+ "16bg7l28n65ngi1abjxvwk906a80i2vd5vzjn812dx8phdg8d7v2"))
+ (patches (search-patches "perl-dbd-mysql-CVE-2017-10788.patch"))))
(build-system perl-build-system)
;; Tests require running MySQL server
(arguments `(#:tests? #f))
diff --git a/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
new file mode 100644
index 000000000..344f2d803
--- /dev/null
+++ b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
@@ -0,0 +1,51 @@
+From 9ce10cfae7138c37c3a0cb2ba2a1d682482943d0 Mon Sep 17 00:00:00 2001
+From: Pali <pali@cpan.org>
+Date: Sun, 25 Jun 2017 10:07:39 +0200
+Subject: [PATCH] Fix use-after-free after calling mysql_stmt_close()
+
+Ignore return value from mysql_stmt_close() and also its error message
+because it points to freed memory after mysql_stmt_close() was called.
+---
+ dbdimp.c | 8 ++------
+ mysql.xs | 7 ++-----
+ 2 files changed, 4 insertions(+), 11 deletions(-)
+
+diff --git a/dbdimp.c b/dbdimp.c
+index c60a5f6..a6410e5 100644
+--- a/dbdimp.c
++++ b/dbdimp.c
+@@ -4894,12 +4894,8 @@ void dbd_st_destroy(SV *sth, imp_sth_t *imp_sth) {
+
+ if (imp_sth->stmt)
+ {
+- if (mysql_stmt_close(imp_sth->stmt))
+- {
+- do_error(DBIc_PARENT_H(imp_sth), mysql_stmt_errno(imp_sth->stmt),
+- mysql_stmt_error(imp_sth->stmt),
+- mysql_stmt_sqlstate(imp_sth->stmt));
+- }
++ mysql_stmt_close(imp_sth->stmt);
++ imp_sth->stmt= NULL;
+ }
+ #endif
+
+diff --git a/mysql.xs b/mysql.xs
+index 55376e1..affde59 100644
+--- a/mysql.xs
++++ b/mysql.xs
+@@ -434,11 +434,8 @@ do(dbh, statement, attr=Nullsv, ...)
+ if (bind)
+ Safefree(bind);
+
+- if(mysql_stmt_close(stmt))
+- {
+- fprintf(stderr, "\n failed while closing the statement");
+- fprintf(stderr, "\n %s", mysql_stmt_error(stmt));
+- }
++ mysql_stmt_close(stmt);
++ stmt= NULL;
+
+ if (retval == -2) /* -2 means error */
+ {
+--
+1.7.9.5
--
2.13.3
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27805@debbugs.gnu.org)
20170724191745.GA26221@jasmine.lan
On Mon, Jul 24, 2017 at 02:31:44PM -0400, Kei Kebreau wrote:
Toggle quote (4 lines)
> * gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.
> * gnu/packages/databases.scm (perl-dbd-mysql)[source]: Use it.

Thanks!

Toggle quote (14 lines)
> diff --git a/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
> new file mode 100644
> index 000000000..344f2d803
> --- /dev/null
> +++ b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
> @@ -0,0 +1,51 @@
> +From 9ce10cfae7138c37c3a0cb2ba2a1d682482943d0 Mon Sep 17 00:00:00 2001
> +From: Pali <pali@cpan.org>
> +Date: Sun, 25 Jun 2017 10:07:39 +0200
> +Subject: [PATCH] Fix use-after-free after calling mysql_stmt_close()
> +
> +Ignore return value from mysql_stmt_close() and also its error message
> +because it points to freed memory after mysql_stmt_close() was called.

Can you add a link to the MITRE page for this CVE (and any other pages
you think are relevant) and to the source of this patch?

Check 'gnu/packages/patches/wget-CVE-2017-6508.patch' for an example if
you are unsure.

There is also CVE-2017-10789. I'm not sure if there is a fix merged
upstream yet:

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAll2R9kACgkQJkb6MLrK
fwgVjg//VlpskWuYx96WD5+K5QjSJZ7s9bmcGyNJEBfoWY001SLLzlgwfzjyiYug
LW4ypt6yA0Sx5Lsnk+SqVZ29gDptB0CeRST6QKa6g9uAsTrr3pIvalbcAti5IGQs
JszIkGF5q5+/Bz6ze9e167P/STpiOCRyXtZJkBTpCQ+E9wnxnekzdh8s5BwzUHBs
iZ+H688J9fgnT9X5Fqb1Co42pe56BD7M/IJaLhv8YLVnKAYUddQHHtPwowAXbFSg
LcRsRVA4leXxTQPAH2MWtfwwBOsW5qrRAj8dLqzJXo0WjZPX6T9P5HKWf02TqFYd
fyXCcJ2IOKnLX8ippfi/vYvd9a7maQgBFSm9cLv7+yf4bN6OVP4GfnuMUBrdmFU2
cHh85Qc60S0ztbVgJkVo6yBzjjGfourFkDFhlpEH8sDbBaaQoOrgwtdkfRWZKvfE
9l3cmusykcPad6yJukFFTNUh06vLgDLwbtIxg4FY1rbnwE7fsZqbm6DsKyCaMMDM
GAw0MVEWZ6qkwCyHCqYetZssYhRbVsagOcUg6AWVn7iQHjOwY2RoXG/omDAI4cLF
fB3mRL6djKi49SCcS6XOrTmAdxj8cwZ1u/KYTMicGPnNcvAG6tor/U/Vg1gSbAfc
XYv8i64ljZ4q2yej6IaJFzG4V6ObRFGuIezFzTNJYD7Ve7FhoBY=
=1nTQ
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 27805@debbugs.gnu.org)
87tw215w0y.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (27 lines)
> On Mon, Jul 24, 2017 at 02:31:44PM -0400, Kei Kebreau wrote:
>> * gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch: New file.
>> * gnu/local.mk (dist_patch_DATA): Add it.
>> * gnu/packages/databases.scm (perl-dbd-mysql)[source]: Use it.
>
> Thanks!
>
>> diff --git
>> a/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
>> b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
>> new file mode 100644
>> index 000000000..344f2d803
>> --- /dev/null
>> +++ b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
>> @@ -0,0 +1,51 @@
>> +From 9ce10cfae7138c37c3a0cb2ba2a1d682482943d0 Mon Sep 17 00:00:00 2001
>> +From: Pali <pali@cpan.org>
>> +Date: Sun, 25 Jun 2017 10:07:39 +0200
>> +Subject: [PATCH] Fix use-after-free after calling mysql_stmt_close()
>> +
>> +Ignore return value from mysql_stmt_close() and also its error message
>> +because it points to freed memory after mysql_stmt_close() was called.
>
> Can you add a link to the MITRE page for this CVE (and any other pages
> you think are relevant) and to the source of this patch?
>

Done! FYI, this patch is tentative (i.e. not merged upstream as of
yet). It seems to do the right thing, but I'm not quite sure, as I'm not
an experienced C programmer, nor am I a user of this package.

Toggle quote (8 lines)
> Check 'gnu/packages/patches/wget-CVE-2017-6508.patch' for an example if
> you are unsure.
>
> There is also CVE-2017-10789. I'm not sure if there is a fix merged
> upstream yet:
>
> http://cve.mitre.org/cgi-bin/cvename.cgi?name=2017-10789

There was a fix that was merged and later reverted in the latest
version, 4.043.

How does the attached patch look?
From d067457fcc87a0353dfdf6c8bfbe4f2bbdb90bb9 Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kei@openmailbox.org>
Date: Mon, 24 Jul 2017 13:51:50 -0400
Subject: [PATCH] gnu: perl-dbd-mysql: Fix CVE-2017-10788.

* gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/databases.scm (perl-dbd-mysql)[source]: Use it.
---
gnu/local.mk | 1 +
gnu/packages/databases.scm | 3 +-
.../patches/perl-dbd-mysql-CVE-2017-10788.patch | 62 ++++++++++++++++++++++
3 files changed, 65 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch

Toggle diff (96 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 3eccc879b..4292d705c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -902,6 +902,7 @@ dist_patch_DATA = \
%D%/packages/patches/pcre2-CVE-2017-8786.patch \
%D%/packages/patches/perl-file-path-CVE-2017-6512.patch \
%D%/packages/patches/perl-autosplit-default-time.patch \
+ %D%/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch \
%D%/packages/patches/perl-deterministic-ordering.patch \
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
%D%/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch \
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ee340505e..7e62452ea 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1015,7 +1015,8 @@ columns, primary keys, unique constraints and relationships.")
"DBD-mysql-" version ".tar.gz"))
(sha256
(base32
- "16bg7l28n65ngi1abjxvwk906a80i2vd5vzjn812dx8phdg8d7v2"))))
+ "16bg7l28n65ngi1abjxvwk906a80i2vd5vzjn812dx8phdg8d7v2"))
+ (patches (search-patches "perl-dbd-mysql-CVE-2017-10788.patch"))))
(build-system perl-build-system)
;; Tests require running MySQL server
(arguments `(#:tests? #f))
diff --git a/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
new file mode 100644
index 000000000..74613cb63
--- /dev/null
+++ b/gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch
@@ -0,0 +1,62 @@
+Fix CVE-2017-10788:
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-10788
+
+Patch written to match corrected documentation specifications:
+
+Old: http://web.archive.org/web/20161220021610/https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-close.html
+New: https://dev.mysql.com/doc/refman/5.7/en/mysql-stmt-close.html
+
+The patch itself is from https://github.com/perl5-dbi/DBD-mysql/issues/120#issuecomment-312420660.
+
+From 9ce10cfae7138c37c3a0cb2ba2a1d682482943d0 Mon Sep 17 00:00:00 2001
+From: Pali <pali@cpan.org>
+Date: Sun, 25 Jun 2017 10:07:39 +0200
+Subject: [PATCH] Fix use-after-free after calling mysql_stmt_close()
+
+Ignore return value from mysql_stmt_close() and also its error message
+because it points to freed memory after mysql_stmt_close() was called.
+---
+ dbdimp.c | 8 ++------
+ mysql.xs | 7 ++-----
+ 2 files changed, 4 insertions(+), 11 deletions(-)
+
+diff --git a/dbdimp.c b/dbdimp.c
+index c60a5f6..a6410e5 100644
+--- a/dbdimp.c
++++ b/dbdimp.c
+@@ -4894,12 +4894,8 @@ void dbd_st_destroy(SV *sth, imp_sth_t *imp_sth) {
+
+ if (imp_sth->stmt)
+ {
+- if (mysql_stmt_close(imp_sth->stmt))
+- {
+- do_error(DBIc_PARENT_H(imp_sth), mysql_stmt_errno(imp_sth->stmt),
+- mysql_stmt_error(imp_sth->stmt),
+- mysql_stmt_sqlstate(imp_sth->stmt));
+- }
++ mysql_stmt_close(imp_sth->stmt);
++ imp_sth->stmt= NULL;
+ }
+ #endif
+
+diff --git a/mysql.xs b/mysql.xs
+index 55376e1..affde59 100644
+--- a/mysql.xs
++++ b/mysql.xs
+@@ -434,11 +434,8 @@ do(dbh, statement, attr=Nullsv, ...)
+ if (bind)
+ Safefree(bind);
+
+- if(mysql_stmt_close(stmt))
+- {
+- fprintf(stderr, "\n failed while closing the statement");
+- fprintf(stderr, "\n %s", mysql_stmt_error(stmt));
+- }
++ mysql_stmt_close(stmt);
++ stmt= NULL;
+
+ if (retval == -2) /* -2 means error */
+ {
+--
+1.7.9.5
--
2.13.3
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAll2b50ACgkQ5qXuPBlG
eg1W3g/+IqjU+ouThkzH9bMfYYuhmOulvzBC5gJiyFW6A4Q0CGypyMGoWBVnKIOj
8EHJr0/YIX4fPGosh3U0BzK2XzdTAm9qBwWdYhoZNwQfvLOX+JI3u8hqydk3n8ZJ
9fDv+CIKs0pfek4Uy21AfO93aFW8s8YrfBx6wURq9eUmkN3LSnR1tHUj1+DOnu+S
O68t6F1NSHqF4sNhcdFroVDvz88I78rLt7CVMTiE9WOGCVY0YOW5HipJ/8+7ZYfi
kQl4TNPUZ2C6lfXoZtZJOzleehNig6w0OJN7MKYE6Uhl1PyYDx52H2fdMhiUXBYa
Wpy9AXzTrC1QkzAucI3YFL2f95Yn75c5oLHQUGk0uuJ9F6iGFAh6SzMsWXEXJ8Ty
EEOAAYS23bufqwmsBfH7dPG5zf/IGcskATVubSDeHxQW86bfYIcM9oy5dWITVNLb
RlCWLINq+6wZ54MuxXhcc8GhDe9Iw8J8OiEzNfcxMxFW9hCIWE6klcjmkKRsw/6p
/LHuuPOBsForKE7RpkWM7og0ZbuTbzBe/DeZcYK29kJjG40H0xZf6QRCE/Rpg7Ll
5+HjuUWnXDcSg3lifSpHXhb+vHwWMQUg6c3k0r0KV3PO1qMNeJfKRLtvBnGRi6p0
OGOZ+I6Zix9LWvhEdmtQjGiM5n5if4b6eYDgaOigG/HS7Njf1Ls=
=KZQH
-----END PGP SIGNATURE-----

Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27805@debbugs.gnu.org)
20170725180003.GA32650@jasmine.lan
On Mon, Jul 24, 2017 at 06:07:25PM -0400, Kei Kebreau wrote:
Toggle quote (4 lines)
> Done! FYI, this patch is tentative (i.e. not merged upstream as of
> yet). It seems to do the right thing, but I'm not quite sure, as I'm not
> an experienced C programmer, nor am I a user of this package.

I'm not an expert but, I agree, it seems to do the right thing.

Toggle quote (8 lines)
> > Check 'gnu/packages/patches/wget-CVE-2017-6508.patch' for an example if
> > you are unsure.
> >
> > There is also CVE-2017-10789. I'm not sure if there is a fix merged
> > upstream yet:
> >
> > http://cve.mitre.org/cgi-bin/cvename.cgi?name=2017-10789

Okay, let's wait on that one. Can you try to keep track of it?

Toggle quote (11 lines)
> How does the attached patch look?

> From d067457fcc87a0353dfdf6c8bfbe4f2bbdb90bb9 Mon Sep 17 00:00:00 2001
> From: Kei Kebreau <kei@openmailbox.org>
> Date: Mon, 24 Jul 2017 13:51:50 -0400
> Subject: [PATCH] gnu: perl-dbd-mysql: Fix CVE-2017-10788.
>
> * gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.
> * gnu/packages/databases.scm (perl-dbd-mysql)[source]: Use it.

Please push!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAll3hyMACgkQJkb6MLrK
fwgOEA/+Kx+6ymFLagiGr06B6HVuQglNlrTSCQ9Qg/MLkltPM4PxBA7PxyJa2759
8SUDUpWE+9dN0NrBiNf6WAunkP6WXjEB8CEnQ1+3AWwqxOy5/VbDDVAt+WXYLRlw
AQLpoNwZQK1rMQKkGsoklgLb8S+w7DpUMlXIhv4P2fmD/LfmvjJAga2rDMl0iieP
DMoBwkImKpNB43OPOjelh3nyN6QDQONwcK9EQ6TEY50eFdvwbKrFfS7wQFImxae6
AlSW3Q0xIStKWNxF13wXIzqI46EuygGpdLEgf2In7TCHax2AYDvKDlnPzTXK1U4I
WNsg7Mg1EKbJxwxtERqPS/XIiTKFCoEewuSnERJZ7drWScovLWw+HXOLqW7Yc3y+
cI8GdNDPZ+4r3qp4jWuKhw2RQMJsl7BWMd6m3DDh1DXZyZ4NdHv+cgdl1Aj9X1FC
nvmbNqsYvvaccoka1CuSlclPavbenW2m54z+6t5RG3HaxOwgOqTv78nYQVPOgwyj
ztJcWJpdZNxIenYXY1Rir6JBxN1UTiU/GtD6rwes5tMKb+rhU1CLbLI2OEdnf+WT
yBBAFCQFGEyRu/FyO17UAzBAToj9/OC6Gb4hL4UJGUCKBgDFw9jHSjVcPBLxMueN
1xTvYgdHt82V1rWYTwZ07NE66KoyK0OQflB+Gaaeo8MyLOgVnZM=
=qUP+
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 27805-done@debbugs.gnu.org)
87lgnc5qrz.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (18 lines)
> On Mon, Jul 24, 2017 at 06:07:25PM -0400, Kei Kebreau wrote:
>> Done! FYI, this patch is tentative (i.e. not merged upstream as of
>> yet). It seems to do the right thing, but I'm not quite sure, as I'm not
>> an experienced C programmer, nor am I a user of this package.
>
> I'm not an expert but, I agree, it seems to do the right thing.
>
>> > Check 'gnu/packages/patches/wget-CVE-2017-6508.patch' for an example if
>> > you are unsure.
>> >
>> > There is also CVE-2017-10789. I'm not sure if there is a fix merged
>> > upstream yet:
>> >
>> > http://cve.mitre.org/cgi-bin/cvename.cgi?name=2017-10789
>
> Okay, let's wait on that one. Can you try to keep track of it?
>

Will do!

Toggle quote (13 lines)
>> How does the attached patch look?
>
>> From d067457fcc87a0353dfdf6c8bfbe4f2bbdb90bb9 Mon Sep 17 00:00:00 2001
>> From: Kei Kebreau <kei@openmailbox.org>
>> Date: Mon, 24 Jul 2017 13:51:50 -0400
>> Subject: [PATCH] gnu: perl-dbd-mysql: Fix CVE-2017-10788.
>>
>> * gnu/packages/patches/perl-dbd-mysql-CVE-2017-10788.patch: New file.
>> * gnu/local.mk (dist_patch_DATA): Add it.
>> * gnu/packages/databases.scm (perl-dbd-mysql)[source]: Use it.
>
> Please push!

Pushed to master! Thank you for reviewing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAll3ijEACgkQ5qXuPBlG
eg0TbxAAlXP2o6RWlWvuA5Cq074A8x76aT5ogVMjKrSivpwg+X9TAM+OZB3PCh/K
U5H2T9WAG73KZVYUD4IZdf2OgLXnctigJBhJe52PCr/i9qkhNTfDVLmr9UEesdde
KZLtBVMLfm1D6Vggj/l3lcxb2buhG+HhaDyAH/wAhvY7CYhK6mSKc0TLsPb29DOV
Cl9AMtlwZoSdFy7QXSjRqqSiLjD7hCbo2zTs1BJzBPd0btOuSpV7+G5/Erw79/zI
IFweDHN5dGrJMg/RIEZcQreCcw7hFgOz9zWnYPrqqddjLZzUNyBhU4Jp7J9iAjr3
o32+JcSz9LZmiCkMr28pZAEmobAxdvyzhsnPKR+KhF6IhmcETyoH6g0GCmrmJP1O
KEay57HPMtuOFdkc1DhyFhRTuYlPaL/uslV20uwnjuCBKvnrJpdtGjr8p8T4LDYX
NHTrZsy8IgisYqhq8NgfvApSzF24a6stlNyKiEqh4yZy6d/5HMo2DaBilYmFuBEJ
t+MGujzJbpCWeGiaBoACIIbDwywUH9uDNe72mZcrYkgmdypS5M6Yi0Fjl6mhU/oP
31eq6uwba2r6hSQGBCYrO71xPNX0LqQ11uEYBiB/p1Kqs0iogMM4an+YYT11Gv1N
tt7ntvgPf+68YNHKO4KHrZsPQZX95uYaXz5YsHqGGLtoP2VLilQ=
=StIj
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27805@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27805
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help