Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/packages/mail.scm (claws-mail)[arguments]: Add make-flags to disable
Gtk+ icon cache generation.
---
gnu/packages/mail.scm | 5 +++++
1 file changed, 5 insertions(+)
Toggle diff (16 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0d1d39990..7228ec9d7 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -930,6 +930,11 @@ compresses it.")
(arguments
'(#:configure-flags
'("--enable-gnutls" "--enable-pgpmime-plugin" "--enable-enchant")
+ #:make-flags
+ ;; Disable updating icon cache since it's done by the profile hook.
+ ;; Conflict with other packages in the profile would be inevitable
+ ;; otherwise.
+ '("gtk_update_icon_cache=true")
#:phases (modify-phases %standard-phases
(add-before 'build 'patch-mime
(lambda* (#:key inputs #:allow-other-keys)