Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
Ok, it turns out that grub-mkrescue can create a hybrid bootloader that works
with both EFI and non-EFI systems.
For that, the contents of lib/grub/i386-pc has to be available to
grub-mkrescue. Then it will build a hybrid bootloader.
I've successfully tested it using:
$ qemu-system-x86_64 -bios $(guix build ovmf)/share/firmware/ovmf_x64.bin -m 1G -enable-kvm -cdrom ZZ -serial stdio
$ qemu-system-x86_64 -bios $(guix build ovmf)/share/firmware/ovmf_x64.bin -m 1G -enable-kvm -hda ZZ -serial stdio
$ qemu-system-x86_64 -m 1G -enable-kvm -cdrom ZZ -serial stdio
$ qemu-system-x86_64 -m 1G -enable-kvm -hda ZZ -serial stdio
and the patch from bug# 27690.
Danny Milosavljevic (2):
bootloader: Add grub-hybrid-bootloader.
install: Use grub-hybrid-bootloader.
gnu/bootloader/grub.scm | 7 +++++++
gnu/packages/bootloaders.scm | 20 ++++++++++++++++++++
gnu/system/install.scm | 3 ++-
3 files changed, 29 insertions(+), 1 deletion(-)