Add mksh

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Ludovic Courtès
  • ng0
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 12 Jul 2017 16:08
(address . guix-patches@gnu.org)
ef5a2eab.AEEANOp8HRMAAAAAAAAAAAOtUOAAAAACwQwAAAAAAAW9WABZZi1k@mailjet.com
Patches adding mksh follow.
A
A
Arun Isaac wrote on 12 Jul 2017 16:10
[PATCH 1/2] licenses: Add MirOS license.
(address . 27669@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
a2cea426.AEEANOqQKjcAAAAAAAAAAAPU1UYAAAACwQwAAAAAAAW9WABZZi39@mailjet.com
* guix/licenses.scm (miros): New variable.
---
guix/licenses.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (26 lines)
diff --git a/guix/licenses.scm b/guix/licenses.scm
index 1bed56af2..17b75bd39 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -67,6 +67,7 @@
lppl1.3a lppl1.3a+
lppl1.3b lppl1.3b+
lppl1.3c lppl1.3c+
+ miros
mpl1.0 mpl1.1 mpl2.0
ms-pl
ncsa
@@ -452,6 +453,11 @@ at URI, which may be a file:// URI pointing the package's tree."
"https://www.latex-project.org/lppl/lppl-1-3c/"
"LaTeX Project Public License 1.3c or later"))
+(define miros
+ (license "MirOS"
+ "https://www.mirbsd.org/MirOS-Licence.htm"
+ "MirOS License"))
+
(define mpl1.0
(license "MPL 1.0"
"http://www.mozilla.org/MPL/1.0/"
--
2.12.2
A
A
Arun Isaac wrote on 12 Jul 2017 16:10
[PATCH 2/2] gnu: Add mksh.
(address . 27669@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
46af05cd.AEEANOqQLHoAAAAAAAAAAAPU1UYAAAACwQwAAAAAAAW9WABZZi4H@mailjet.com
* gnu/packages/shells.scm (mksh): New variable.
---
gnu/packages/shells.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 65e0eda50..2b53afec1 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -599,3 +599,42 @@ interactive POSIX shell targeted at resource-constrained systems.")
;; The file 'LEGAL' says it is the public domain, and the 2
;; exceptions which are listed are not included in this port.
(license public-domain)))
+
+(define-public mksh
+ (package
+ (name "mksh")
+ (version "55")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.mirbsd.org/MirOS/dist/mir/mksh/mksh-R"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0mssqd2wp3cs9x01v6g66iy3ymdxagbyw2c0v597vnc1l6s2rm6f"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; tests require access to /dev/tty
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (setenv "CC" "gcc")
+ (zero? (system* (which "sh") "Build.sh"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man/man1")))
+ (install-file "mksh" bin)
+ (with-directory-excursion bin
+ (symlink "mksh" "ksh"))
+ (install-file "mksh.1" man)))))))
+ (home-page "https://www.mirbsd.org/mksh.htm")
+ (synopsis "Korn Shell from MirBSD")
+ (description "mksh is an actively developed free implementation of the
+Korn Shell programming language and a successor to the Public Domain Korn
+Shell (pdksh).")
+ (license (list miros
+ isc)))) ; strlcpy.c
--
2.12.2
A
A
Arun Isaac wrote on 12 Jul 2017 16:14
(address . 27669@debbugs.gnu.org)
40a55fb7.AEMAM65-i9EAAAAAAAAAAAPU1UYAAAACwQwAAAAAAAW9WABZZi7a@mailjet.com
Toggle quote (3 lines)
> + (license (list miros
> + isc)))) ; strlcpy.c

The file mksh.ico is under a different license as stated in Appendix D

I haven't added it to the list of licenses for the following two reasons:

- the file mksh.ico is not installed in our built package
- I don't understand what license is described in Appendix D, and could
use some help.

Could someone clarify? Thanks.
N
Re: [bug#27669] Add mksh
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 27669@debbugs.gnu.org)
20170712143845.62usajmpkofrjbdx@abyayala
Arun Isaac transcribed 0.1K bytes:
Toggle quote (6 lines)
>
> Patches adding mksh follow.
>
>
>
>
Which of the mksh if I may ask? I have some MKSH's here
I was just too slow to upstream.
At the moment it's just Mirsh, oksh.
--
ng0
GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAllmNHEACgkQ4i+bv+40
hYgKsg//YBHFRuS4d2+6MIrhw2EJwuNspc+o9VaV70moatVhO830An+Tan2krDle
Y9hQTk0p1h0gx3JYKIm8ZPpDUEiDrpCPi+ENi1+KLmruYnp3lpc0WNC9WCjllMV4
d6fqWv0ligqkviJ/r85ND8FupljcyzIUebSMOY/N7IdfQQ398WFUpcSQvJ8gMKMp
TsTzExpCVC09viF2HHOpOr/mfluPdkZPBuNBNuhDCkOwUkNG8X/C/G+cEJCW2duG
Qpgv1gsTuZntbktYVHn2RpYAop+exn5+3P7lsvPhMFmHD0/GPnBk0Ht8vo3MbbTw
qIgecygrt76xgBPFc3AxZbmEp7TALEd6uk01zZNE667iBwppWGiwjXKEzrPiVuC5
bQi34lIRu8sLlzkmuUI308vMf4EMMbYEEqihlmV7utU5VDd7mPtCsFe02Nc1V/FW
V2NtQYsnxL3zJ8UJZ/aRws9i8vAQoLqd9NuRG/ICdrZmaCk5QZOrK5szg1H8cqO3
i4NeoLmOoGrAhMt6UMGI/UFRI9jO6nRZtIzgtMZccCR06wGDUlJVKsg6GBiQOlQs
N/S6WmvZm8YLQOD+/JKh0I+OivtZni9KYV8dK8q5vSqB+priwHkrXDkz82pm+U1W
goOA8z/gZvf7ZfzgsEjcfSfD1nU4kXWiqEc8xdY1hffc8jszsII=
=dEe6
-----END PGP SIGNATURE-----


A
A
Arun Isaac wrote on 12 Jul 2017 16:48
(name . ng0)(address . ng0@infotropique.org)(address . 27669@debbugs.gnu.org)
9cf2de64.AEAAMypJleMAAAAAAAAAAAPU1UYAAAACwQwAAAAAAAW9WABZZjbi@mailjet.com
ng0 writes:

Toggle quote (6 lines)
> Arun Isaac transcribed 0.1K bytes:
>>
>> Patches adding mksh follow.
>>
> Which of the mksh if I may ask?

The MirBSD Korn Shell: https://www.mirbsd.org/mksh.htm
L
L
Ludovic Courtès wrote on 20 Jul 2017 11:20
Re: [bug#27669] [PATCH 2/2] gnu: Add mksh.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 27669@debbugs.gnu.org)
87a83zxy5x.fsf@gnu.org
Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/shells.scm (mksh): New variable.

LGTM, thanks!

Ludo'.
A
A
Arun Isaac wrote on 20 Jul 2017 16:32
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27669-done@debbugs.gnu.org)
ab12f100.ADkAACVg8LkAAAAAAAAAAAPYNwwAAAACwQwAAAAAAAW9WABZcL8V@mailjet.com
Pushed, thanks!
Closed
?