[PATCH 0/2] Add guile-ncurses-with-gpm and ncurses-with-gpm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170705202926.20803-1-dannym@scratchpost.org
For the installer.

Danny Milosavljevic (2):
gnu: Add ncurses-with-gpm.
gnu: Add guile-ncurses-with-gpm.

gnu/packages/guile.scm | 7 +++++++
gnu/packages/linux.scm | 13 +++++++++++++
2 files changed, 20 insertions(+)
Danny Milosavljevic wrote 8 years ago
[PATCH 1/2] gnu: Add ncurses-with-gpm.
(address . 27591@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170705203104.20941-1-dannym@scratchpost.org
* gnu/packages/linux.scm (ncurses/gpm): New variable.
---
gnu/packages/linux.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index da41824cf..123cace2a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3003,6 +3003,19 @@ applications running on the Linux console. It allows users to select items
and copy/paste text in the console and in xterm.")
(license license:gpl2+)))
+(define-public ncurses/gpm
+ (package
+ (inherit ncurses)
+ (name "ncurses-with-gpm")
+ (arguments
+ (substitute-keyword-arguments (package-arguments ncurses)
+ ((#:configure-flags cf)
+ `(cons (string-append "--with-gpm="
+ (assoc-ref %build-inputs "gpm")
+ "/lib/libgpm.so.2") ,cf))))
+ (inputs
+ `(("gpm" ,gpm)))))
+
(define-public btrfs-progs
(package
(name "btrfs-progs")
Danny Milosavljevic wrote 8 years ago
[PATCH 2/2] gnu: Add guile-ncurses-with-gpm.
(address . 27591@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170705203104.20941-2-dannym@scratchpost.org
* gnu/packages/guile.scm (guile-ncurses/gpm): New variable.
---
gnu/packages/guile.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d79094e1e..9724186cc 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -519,6 +519,13 @@ many readers as needed).")
library.")
(license license:lgpl3+)))
+(define-public guile-ncurses/gpm
+ (package
+ (inherit guile-ncurses)
+ (name "guile-ncurses-with-gpm")
+ (inputs `(("ncurses" ,ncurses/gpm)
+ ("guile" ,guile-2.2)))))
+
(define-public mcron
(package
(name "mcron")
Ludovic Courtès wrote 8 years ago
Re: [bug#27591] [PATCH 1/2] gnu: Add ncurses-with-gpm.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27591@debbugs.gnu.org)
87van0611f.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (24 lines)
> * gnu/packages/linux.scm (ncurses/gpm): New variable.
> ---
> gnu/packages/linux.scm | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index da41824cf..123cace2a 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -3003,6 +3003,19 @@ applications running on the Linux console. It allows users to select items
> and copy/paste text in the console and in xterm.")
> (license license:gpl2+)))
>
> +(define-public ncurses/gpm
> + (package
> + (inherit ncurses)
> + (name "ncurses-with-gpm")
> + (arguments
> + (substitute-keyword-arguments (package-arguments ncurses)
> + ((#:configure-flags cf)
> + `(cons (string-append "--with-gpm="
> + (assoc-ref %build-inputs "gpm")
> + "/lib/libgpm.so.2") ,cf))))

As discussed elsewhere, even better if we can avoid hardcoding “.so.2”
here. If we can’t, that’s OK.

Thank you,
Ludo’.
Ludovic Courtès wrote 8 years ago
Re: [bug#27591] [PATCH 2/2] gnu: Add guile-ncurses-with-gpm.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27591@debbugs.gnu.org)
87r2xo610m.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (20 lines)
> * gnu/packages/guile.scm (guile-ncurses/gpm): New variable.
> ---
> gnu/packages/guile.scm | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
> index d79094e1e..9724186cc 100644
> --- a/gnu/packages/guile.scm
> +++ b/gnu/packages/guile.scm
> @@ -519,6 +519,13 @@ many readers as needed).")
> library.")
> (license license:lgpl3+)))
>
> +(define-public guile-ncurses/gpm
> + (package
> + (inherit guile-ncurses)
> + (name "guile-ncurses-with-gpm")
> + (inputs `(("ncurses" ,ncurses/gpm)
> + ("guile" ,guile-2.2)))))

LGTM, thanks!

Ludo'.
Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170715101602.2dd33f31@scratchpost.org
close 27591
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27591@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27591
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help