Danny Milosavljevic <dannym@scratchpost.org> skribis:
Toggle quote (24 lines)
> * gnu/packages/linux.scm (ncurses/gpm): New variable.
> ---
> gnu/packages/linux.scm | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index da41824cf..123cace2a 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -3003,6 +3003,19 @@ applications running on the Linux console. It allows users to select items
> and copy/paste text in the console and in xterm.")
> (license license:gpl2+)))
>
> +(define-public ncurses/gpm
> + (package
> + (inherit ncurses)
> + (name "ncurses-with-gpm")
> + (arguments
> + (substitute-keyword-arguments (package-arguments ncurses)
> + ((#:configure-flags cf)
> + `(cons (string-append "--with-gpm="
> + (assoc-ref %build-inputs "gpm")
> + "/lib/libgpm.so.2") ,cf))))
As discussed elsewhere, even better if we can avoid hardcoding “.so.2”
here. If we can’t, that’s OK.
Thank you,
Ludo’.