Christopher Allan Webber wrote 8 years ago
(address . guix-patches@gnu.org)
This adds dirvish (a backup program) along with dependencies of
perl-libtime-parsedate and perl-libtime-period.
From 60a448f1daf37927155577dabaf1c090f9404bee Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Sat, 1 Jul 2017 20:45:04 -0500
Subject: [PATCH 1/3] gnu: Add perl-libtime-parsedate.
* gnu/packages/perl.scm (perl-libtime-parsedate): New variable.
---
gnu/packages/perl.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (56 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6da4bb13f..6906bc2bb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8248,3 +8249,41 @@ interface to File::Find::Object.")
(description "Test::TrailingSpace tests for trailing spaces
in Perl source files.")
(license x11)))
+
+(define-public perl-libtime-parsedate
+ (package
+ (name "perl-libtime-parsedate")
+ (version "2015.103")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MU/MUIR/modules/Time-ParseDate-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1lgfr87j4qwqnln0hyyzgik5ixqslzdaksn9m8y824gqbcihc6ic"))))
+ (build-system perl-build-system)
+ (arguments
+ ;; Output when running tests:
+ ;; t/metdate.t ... skipped: It seems localtime() does not honor
+ ;; $ENV{TZ} when set in the test script.
+ ;; Seemingly related:
+ ;; https://stackoverflow.com/questions/19956693/timeparsedate-install-fail
+ ;; https://rt.cpan.org/Public/Bug/Display.html?id=90367
+ `(#:tests? #f))
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "https://metacpan.org/release/Time-ParseDate")
+ (synopsis
+ "Collection of Perl modules for time/date manipulation")
+ (description "Provides several perl modules for date/time manipulation:
+Time::CTime.pm, Time::JulianDay.pm, Time::ParseDate.pm, Time::Timezone.pm,
+and Time::DaysInMonth.pm.")
+ ;; License text:
+ ;; "License hereby granted for anyone to use, modify or redistribute this
+ ;; module at their own risk. Please feed useful changes back to
+ ;; cpan@dave.sharnoff.org."
+ (license (non-copyleft "http://metadata.ftp-master.debian.org/\
+changelogs/main/libt/libtime-parsedate-perl/\
+libtime-parsedate-perl_2015.103-2_copyright"))))
--
2.13.1
From f475a133812a4d62e32a90caa26f41bb242f8a37 Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Sat, 1 Jul 2017 20:46:00 -0500
Subject: [PATCH 2/3] gnu: Add perl-libtime-period.
* gnu/packages/perl.scm (perl-libtime-period): New variable.
---
gnu/packages/perl.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6906bc2bb..93b74df8e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8287,3 +8287,32 @@ and Time::DaysInMonth.pm.")
(license (non-copyleft "http://metadata.ftp-master.debian.org/\
changelogs/main/libt/libtime-parsedate-perl/\
libtime-parsedate-perl_2015.103-2_copyright"))))
+
+(define-public perl-libtime-period
+ (package
+ (name "perl-libtime-period")
+ (version "1.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://http.debian.net/debian/pool/main/libt/"
+ "libtime-period-perl/libtime-period-perl_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32 "0c0yd999h0ikj88c9j95wa087m87i0qh7vja3715y2kd7vixkci2"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ ;; Unless some other homepage is out there...
+ (home-page
+ "https://packages.debian.org/stretch/libtime-period-perl")
+ (synopsis
+ "Perl library for testing if a time() is in a specific period")
+ (description "This Perl library provides a function which tells whether a
+specific time falls within a specified time period. Its syntax for specifying
+time periods allows you to test for conditions like \"Monday to Friday, 9am
+till 5pm\" and \"on the second Tuesday of the month\" and \"between 4pm and
+4:15pm\" and \"in the first half of each minute\" and \"in January of
+1998\".")
+ (license (package-license perl))))
--
2.13.1