Add dirvish and dependencies

  • Done
  • quality assurance status badge
Details
4 participants
  • Christopher Allan Webber
  • Leo Famulari
  • Ludovic Courtès
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Allan Webber
Severity
normal

Debbugs page

Christopher Allan Webber wrote 8 years ago
(address . guix-patches@gnu.org)
8737afvbwd.fsf@dustycloud.org
This adds dirvish (a backup program) along with dependencies of
perl-libtime-parsedate and perl-libtime-period.
From 60a448f1daf37927155577dabaf1c090f9404bee Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Sat, 1 Jul 2017 20:45:04 -0500
Subject: [PATCH 1/3] gnu: Add perl-libtime-parsedate.

* gnu/packages/perl.scm (perl-libtime-parsedate): New variable.
---
gnu/packages/perl.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6da4bb13f..6906bc2bb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8248,3 +8249,41 @@ interface to File::Find::Object.")
(description "Test::TrailingSpace tests for trailing spaces
in Perl source files.")
(license x11)))
+
+(define-public perl-libtime-parsedate
+ (package
+ (name "perl-libtime-parsedate")
+ (version "2015.103")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MU/MUIR/modules/Time-ParseDate-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1lgfr87j4qwqnln0hyyzgik5ixqslzdaksn9m8y824gqbcihc6ic"))))
+ (build-system perl-build-system)
+ (arguments
+ ;; Output when running tests:
+ ;; t/metdate.t ... skipped: It seems localtime() does not honor
+ ;; $ENV{TZ} when set in the test script.
+ ;; Seemingly related:
+ ;; https://stackoverflow.com/questions/19956693/timeparsedate-install-fail
+ ;; https://rt.cpan.org/Public/Bug/Display.html?id=90367
+ `(#:tests? #f))
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (home-page
+ "https://metacpan.org/release/Time-ParseDate")
+ (synopsis
+ "Collection of Perl modules for time/date manipulation")
+ (description "Provides several perl modules for date/time manipulation:
+Time::CTime.pm, Time::JulianDay.pm, Time::ParseDate.pm, Time::Timezone.pm,
+and Time::DaysInMonth.pm.")
+ ;; License text:
+ ;; "License hereby granted for anyone to use, modify or redistribute this
+ ;; module at their own risk. Please feed useful changes back to
+ ;; cpan@dave.sharnoff.org."
+ (license (non-copyleft "http://metadata.ftp-master.debian.org/\
+changelogs/main/libt/libtime-parsedate-perl/\
+libtime-parsedate-perl_2015.103-2_copyright"))))
--
2.13.1
From f475a133812a4d62e32a90caa26f41bb242f8a37 Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Sat, 1 Jul 2017 20:46:00 -0500
Subject: [PATCH 2/3] gnu: Add perl-libtime-period.

* gnu/packages/perl.scm (perl-libtime-period): New variable.
---
gnu/packages/perl.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6906bc2bb..93b74df8e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8287,3 +8287,32 @@ and Time::DaysInMonth.pm.")
(license (non-copyleft "http://metadata.ftp-master.debian.org/\
changelogs/main/libt/libtime-parsedate-perl/\
libtime-parsedate-perl_2015.103-2_copyright"))))
+
+(define-public perl-libtime-period
+ (package
+ (name "perl-libtime-period")
+ (version "1.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://http.debian.net/debian/pool/main/libt/"
+ "libtime-period-perl/libtime-period-perl_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32 "0c0yd999h0ikj88c9j95wa087m87i0qh7vja3715y2kd7vixkci2"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ ;; Unless some other homepage is out there...
+ (home-page
+ "https://packages.debian.org/stretch/libtime-period-perl")
+ (synopsis
+ "Perl library for testing if a time() is in a specific period")
+ (description "This Perl library provides a function which tells whether a
+specific time falls within a specified time period. Its syntax for specifying
+time periods allows you to test for conditions like \"Monday to Friday, 9am
+till 5pm\" and \"on the second Tuesday of the month\" and \"between 4pm and
+4:15pm\" and \"in the first half of each minute\" and \"in January of
+1998\".")
+ (license (package-license perl))))
--
2.13.1
Ludovic Courtès wrote 8 years ago
(name . Christopher Allan Webber)(address . cwebber@dustycloud.org)(address . 27554@debbugs.gnu.org)
877ezq7tmi.fsf@gnu.org
Hi Chris!

Christopher Allan Webber <cwebber@dustycloud.org> skribis:

Toggle quote (7 lines)
> From 60a448f1daf37927155577dabaf1c090f9404bee Mon Sep 17 00:00:00 2001
> From: Christopher Allan Webber <cwebber@dustycloud.org>
> Date: Sat, 1 Jul 2017 20:45:04 -0500
> Subject: [PATCH 1/3] gnu: Add perl-libtime-parsedate.
>
> * gnu/packages/perl.scm (perl-libtime-parsedate): New variable.

[...]

Toggle quote (9 lines)
> + (arguments
> + ;; Output when running tests:
> + ;; t/metdate.t ... skipped: It seems localtime() does not honor
> + ;; $ENV{TZ} when set in the test script.
> + ;; Seemingly related:
> + ;; https://stackoverflow.com/questions/19956693/timeparsedate-install-fail
> + ;; https://rt.cpan.org/Public/Bug/Display.html?id=90367
> + `(#:tests? #f))

Perhaps if we add a dependency on tzdata and set TZDIR, as is done for
‘duplicity’ for instance, the tests would run?

Anyway this probably shouldn’t block the whole series!

Toggle quote (7 lines)
> From f475a133812a4d62e32a90caa26f41bb242f8a37 Mon Sep 17 00:00:00 2001
> From: Christopher Allan Webber <cwebber@dustycloud.org>
> Date: Sat, 1 Jul 2017 20:46:00 -0500
> Subject: [PATCH 2/3] gnu: Add perl-libtime-period.
>
> * gnu/packages/perl.scm (perl-libtime-period): New variable.

[...]

Toggle quote (2 lines)
> + (license (package-license perl))))

Please use ‘license:perl-license’ here.

Toggle quote (7 lines)
> From 01b0c93222658f74d5049f1666d383efacf4a724 Mon Sep 17 00:00:00 2001
> From: Christopher Allan Webber <cwebber@dustycloud.org>
> Date: Sun, 20 Nov 2016 10:36:46 -0600
> Subject: [PATCH 3/3] gnu: Add dirvish.
>
> * gnu/packages/backup.scm (dirvish): New variable.

[...]

Toggle quote (3 lines)
> + (home-page "http://dirvish.org/")
> + (license (license:fsf-free "file://COPYING")))) ; Open Software License 2.0

You can make it:

(license:fsf-free "file://COPYING"
"Open Software License 2.0")

OK with these changes, thank you!

Ludo’.
Leo Famulari wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
20170702153847.GA18347@jasmine.lan
On Sun, Jul 02, 2017 at 05:20:37PM +0200, Ludovic Courtès wrote:
Toggle quote (27 lines)
> Hi Chris!
>
> Christopher Allan Webber <cwebber@dustycloud.org> skribis:
>
> > From 60a448f1daf37927155577dabaf1c090f9404bee Mon Sep 17 00:00:00 2001
> > From: Christopher Allan Webber <cwebber@dustycloud.org>
> > Date: Sat, 1 Jul 2017 20:45:04 -0500
> > Subject: [PATCH 1/3] gnu: Add perl-libtime-parsedate.
> >
> > * gnu/packages/perl.scm (perl-libtime-parsedate): New variable.
>
> [...]
>
> > + (arguments
> > + ;; Output when running tests:
> > + ;; t/metdate.t ... skipped: It seems localtime() does not honor
> > + ;; $ENV{TZ} when set in the test script.
> > + ;; Seemingly related:
> > + ;; https://stackoverflow.com/questions/19956693/timeparsedate-install-fail
> > + ;; https://rt.cpan.org/Public/Bug/Display.html?id=90367
> > + `(#:tests? #f))
>
> Perhaps if we add a dependency on tzdata and set TZDIR, as is done for
> ‘duplicity’ for instance, the tests would run?
>
> Anyway this probably shouldn’t block the whole series!

If it only uses them for tests, please use the special tzdata package
that is just for tests, currently tzdata-2017a.

This package is out-of-date, so the built package should not keep a
reference to it.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAllZE4cACgkQJkb6MLrK
fwh0SBAAknTwwJesRqFHz3glnLcBxnfVwSmg9nVQ7SUU2QsGwZTYoG6gs0Ymx9sV
Mg/b07Q8D9+iQFZl51tISXuW6zG+bJqBH2uWt1z5cWx3+Ep2t5Qxd2uF4RtMFZh1
wRYy1seo0qWEKD1rgRkVrPFazyrP7NjYBe3/OJmKHQCxcklJPfPnz+55TyXEpwos
CCwuMO60V9GzvdMPEuGnJduePGztFBbio+eiCPuK40IZmf4yr7DA0tf1lk0A0GuJ
ik1LlwiSIBwr21br0D4fgwr/N6DOMtop0ULOoMIb1I7NCq6qsKSKJWSTMIaI0fLP
6BA9/O3DJkFZW9gM7OV/zSVN3ywjtExvVm9sPIYerWECPoDiIpZONlsIxQwWO9PN
fK/Mlko99G3B6rkRKBkBIQzEJlQeeT/CEQE350Cnh6rR6yLJ0GNXrjYZNFjvrdAo
mMTR19uITo1eWVZJE3xW3kSf8QFpAYYkU3CbbXEk0zf2waKlbfqEvs5eksiqEcM7
7OHrQY9aFMDQtjZYCzQ3kzh7wlLIX5EsbGTKVwl60XiBFUH0k9lmLydPrIKYA/pC
OgeQPOGaUWWanAmmnC5o/LmEcTeagNDTocrCSVADaYtpnhgVz9Is1kZ8syoYykho
ZmGcMpm3Vl+7mGxdvezs5YGdjLpOodsUp/JCoh5xn8zY8aw7Chw=
=Q1Tn
-----END PGP SIGNATURE-----


Ricardo Wurmus wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)
87tvyw2gjb.fsf@elephly.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (31 lines)
> On Sun, Jul 02, 2017 at 05:20:37PM +0200, Ludovic Courtès wrote:
>> Hi Chris!
>>
>> Christopher Allan Webber <cwebber@dustycloud.org> skribis:
>>
>> > From 60a448f1daf37927155577dabaf1c090f9404bee Mon Sep 17 00:00:00 2001
>> > From: Christopher Allan Webber <cwebber@dustycloud.org>
>> > Date: Sat, 1 Jul 2017 20:45:04 -0500
>> > Subject: [PATCH 1/3] gnu: Add perl-libtime-parsedate.
>> >
>> > * gnu/packages/perl.scm (perl-libtime-parsedate): New variable.
>>
>> [...]
>>
>> > + (arguments
>> > + ;; Output when running tests:
>> > + ;; t/metdate.t ... skipped: It seems localtime() does not honor
>> > + ;; $ENV{TZ} when set in the test script.
>> > + ;; Seemingly related:
>> > + ;; https://stackoverflow.com/questions/19956693/timeparsedate-install-fail
>> > + ;; https://rt.cpan.org/Public/Bug/Display.html?id=90367
>> > + `(#:tests? #f))
>>
>> Perhaps if we add a dependency on tzdata and set TZDIR, as is done for
>> ‘duplicity’ for instance, the tests would run?
>>
>> Anyway this probably shouldn’t block the whole series!
>
> If it only uses them for tests, please use the special tzdata package
> that is just for tests, currently tzdata-2017a.

Thanks for the hint.

I’ve implemented the suggested changes and pushed these patches to
master with commit 0ff4425ce.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27554@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27554
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help