[PATCH] gnu: gcr: Enable working tests.

  • Done
  • quality assurance status badge
Details
3 participants
  • Kei Kebreau
  • Ludovic Courtès
  • Roel Janssen
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170630214326.27709-1-kei@openmailbox.org
* gnu/packages/patches/gcr-disable-failing-tests.patch,
gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
New files.
* gnu/local.mk (dist_patch_DATA): Add patches.
* gnu/packages/gnome.scm (gcr)[source]: Use patches.
[arguments]: Enable tests.
---
gnu/local.mk | 2 +
gnu/packages/gnome.scm | 9 +-
.../patches/gcr-disable-failing-tests.patch | 127 +++++++++++++++++++++
...-fix-collection-tests-to-work-with-gpg-21.patch | 31 +++++
4 files changed, 165 insertions(+), 4 deletions(-)
create mode 100644 gnu/packages/patches/gcr-disable-failing-tests.patch
create mode 100644 gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch

Toggle diff (207 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 83b019605..22df8dfdd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -614,6 +614,8 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-5-source-date-epoch-2.patch \
%D%/packages/patches/gcc-6-arm-none-eabi-multilib.patch \
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
+ %D%/packages/patches/gcr-disable-failing-tests.patch \
+ %D%/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch \
%D%/packages/patches/gdk-pixbuf-list-dir.patch \
%D%/packages/patches/gd-fix-gd2-read-test.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e6072e033..3491f4be1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -470,12 +470,13 @@ and keep up to date translations of documentation.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ydk9dzxx6snxza7j5ps8x932hbr3x1b8hhcaqjq4w4admi2qmwh"))))
+ "0ydk9dzxx6snxza7j5ps8x932hbr3x1b8hhcaqjq4w4admi2qmwh"))
+ (patches
+ (search-patches "gcr-disable-failing-tests.patch"
+ "gcr-fix-collection-tests-to-work-with-gpg-21.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ;25 of 598 tests fail because /var/lib/dbus/machine-id does
- ;not exist
- #:phases (modify-phases %standard-phases
+ '(#:phases (modify-phases %standard-phases
(add-before
'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
diff --git a/gnu/packages/patches/gcr-disable-failing-tests.patch b/gnu/packages/patches/gcr-disable-failing-tests.patch
new file mode 100644
index 000000000..dcf2d3d34
--- /dev/null
+++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
@@ -0,0 +1,127 @@
+This patch removes a group of tests that fail because /var/lib/dbus/machine-id
+is not present in the build environment.
+
+diff -ur gcr-3.20.0.old/Makefile.in gcr-3.20.0/Makefile.in
+--- gcr-3.20.0.old/Makefile.in 2017-06-29 14:26:33.794837648 -0400
++++ gcr-3.20.0/Makefile.in 2017-06-29 14:26:54.023532689 -0400
+@@ -482,8 +482,7 @@
+ test-openssh$(EXEEXT) test-secure-memory$(EXEEXT) \
+ test-trust$(EXEEXT) test-parser$(EXEEXT) test-record$(EXEEXT) \
+ test-memory-icon$(EXEEXT) test-gnupg-key$(EXEEXT) \
+- test-gnupg-collection$(EXEEXT) test-gnupg-process$(EXEEXT) \
+- test-system-prompt$(EXEEXT)
++ test-gnupg-collection$(EXEEXT) test-gnupg-process$(EXEEXT)
+ @WITH_GTK_TRUE@am__EXEEXT_4 = frob-certificate$(EXEEXT) \
+ @WITH_GTK_TRUE@ frob-combo-selector$(EXEEXT) \
+ @WITH_GTK_TRUE@ frob-gnupg-selector$(EXEEXT) \
+@@ -882,14 +881,6 @@
+ am_test_symkey_OBJECTS = egg/test-symkey.$(OBJEXT)
+ test_symkey_OBJECTS = $(am_test_symkey_OBJECTS)
+ test_symkey_DEPENDENCIES = $(am__DEPENDENCIES_4)
+-am_test_system_prompt_OBJECTS = \
+- gcr/test_system_prompt-test-system-prompt.$(OBJEXT)
+-test_system_prompt_OBJECTS = $(am_test_system_prompt_OBJECTS)
+-test_system_prompt_DEPENDENCIES = $(am__DEPENDENCIES_3)
+-test_system_prompt_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
+- $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
+- $(test_system_prompt_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
+- $(LDFLAGS) -o $@
+ am_test_trust_OBJECTS = gcr/test_trust-test-trust.$(OBJEXT)
+ test_trust_OBJECTS = $(am_test_trust_OBJECTS)
+ test_trust_DEPENDENCIES = $(am__DEPENDENCIES_3)
+@@ -974,8 +965,7 @@
+ $(test_secret_exchange_SOURCES) $(test_secure_memory_SOURCES) \
+ $(test_simple_certificate_SOURCES) \
+ $(test_subject_public_key_SOURCES) $(test_symkey_SOURCES) \
+- $(test_system_prompt_SOURCES) $(test_trust_SOURCES) \
+- $(test_util_SOURCES)
++ $(test_trust_SOURCES) $(test_util_SOURCES)
+ DIST_SOURCES = $(libegg_asn1x_la_SOURCES) $(libegg_hex_la_SOURCES) \
+ $(libegg_secmem_la_SOURCES) $(libegg_test_la_SOURCES) \
+ $(libegg_la_SOURCES) $(libgck_@GCK_MAJOR@_la_SOURCES) \
+@@ -1016,8 +1006,7 @@
+ $(test_secret_exchange_SOURCES) $(test_secure_memory_SOURCES) \
+ $(test_simple_certificate_SOURCES) \
+ $(test_subject_public_key_SOURCES) $(test_symkey_SOURCES) \
+- $(test_system_prompt_SOURCES) $(test_trust_SOURCES) \
+- $(test_util_SOURCES)
++ $(test_trust_SOURCES) $(test_util_SOURCES)
+ RECURSIVE_TARGETS = all-recursive check-recursive cscopelist-recursive \
+ ctags-recursive dvi-recursive html-recursive info-recursive \
+ install-data-recursive install-dvi-recursive \
+@@ -2117,8 +2106,7 @@
+ test-memory-icon \
+ test-gnupg-key \
+ test-gnupg-collection \
+- test-gnupg-process \
+- test-system-prompt
++ test-gnupg-process
+
+ test_certificate_SOURCES = gcr/test-certificate.c
+ test_certificate_CFLAGS = $(gcr_CFLAGS)
+@@ -2171,9 +2159,6 @@
+ test_subject_public_key_SOURCES = gcr/test-subject-public-key.c
+ test_subject_public_key_CFLAGS = $(gcr_CFLAGS)
+ test_subject_public_key_LDADD = $(gcr_LIBS)
+-test_system_prompt_SOURCES = gcr/test-system-prompt.c
+-test_system_prompt_CFLAGS = $(gcr_CFLAGS)
+-test_system_prompt_LDADD = $(gcr_LIBS)
+ test_trust_SOURCES = gcr/test-trust.c
+ test_trust_CFLAGS = $(gcr_CFLAGS)
+ test_trust_LDADD = $(gcr_LIBS)
+@@ -3283,12 +3268,7 @@
+ test-symkey$(EXEEXT): $(test_symkey_OBJECTS) $(test_symkey_DEPENDENCIES) $(EXTRA_test_symkey_DEPENDENCIES)
+ @rm -f test-symkey$(EXEEXT)
+ $(AM_V_CCLD)$(LINK) $(test_symkey_OBJECTS) $(test_symkey_LDADD) $(LIBS)
+-gcr/test_system_prompt-test-system-prompt.$(OBJEXT): \
+- gcr/$(am__dirstamp) gcr/$(DEPDIR)/$(am__dirstamp)
+
+-test-system-prompt$(EXEEXT): $(test_system_prompt_OBJECTS) $(test_system_prompt_DEPENDENCIES) $(EXTRA_test_system_prompt_DEPENDENCIES)
+- @rm -f test-system-prompt$(EXEEXT)
+- $(AM_V_CCLD)$(test_system_prompt_LINK) $(test_system_prompt_OBJECTS) $(test_system_prompt_LDADD) $(LIBS)
+ gcr/test_trust-test-trust.$(OBJEXT): gcr/$(am__dirstamp) \
+ gcr/$(DEPDIR)/$(am__dirstamp)
+
+@@ -3446,7 +3426,6 @@
+ @AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_secure_memory-test-secure-memory.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_simple_certificate-test-simple-certificate.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_subject_public_key-test-subject-public-key.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_trust-test-trust.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@gcr/$(DEPDIR)/test_util-test-util.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@ui/$(DEPDIR)/frob_certificate-frob-certificate.Po@am__quote@
+@@ -4968,20 +4947,6 @@
+ @AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ @am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_subject_public_key_CFLAGS) $(CFLAGS) -c -o gcr/test_subject_public_key-test-subject-public-key.obj `if test -f 'gcr/test-subject-public-key.c'; then $(CYGPATH_W) 'gcr/test-subject-public-key.c'; else $(CYGPATH_W) '$(srcdir)/gcr/test-subject-public-key.c'; fi`
+
+-gcr/test_system_prompt-test-system-prompt.o: gcr/test-system-prompt.c
+-@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -MT gcr/test_system_prompt-test-system-prompt.o -MD -MP -MF gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo -c -o gcr/test_system_prompt-test-system-prompt.o `test -f 'gcr/test-system-prompt.c' || echo '$(srcdir)/'`gcr/test-system-prompt.c
+-@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Po
+-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='gcr/test-system-prompt.c' object='gcr/test_system_prompt-test-system-prompt.o' libtool=no @AMDEPBACKSLASH@
+-@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -c -o gcr/test_system_prompt-test-system-prompt.o `test -f 'gcr/test-system-prompt.c' || echo '$(srcdir)/'`gcr/test-system-prompt.c
+-
+-gcr/test_system_prompt-test-system-prompt.obj: gcr/test-system-prompt.c
+-@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -MT gcr/test_system_prompt-test-system-prompt.obj -MD -MP -MF gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo -c -o gcr/test_system_prompt-test-system-prompt.obj `if test -f 'gcr/test-system-prompt.c'; then $(CYGPATH_W) 'gcr/test-system-prompt.c'; else $(CYGPATH_W) '$(srcdir)/gcr/test-system-prompt.c'; fi`
+-@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Tpo gcr/$(DEPDIR)/test_system_prompt-test-system-prompt.Po
+-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='gcr/test-system-prompt.c' object='gcr/test_system_prompt-test-system-prompt.obj' libtool=no @AMDEPBACKSLASH@
+-@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_system_prompt_CFLAGS) $(CFLAGS) -c -o gcr/test_system_prompt-test-system-prompt.obj `if test -f 'gcr/test-system-prompt.c'; then $(CYGPATH_W) 'gcr/test-system-prompt.c'; else $(CYGPATH_W) '$(srcdir)/gcr/test-system-prompt.c'; fi`
+-
+ gcr/test_trust-test-trust.o: gcr/test-trust.c
+ @am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(test_trust_CFLAGS) $(CFLAGS) -MT gcr/test_trust-test-trust.o -MD -MP -MF gcr/$(DEPDIR)/test_trust-test-trust.Tpo -c -o gcr/test_trust-test-trust.o `test -f 'gcr/test-trust.c' || echo '$(srcdir)/'`gcr/test-trust.c
+ @am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) gcr/$(DEPDIR)/test_trust-test-trust.Tpo gcr/$(DEPDIR)/test_trust-test-trust.Po
+@@ -5808,13 +5773,6 @@
+ $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
+ --log-file $$b.log --trs-file $$b.trs \
+ $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
+- "$$tst" $(AM_TESTS_FD_REDIRECT)
+-test-system-prompt.log: test-system-prompt$(EXEEXT)
+- @p='test-system-prompt$(EXEEXT)'; \
+- b='test-system-prompt'; \
+- $(am__check_pre) $(LOG_DRIVER) --test-name "$$f" \
+- --log-file $$b.log --trs-file $$b.trs \
+- $(am__common_driver_flags) $(AM_LOG_DRIVER_FLAGS) $(LOG_DRIVER_FLAGS) -- $(LOG_COMPILE) \
+ "$$tst" $(AM_TESTS_FD_REDIRECT)
+ .test.log:
+ @p='$<'; \
diff --git a/gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch b/gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch
new file mode 100644
index 000000000..2e03be8aa
--- /dev/null
+++ b/gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch
@@ -0,0 +1,31 @@
+This patch comes from Debian.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=771052
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835737
+
+--- gcr-3.20.0.old/gcr/test-gnupg-collection.c 2017-06-29 14:26:33.810838197 -0400
++++ gcr-3.20.0/gcr/test-gnupg-collection.c 2017-06-30 17:25:09.149383067 -0400
+@@ -115,6 +115,14 @@
+
+ g_object_unref (test->collection);
+
++ /* remove potential gpg 2.1 extras, ignore any errors. */
++ cmd = g_strdup_printf ("rm -rf %s/*.d", test->directory);
++ system(cmd);
++ g_free(cmd);
++ cmd = g_strdup_printf ("rm -f %s/.gpg-v21-migrated", test->directory);
++ system(cmd);
++ g_free(cmd);
++
+ cmd = g_strdup_printf ("rm -f %s/*", test->directory);
+ g_spawn_check_exit_status (system (cmd), &error);
+ g_assert_no_error (error);
+@@ -202,7 +210,7 @@
+ GcrGnupgKey *key;
+
+ _gcr_gnupg_collection_load_async (test->collection, NULL, on_async_ready, test);
+- egg_test_wait_until (500);
++ egg_test_wait_until (2500);
+ g_assert (test->result);
+ _gcr_gnupg_collection_load_finish (test->collection, test->result, &error);
+ g_assert_no_error (error);
--
2.13.2
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27542@debbugs.gnu.org)
87shie7u9l.fsf@gnu.org
Hello,

Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (7 lines)
> * gnu/packages/patches/gcr-disable-failing-tests.patch,
> gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
> New files.
> * gnu/local.mk (dist_patch_DATA): Add patches.
> * gnu/packages/gnome.scm (gcr)[source]: Use patches.
> [arguments]: Enable tests.

[...]

Toggle quote (5 lines)
> +++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
> @@ -0,0 +1,127 @@
> +This patch removes a group of tests that fail because /var/lib/dbus/machine-id
> +is not present in the build environment.

We usually work around these with:

(setenv "DBUS_FATAL_WARNINGS" "0")

Is it ineffective here?

Thanks,
Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27542@debbugs.gnu.org)
87podiiqr6.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (26 lines)
> Hello,
>
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> * gnu/packages/patches/gcr-disable-failing-tests.patch,
>> gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
>> New files.
>> * gnu/local.mk (dist_patch_DATA): Add patches.
>> * gnu/packages/gnome.scm (gcr)[source]: Use patches.
>> [arguments]: Enable tests.
>
> [...]
>
>> +++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
>> @@ -0,0 +1,127 @@
>> +This patch removes a group of tests that fail because
>> /var/lib/dbus/machine-id
>> +is not present in the build environment.
>
> We usually work around these with:
>
> (setenv "DBUS_FATAL_WARNINGS" "0")
>
> Is it ineffective here?
>

That's good to know, but it doesn't seem to work in this case. I get 18
test failures all from the same group mentioning the missing
'machine-id' file.

Toggle quote (2 lines)
> Thanks,
> Ludo’.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJZWUkNAAoJEOal7jwZRnoNZckP/1DYHiVVhFMObUm8RqcL8upn
tITZdDGJ9KSP89TtzeXB84i+NyjErnyCg+4lhewe00cHAJVTeBwjkJqB8RrpHWe8
iO8uQu0TgT0opVkhkhBXPmOVPFLf6Tkq6PWi/cCyszD2X45oMrhLo0O6cxJzgwja
OihOEnMlEw6ygUZUHgNRKHfdzmlUUp8GCS0OvkfcOWWBpeLG21Vxlk1P84Y2IzUj
p0nCV3Cm53ghvyXjBw/GEBKttZSUeh7ghGXpsSwS7uZ3BmsIXMv1vS0jsOAlFp8H
RATTzxN0zTKdpSm+qKNJtZ6lXmwYz99p0Ff2GHNpow23Z+Cj59Zs/Cvdp+o+GwjX
1jlp9J7iBNuwb1slpFM2XQ4jH8Ma+sXStuLLN2P8vSIblaa2anPEiCMlQI32TZ+f
QtsGKBZS1rG7HCmYs3SfySHo5RbcGL9eNJS+xupFBUgNNAB60l8SuKOeKXuxvE0h
Wg50Mk3GsBF9OBZAVV4x1+v5iUlmtGZvY3LHJjQavVrBnZrjO+JrmZC3QdHQxT/D
4dB4+OU//u1K0hSs4l4u+8dVMhaC18D1S0ZBs3n6Hdl2Ik+ekd2/hmciATTUs034
QExesdMcof+ItOS4oLUKaHKEdnaEpFWHHG2q5QQztejxob67yVE6ZaVLU/Ptg3S1
LRh82ihr21ILVSbGr7dK
=AQUu
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27542@debbugs.gnu.org)
87shie4n1e.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (32 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Hello,
>>
>> Kei Kebreau <kei@openmailbox.org> skribis:
>>
>>> * gnu/packages/patches/gcr-disable-failing-tests.patch,
>>> gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
>>> New files.
>>> * gnu/local.mk (dist_patch_DATA): Add patches.
>>> * gnu/packages/gnome.scm (gcr)[source]: Use patches.
>>> [arguments]: Enable tests.
>>
>> [...]
>>
>>> +++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
>>> @@ -0,0 +1,127 @@
>>> +This patch removes a group of tests that fail because
>>> /var/lib/dbus/machine-id
>>> +is not present in the build environment.
>>
>> We usually work around these with:
>>
>> (setenv "DBUS_FATAL_WARNINGS" "0")
>>
>> Is it ineffective here?
>>
>
> That's good to know, but it doesn't seem to work in this case. I get 18
> test failures all from the same group mentioning the missing
> 'machine-id' file.

Are they really errors and not just warnings (the errors being something
else)?

Also, could it be that some Makefile or script forcefully sets
DBUS_FATAL_WARNINGS to 1, as is the case in ‘python-dbus’?

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27542@debbugs.gnu.org)
87lgo68qjy.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (41 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> ludo@gnu.org (Ludovic Courtès) writes:
>>
>>> Hello,
>>>
>>> Kei Kebreau <kei@openmailbox.org> skribis:
>>>
>>>> * gnu/packages/patches/gcr-disable-failing-tests.patch,
>>>> gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
>>>> New files.
>>>> * gnu/local.mk (dist_patch_DATA): Add patches.
>>>> * gnu/packages/gnome.scm (gcr)[source]: Use patches.
>>>> [arguments]: Enable tests.
>>>
>>> [...]
>>>
>>>> +++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
>>>> @@ -0,0 +1,127 @@
>>>> +This patch removes a group of tests that fail because
>>>> /var/lib/dbus/machine-id
>>>> +is not present in the build environment.
>>>
>>> We usually work around these with:
>>>
>>> (setenv "DBUS_FATAL_WARNINGS" "0")
>>>
>>> Is it ineffective here?
>>>
>>
>> That's good to know, but it doesn't seem to work in this case. I get 18
>> test failures all from the same group mentioning the missing
>> 'machine-id' file.
>
> Are they really errors and not just warnings (the errors being something
> else)?
>
> Also, could it be that some Makefile or script forcefully sets
> DBUS_FATAL_WARNINGS to 1, as is the case in ‘python-dbus’?
>

I see no such setting.

Toggle quote (1 lines)
> Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAllZaJIACgkQ5qXuPBlG
eg0qlA//ZeyGt2m46hUPE8sBzdV5FMW45fFloFtlSHYcURplYm7X5xb6CJTbBT6K
x9yrkRBJwoFW8wnqywy/b3RIYaSQrPjDjOzawHkXPil54BHE4zd6WGcf/vcrGNPm
SxP9Qr4vOBhx4JIvooVI9NP3JDOO5ZhgxGlGoA0ykTtTp7SgvQHQv+bpy+zz1xwt
7Wk0k4puy0XgqnGilOvnrMuNUw1CFFMIv1fry2wUX6SbL23kdYaC/s67QYBSWGXR
j1RKvMZfC7b3hwQ09cEiI/gxW62CLLlZBxaaBBKxx99PpD13ZEhLYPphJXYLUy72
W5rQoIUnevUsx5EiNjWfsc7prGrtfwtxFVnk1Nij6H8ZyhXkjD4tMmTw8yFD3coR
Puut9VVJmaI7Tv0IWJGco4PUw/2eRgEDdAyFUK1Ofnw/ac8FFTEaBTUAC+KJFboz
e7MfoAuxFl9jU1i3mcFHpeoUm5vPJH0VPH3T1wb1niHzc7GhuEeQ+msFfq8QCnxJ
Xk7PP+c+HFfk/7S/aeJb3X37xXuOBmVHVhCCwOsmTg2FI5vJZgSmANloKR7muWNx
VPIcI57DjV0jMs9J+jDR1NUyNv9KAdvHZdyFgkf2sZpUNCWG6h/yYg68OE07f12n
PKqliG4GPOLWp5oV/YyKUkYYOBWtmjWG5DE8UwssmFjXAtcRCis=
=dDF7
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27542@debbugs.gnu.org)
87h8yurn14.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (45 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Kei Kebreau <kei@openmailbox.org> skribis:
>>
>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>
>>>> Hello,
>>>>
>>>> Kei Kebreau <kei@openmailbox.org> skribis:
>>>>
>>>>> * gnu/packages/patches/gcr-disable-failing-tests.patch,
>>>>> gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
>>>>> New files.
>>>>> * gnu/local.mk (dist_patch_DATA): Add patches.
>>>>> * gnu/packages/gnome.scm (gcr)[source]: Use patches.
>>>>> [arguments]: Enable tests.
>>>>
>>>> [...]
>>>>
>>>>> +++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
>>>>> @@ -0,0 +1,127 @@
>>>>> +This patch removes a group of tests that fail because
>>>>> /var/lib/dbus/machine-id
>>>>> +is not present in the build environment.
>>>>
>>>> We usually work around these with:
>>>>
>>>> (setenv "DBUS_FATAL_WARNINGS" "0")
>>>>
>>>> Is it ineffective here?
>>>>
>>>
>>> That's good to know, but it doesn't seem to work in this case. I get 18
>>> test failures all from the same group mentioning the missing
>>> 'machine-id' file.
>>
>> Are they really errors and not just warnings (the errors being something
>> else)?
>>
>> Also, could it be that some Makefile or script forcefully sets
>> DBUS_FATAL_WARNINGS to 1, as is the case in ‘python-dbus’?
>>
>
> I see no such setting.

OK. In that case your patch looks like the right thing to me.

Thank you, and sorry for introducing more delay!

Ludo’.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27542-done@debbugs.gnu.org)
87h8yt8w2r.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (52 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> ludo@gnu.org (Ludovic Courtès) writes:
>>
>>> Kei Kebreau <kei@openmailbox.org> skribis:
>>>
>>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>>
>>>>> Hello,
>>>>>
>>>>> Kei Kebreau <kei@openmailbox.org> skribis:
>>>>>
>>>>>> * gnu/packages/patches/gcr-disable-failing-tests.patch,
>>>>>> gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
>>>>>> New files.
>>>>>> * gnu/local.mk (dist_patch_DATA): Add patches.
>>>>>> * gnu/packages/gnome.scm (gcr)[source]: Use patches.
>>>>>> [arguments]: Enable tests.
>>>>>
>>>>> [...]
>>>>>
>>>>>> +++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
>>>>>> @@ -0,0 +1,127 @@
>>>>>> +This patch removes a group of tests that fail because
>>>>>> /var/lib/dbus/machine-id
>>>>>> +is not present in the build environment.
>>>>>
>>>>> We usually work around these with:
>>>>>
>>>>> (setenv "DBUS_FATAL_WARNINGS" "0")
>>>>>
>>>>> Is it ineffective here?
>>>>>
>>>>
>>>> That's good to know, but it doesn't seem to work in this case. I get 18
>>>> test failures all from the same group mentioning the missing
>>>> 'machine-id' file.
>>>
>>> Are they really errors and not just warnings (the errors being something
>>> else)?
>>>
>>> Also, could it be that some Makefile or script forcefully sets
>>> DBUS_FATAL_WARNINGS to 1, as is the case in ‘python-dbus’?
>>>
>>
>> I see no such setting.
>
> OK. In that case your patch looks like the right thing to me.
>
> Thank you, and sorry for introducing more delay!
>

I'd rather be safe than sorry! Thanks for the review.

Pushed to master as 85c774808fc13a0adc603784b2358a7c285c4822.

Toggle quote (1 lines)
> Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAllaTJwACgkQ5qXuPBlG
eg3loA//Wrfu0cBnxLpDT9ltrbEFtgmaGgT0ahT5WTvRMVEszkc9Q9npecB0wGyR
qq3KUYHccRk6yYm++C04C4Lxl+CqTf/KrzD1mejqgVnH5luwgpzgq5ZvGTa5Rpat
2SdbUDiS0SmANAuhVXqnxnwYZ4S71hlCB2qLvaQbsr/tqO5dd98pgmR+E6O1ZYGf
Qc7bSw4LyAdN6ULpQoNOqKCWOeaAxILWpBxlRClBH7up4bL2U5fWJFUqxPIBudiR
r7b4RLuYQXoBsnDXuOfk9w/rlY3E8wUVLJ+1FPmteqkBVCmQf9MH7zxfCY166nb1
gq80tujWx6DipzNeh98+JrvwLU1NcQfVOZUdn42KOLHuMZJAWhnmrLpCpqP+J9Su
ktfSGPnL9pGA28UaVkPsmv3qvRc+tLb2LSrJpy44TlVVzKvlhzRh77tAyfztIWM7
tfDJc2O1xoWdv+6RV76UYqCaoYhyLLI2HvYz4fkrad4npje2E5Wz4U+SZABLITNd
vYIU1Kxsao1XS8/kN/ZzHdRSga/lZPvSHWj2yvgtgUp8jZluM7+nmBo44YsLCUYC
wtUcHP88/hJ7tvYqxW+/SQRtNCkw+wO5ZmDApiaBwFer/8BF+9hcI5Ij9+N45W6w
PmTb5mLr9F+6YxrMZXQseyetGAxzvp0VMbv+TsG/lCBgewgOh9Y=
=I6Zg
-----END PGP SIGNATURE-----

Closed
Roel Janssen wrote 8 years ago
Re: bug#27542: [PATCH] gnu: gcr: Enable working tests.
(name . Kei Kebreau)(address . kei@openmailbox.org)
87inj9feuc.fsf@gnu.org
Kei Kebreau writes:

Toggle quote (60 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Kei Kebreau <kei@openmailbox.org> skribis:
>>
>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>
>>>> Kei Kebreau <kei@openmailbox.org> skribis:
>>>>
>>>>> ludo@gnu.org (Ludovic Courtès) writes:
>>>>>
>>>>>> Hello,
>>>>>>
>>>>>> Kei Kebreau <kei@openmailbox.org> skribis:
>>>>>>
>>>>>>> * gnu/packages/patches/gcr-disable-failing-tests.patch,
>>>>>>> gnu/packages/patches/gcr-fix-collection-tests-to-work-with-gpg-21.patch:
>>>>>>> New files.
>>>>>>> * gnu/local.mk (dist_patch_DATA): Add patches.
>>>>>>> * gnu/packages/gnome.scm (gcr)[source]: Use patches.
>>>>>>> [arguments]: Enable tests.
>>>>>>
>>>>>> [...]
>>>>>>
>>>>>>> +++ b/gnu/packages/patches/gcr-disable-failing-tests.patch
>>>>>>> @@ -0,0 +1,127 @@
>>>>>>> +This patch removes a group of tests that fail because
>>>>>>> /var/lib/dbus/machine-id
>>>>>>> +is not present in the build environment.
>>>>>>
>>>>>> We usually work around these with:
>>>>>>
>>>>>> (setenv "DBUS_FATAL_WARNINGS" "0")
>>>>>>
>>>>>> Is it ineffective here?
>>>>>>
>>>>>
>>>>> That's good to know, but it doesn't seem to work in this case. I get 18
>>>>> test failures all from the same group mentioning the missing
>>>>> 'machine-id' file.
>>>>
>>>> Are they really errors and not just warnings (the errors being something
>>>> else)?
>>>>
>>>> Also, could it be that some Makefile or script forcefully sets
>>>> DBUS_FATAL_WARNINGS to 1, as is the case in ‘python-dbus’?
>>>>
>>>
>>> I see no such setting.
>>
>> OK. In that case your patch looks like the right thing to me.
>>
>> Thank you, and sorry for introducing more delay!
>>
>
> I'd rather be safe than sorry! Thanks for the review.
>
> Pushed to master as 85c774808fc13a0adc603784b2358a7c285c4822.
>
>> Ludo’.

Not sure if this is related, but I now get:

...
gcr-3.20.0/ui/gcr-prompt-dialog.c
gcr-3.20.0/README
patching file Makefile.in
Hunk #7 FAILED at 3268.
1 out of 10 hunks FAILED -- saving rejects to file Makefile.in.rej
source is under 'gcr-3.20.0'
applying '/gnu/store/8dizfkad578r7n3iwafhmi9ckfnhx7lc-gcr-disable-failing-tests.patch'...
builder for `/gnu/store/b5p4nsrnsf55krjidq53mw93xcwbqzyb-gcr-3.20.0.tar.xz.drv' failed to produce output path `/gnu/st
ore/ram3idajh7jwxk18k6ixaccgq0arigrx-gcr-3.20.0.tar.xz'
...

Does gcr build for you?

Kind regards,
Roel Janssen
Closed
Kei Kebreau wrote 8 years ago
(name . Roel Janssen)(address . roel@gnu.org)
87shid6sxb.fsf@openmailbox.org
Roel Janssen <roel@gnu.org> writes:

Toggle quote (21 lines)
>
> Not sure if this is related, but I now get:
>
> ...
> gcr-3.20.0/ui/gcr-prompt-dialog.c
> gcr-3.20.0/README
> patching file Makefile.in
> Hunk #7 FAILED at 3268.
> 1 out of 10 hunks FAILED -- saving rejects to file Makefile.in.rej
> source is under 'gcr-3.20.0'
> applying
> '/gnu/store/8dizfkad578r7n3iwafhmi9ckfnhx7lc-gcr-disable-failing-tests.patch'...
> builder for
> `/gnu/store/b5p4nsrnsf55krjidq53mw93xcwbqzyb-gcr-3.20.0.tar.xz.drv'
> failed to produce output path `/gnu/st
> ore/ram3idajh7jwxk18k6ixaccgq0arigrx-gcr-3.20.0.tar.xz'
> ...
>
> Does gcr build for you?
>

No... I've committed a corrective patch to master. I must have
accidentally used an old revision of the patch.

Toggle quote (2 lines)
> Kind regards,
> Roel Janssen
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAllayRAACgkQ5qXuPBlG
eg2XcQ/9GYb0wXPsTrR7FkioDDwQpI+RYo6kXf5T8EbY87ZBCghBZEd8f7/+46KM
ahhAS7kTt8ahEIQu3Zceiqsl036qo2/Ur7nFwVSE74Hjx78a71hmoKi3iFES4ABB
aDc49PJirkpizCoDLI8wX31emm1JwZ0duzkbOtxHWQ/cXJW2UGQ3DRZxqgBPH8t5
I9Gy8fFz499PLr5eXWeQrFd0Jex2bWsNoksIxDwzSx0YWtnilk9Harvfd9lIOZ16
KwsL4hhWz4A0mWiLV/YNHx7LQszZDnchaxPtKKHtHLzmBc3iODAgwG0AiB3+Q1D0
PuyzVIVf5tqk53F0gCXjR1nq85SZ2iR3uUjIgNLLp+c1Mlxs/6tiWl0btP+9BpKW
Bt7AMBVf0VzY3YAZ/VcDOJjWQDznG1417YJqPQt8Wn1nh2583WPQJKWvsRTBZbeR
9UhkPrVztZQiwAnz6bLfAdBgnl49Znn5WRsIgJfV2zi6FS1mSKM4WzkToLdX5ILc
RZSWtaewLvPs2JeDBC5zN/1OBZOnMrVLtMkV9Jw0SMefs1dXSqXImURT8SnHkaHe
mPRGbyYplr/illhlOEHH/mlbW2iqF2owMsde+Ot/TG5t4OTBjUX/EMYA0IKgPC9E
NOJgRvzKjY7bTvz96ZVzAhTYTqFGPb4oMVqfVwfozQVhfqIWMhU=
=5/+a
-----END PGP SIGNATURE-----

Closed
Roel Janssen wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87fuecr8y2.fsf@gnu.org
Kei Kebreau writes:

Toggle quote (26 lines)
> Roel Janssen <roel@gnu.org> writes:
>
>>
>> Not sure if this is related, but I now get:
>>
>> ...
>> gcr-3.20.0/ui/gcr-prompt-dialog.c
>> gcr-3.20.0/README
>> patching file Makefile.in
>> Hunk #7 FAILED at 3268.
>> 1 out of 10 hunks FAILED -- saving rejects to file Makefile.in.rej
>> source is under 'gcr-3.20.0'
>> applying
>> '/gnu/store/8dizfkad578r7n3iwafhmi9ckfnhx7lc-gcr-disable-failing-tests.patch'...
>> builder for
>> `/gnu/store/b5p4nsrnsf55krjidq53mw93xcwbqzyb-gcr-3.20.0.tar.xz.drv'
>> failed to produce output path `/gnu/st
>> ore/ram3idajh7jwxk18k6ixaccgq0arigrx-gcr-3.20.0.tar.xz'
>> ...
>>
>> Does gcr build for you?
>>
>
> No... I've committed a corrective patch to master. I must have
> accidentally used an old revision of the patch.

Thanks for the corrective patch. :)

Kind regards,
Roel Janssen
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27542@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27542
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help