[PATCH] gnu: Add toxic.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Theodoros Foradis
Owner
unassigned
Submitted by
Theodoros Foradis
Severity
normal
T
T
Theodoros Foradis wrote on 30 Jun 2017 20:51
(address . guix-patches@gnu.org)(name . Theodoros Foradis)(address . theodoros.for@openmailbox.org)
20170630185123.13541-1-theodoros.for@openmailbox.org
* gnu/packages/messaging.scm (toxic): New variable.
---
gnu/packages/messaging.scm | 51 ++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (83 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 425a7c4c2..cac2084dc 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Theodoros Foradis <theodoros.for@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages libcanberra)
@@ -74,6 +76,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages admin)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages qt)
@@ -1394,4 +1397,52 @@ RFC standards as well as non-standard but popular features. It can be used for
building the IRC clients and bots.")
(license license:lgpl3+)))
+(define-public toxic
+ (package
+ (name "toxic")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/JFreegman/toxic/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0166lqb47f4kj34mhi57aqmnk9mh4hsicmbdsj6ag54sy1zicy20"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'enable-python-scripting
+ (lambda _
+ (setenv "ENABLE_PYTHON" "1"))))))
+ (inputs
+ `(("c-toxcore" ,c-toxcore)
+ ("curl" ,curl)
+ ("freealut" ,freealut)
+ ("gdk-pixbuf" ,gdk-pixbuf) ; for libnotify.pc
+ ("libconfig" ,libconfig)
+ ("libnotify" ,libnotify)
+ ("libpng" ,libpng)
+ ("libvpx" ,libvpx)
+ ("libx11" ,libx11)
+ ("ncurses" ,ncurses)
+ ("openal" ,openal)
+ ("python" ,python)
+ ("qrencode" ,qrencode)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/JFreegman/toxic")
+ (synopsis "Tox chat client using ncurses")
+ (description "@code{toxic} is a Tox-based instant messenging client
+which formerly resided in the Tox core repository,and is now available
+as a standalone application.")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.13.1
L
L
Ludovic Courtès wrote on 2 Jul 2017 17:04
(name . Theodoros Foradis)(address . theodoros.for@openmailbox.org)(address . 27540@debbugs.gnu.org)
87wp7q7ucp.fsf@gnu.org
Hi!

Theodoros Foradis <theodoros.for@openmailbox.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/messaging.scm (toxic): New variable.

[...]

Toggle quote (4 lines)
> + (add-before 'build 'enable-python-scripting
> + (lambda _
> + (setenv "ENABLE_PYTHON" "1"))))))

Please return #t at the end of the phase, to explicitly denote success.

Toggle quote (6 lines)
> + (synopsis "Tox chat client using ncurses")
> + (description "@code{toxic} is a Tox-based instant messenging client
> +which formerly resided in the Tox core repository,and is now available
> +as a standalone application.")

One minor request: could the description focus on the functionality
(“console-based instant messaging program that does this and that”)
rather than on its history? That should be more helpful to users
looking for a Tox client.

Apart from that it LGTM. Could you send an updated patch?

Thank you!

Ludo’.
T
T
Theodoros Foradis wrote on 2 Jul 2017 20:24
[PATCH v2] gnu: Add toxic.
(address . 27540@debbugs.gnu.org)
20170702182416.27509-1-theodoros.for@openmailbox.org
* gnu/packages/messaging.scm (toxic): New variable.
---
gnu/packages/messaging.scm | 52 ++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (84 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 425a7c4c2..2c9724366 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Theodoros Foradis <theodoros.for@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages libcanberra)
@@ -74,6 +76,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages admin)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages qt)
@@ -1394,4 +1397,53 @@ RFC standards as well as non-standard but popular features. It can be used for
building the IRC clients and bots.")
(license license:lgpl3+)))
+(define-public toxic
+ (package
+ (name "toxic")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/JFreegman/toxic/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0166lqb47f4kj34mhi57aqmnk9mh4hsicmbdsj6ag54sy1zicy20"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'enable-python-scripting
+ (lambda _
+ (setenv "ENABLE_PYTHON" "1")
+ #t)))))
+ (inputs
+ `(("c-toxcore" ,c-toxcore)
+ ("curl" ,curl)
+ ("freealut" ,freealut)
+ ("gdk-pixbuf" ,gdk-pixbuf) ; for libnotify.pc
+ ("libconfig" ,libconfig)
+ ("libnotify" ,libnotify)
+ ("libpng" ,libpng)
+ ("libvpx" ,libvpx)
+ ("libx11" ,libx11)
+ ("ncurses" ,ncurses)
+ ("openal" ,openal)
+ ("python" ,python)
+ ("qrencode" ,qrencode)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/JFreegman/toxic")
+ (synopsis "Tox chat client using ncurses")
+ (description "@code{toxic} is a console-based instant messaging client,
+using @code{c-toxcore} and @code{ncurses}. It provides audio calls, sound and
+desktop notifications, and python scripting support.")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.13.1
L
L
Ludovic Courtès wrote on 2 Jul 2017 21:59
(name . Theodoros Foradis)(address . theodoros.for@openmailbox.org)(address . 27540-done@debbugs.gnu.org)
8760fa624p.fsf@gnu.org
Thanks, applied with the minor changes below (the first one reported by
‘guix lint’, and the removal of @code because “Toxic” and “ncurses” are
a proper names.)

Ludo’.
Toggle diff (27 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2c9724366..aefd24b84 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1407,7 +1407,8 @@ building the IRC clients and bots.")
version ".tar.gz"))
(sha256
(base32
- "0166lqb47f4kj34mhi57aqmnk9mh4hsicmbdsj6ag54sy1zicy20"))))
+ "0166lqb47f4kj34mhi57aqmnk9mh4hsicmbdsj6ag54sy1zicy20"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1441,9 +1442,9 @@ building the IRC clients and bots.")
`(("pkg-config" ,pkg-config)))
(home-page "https://github.com/JFreegman/toxic")
(synopsis "Tox chat client using ncurses")
- (description "@code{toxic} is a console-based instant messaging client,
-using @code{c-toxcore} and @code{ncurses}. It provides audio calls, sound and
-desktop notifications, and python scripting support.")
+ (description "Toxic is a console-based instant messaging client, using
+c-toxcore and ncurses. It provides audio calls, sound and desktop
+notifications, and Python scripting support.")
(license license:gpl3+)))
;;; messaging.scm ends here
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27540@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27540
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch