[PATCH] gnu: Add procenv.

  • Done
  • quality assurance status badge
Details
2 participants
  • Dave Love
  • Ludovic Courtès
Owner
unassigned
Submitted by
Dave Love
Severity
normal
D
D
Dave Love wrote on 26 Jun 2017 16:28
(address . guix-patches@gnu.org)
87h8z2962r.fsf@c-l07itc0gcrgz.its.manchester.ac.uk
* gnu/packages/linux.scm (procenv): New variable.
---
gnu/packages/linux.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ec950d227..e5c7112c3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -98,6 +98,8 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages groff)
+ #:use-module (gnu packages selinux)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -4180,3 +4182,28 @@ NexGen, Rise, and SiS CPUs.")
to data over the Media Transfer Protocol (MTP). Unprivileged users can mount
the MTP device as a filesystem.")
(license license:gpl3)))
+
+(define-public procenv
+ (package
+ (name "procenv")
+ (version "0.49")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/jamesodhunt/procenv/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0brzf6185hb76imw107cl21c8lzwiywkxi3jknihrk86bvvicd0d"))))
+ (build-system gnu-build-system)
+ (arguments `(#:configure-flags '("--disable-silent-rules")))
+ (inputs `(("expat" ,expat) ("libcap" ,libcap) ("check" ,check)
+ ("groff" ,groff) ; for tests
+ ("libselinux" ,libselinux)))
+ (synopsis "Utility to show process environment")
+ (description "Procenv is a command-line tool that displays as much detail about
+itself and its environment as possible. It can be used as a test
+tool, to understand the type of environment a process runs in, and for
+comparing system environments.")
+ (home-page "http://github.com/jamesodhunt/procenv/")
+ (license license:gpl3+)))
--
2.11.0
L
L
Ludovic Courtès wrote on 29 Jun 2017 15:11
(name . Dave Love)(address . fx@gnu.org)(address . 27499-done@debbugs.gnu.org)
87podnndlh.fsf@gnu.org
Hi,

Dave Love <fx@gnu.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (procenv): New variable.

I added a copyright line for you in that file and committed. Thanks!

Ludo’.
Closed
?