[PATCH] gnu: Add python-pass-git-helper.

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Jelle Licht
  • Jelle Licht
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal

Debbugs page

Jelle Licht wrote 8 years ago
(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
20170625123947.5031-1-jlicht@fsfe.org
* gnu/packages/password-utils.scm (python-pass-git-helper): New variable.
---
gnu/packages/password-utils.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9cfacdb42..55b6e2a04 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages aidc)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
@@ -410,3 +411,38 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
(define-public python2-bcrypt
(package-with-python2 python-bcrypt))
+
+(define-public python-pass-git-helper
+ (package
+ (name "python-pass-git-helper")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pass-git-helper" version))
+ (sha256
+ (base32
+ "1zxzwljz8zqayd6dcai6y9qkj2ingbk89z20hqqvcr62a5bjks7v"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-pass-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((password-store (assoc-ref inputs "password-store"))
+ (pass (string-append password-store
+ "/bin/pass")))
+ (substitute* "pass-git-helper"
+ (("'pass'") (string-append "'" pass "'")))
+ #t))))))
+ (inputs
+ `(("python-pyxdg" ,python-pyxdg)
+ ("password-store" ,password-store)))
+ (home-page "https://github.com/languitar/pass-git-helper")
+ (synopsis "Git credential helper interfacing with pass")
+ (description
+ "A git credential helper implementation which allows to use pass, the
+standard unix password manager, as the credential backend for your git
+repositories. This is achieved by explicitly defining mappings between hosts
+and entries in the password store.")
+ (license license:lgpl3)))
--
2.13.1
Arun Isaac wrote 8 years ago
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 27483@debbugs.gnu.org)
c5e215c5.AEEAMX9gutgAAAAAAAAAAAPNjeEAAAACwQwAAAAAAAW9WABZT_F4@mailjet.com
Thanks for the patch!

Toggle quote (4 lines)
> +(define-public python-pass-git-helper
> + (package
> + (name "python-pass-git-helper")

Since, this is an application, not a python library, this package should
not have the "python-" prefix. It should just be called pass-git-helper.

Toggle quote (2 lines)
> + (version "0.3")

The latest version is 0.3.1. However, this is only available on the
project's github releases page. Could you try with that?


Toggle quote (6 lines)
> + (description
> + "A git credential helper implementation which allows to use pass, the
> +standard unix password manager, as the credential backend for your git
> +repositories. This is achieved by explicitly defining mappings between hosts
> +and entries in the password store.")

Descriptions should use full sentences. Could you rephrase the first
sentence to comply?


Toggle quote (2 lines)
> + (license license:lgpl3)))

The license is lgpl3+. Look at line 17 of setup.py.

Everything else LGTM. Could you send an updated patch?
Jelle Licht wrote 8 years ago
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
871sq83q8m.fsf@gmail.com
Arun Isaac <arunisaac@systemreboot.net> writes:
Toggle quote (33 lines)
> Thanks for the patch!
>
>> +(define-public python-pass-git-helper
>> + (package
>> + (name "python-pass-git-helper")
>
> Since, this is an application, not a python library, this package should
> not have the "python-" prefix. It should just be called pass-git-helper.
>
>> + (version "0.3")
>
> The latest version is 0.3.1. However, this is only available on the
> project's github releases page. Could you try with that?
>
> https://github.com/languitar/pass-git-helper/releases
>
>> + (description
>> + "A git credential helper implementation which allows to use pass, the
>> +standard unix password manager, as the credential backend for your git
>> +repositories. This is achieved by explicitly defining mappings between hosts
>> +and entries in the password store.")
>
> Descriptions should use full sentences. Could you rephrase the first
> sentence to comply?
>
> https://www.gnu.org/software/guix/manual/html_node/Synopses-and-Descriptions.html
>
>> + (license license:lgpl3)))
>
> The license is lgpl3+. Look at line 17 of setup.py.
>
> Everything else LGTM. Could you send an updated patch?

Done!
From 9b818abc4d313f42efa6f052830050b0e376a073 Mon Sep 17 00:00:00 2001
From: Jelle Licht <jlicht@fsfe.org>
Date: Sun, 25 Jun 2017 14:38:40 +0200
Subject: [PATCH] gnu: Add pass-git-helper.

* gnu/packages/password-utils.scm (pass-git-helper): New variable.
---
gnu/packages/password-utils.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9cfacdb42..bad52dd22 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages aidc)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
@@ -410,3 +411,39 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
(define-public python2-bcrypt
(package-with-python2 python-bcrypt))
+
+(define-public pass-git-helper
+ (package
+ (name "pass-git-helper")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/languitar/pass-git-helper/"
+ "archive/release-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lz5ncy44pz7z1j2nnyildx8sq33zi3xvg5nkwg25n11nasqh2xn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-pass-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((password-store (assoc-ref inputs "password-store"))
+ (pass (string-append password-store
+ "/bin/pass")))
+ (substitute* "pass-git-helper"
+ (("'pass'") (string-append "'" pass "'")))
+ #t))))))
+ (inputs
+ `(("python-pyxdg" ,python-pyxdg)
+ ("password-store" ,password-store)))
+ (home-page "https://github.com/languitar/pass-git-helper")
+ (synopsis "Git credential helper interfacing with pass")
+ (description
+ "pass-git-helper is a git credential helper which allows to use pass, the
+standard unix password manager, as the credential backend for your git
+repositories. This is achieved by explicitly defining mappings between hosts
+and entries in the password store.")
+ (license license:lgpl3+)))
--
2.13.1
Arun Isaac wrote 8 years ago
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 27483-done@debbugs.gnu.org)
fb7030de.AEQAMJnnolIAAAAAAAAAAAPNlDgAAAACwQwAAAAAAAW9WABZUCD2@mailjet.com
Pushed! Thanks!

I added a copyright header for you, and made a few other minor stylistic
changes.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27483@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27483
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help