[PATCH] gnu: acl: Enable tests.

  • Done
  • quality assurance status badge
Details
4 participants
  • Kei Kebreau
  • Kei Kebreau
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170624180606.1230-1-kei@openmailbox.org
* gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add 'patch-tests' phase.
---
gnu/packages/acl.scm | 23 +++++++++++++++++------
1 file changed, 17 insertions(+), 6 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/acl.scm b/gnu/packages/acl.scm
index ae6764993..34f8c294a 100644
--- a/gnu/packages/acl.scm
+++ b/gnu/packages/acl.scm
@@ -44,19 +44,30 @@
(patches (search-patches "acl-hurd-path-max.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; FIXME: Investigate test suite failures
- #:test-target "tests"
+ `(#:test-target "tests"
#:phases
(alist-cons-after
'build 'patch-exec-bin-sh
(lambda _
(substitute* "test/run"
(("/bin/sh") (which "sh"))))
- (alist-replace
- 'install
+ (alist-cons-before
+ 'check 'patch-tests
(lambda _
- (zero? (system* "make" "install" "install-lib" "install-dev")))
- %standard-phases))))
+ ;; The coreutils do not have an ACL bit to remove from their
+ ;; output, so the sed expression that removes the bit is disabled.
+ (substitute* "test/sbits-restore.test"
+ (("\\| sed.*'") ""))
+ ;; These tests require the existence of a user named "bin", but
+ ;; this user does not exist within Guix's build environment.
+ (for-each (lambda (file)
+ (delete-file (string-append "test/" file)))
+ '("setfacl-X.test" "cp.test" "misc.test")))
+ (alist-replace
+ 'install
+ (lambda _
+ (zero? (system* "make" "install" "install-lib" "install-dev")))
+ %standard-phases)))))
(inputs `(("attr" ,attr)))
(native-inputs
`(("gettext" ,gettext-minimal)
--
2.13.1
Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27477@debbugs.gnu.org)
20170624182222.GA8908@jasmine.lan
On Sat, Jun 24, 2017 at 02:06:06PM -0400, Kei Kebreau wrote:
Toggle quote (2 lines)
> * gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add 'patch-tests' phase.

Great!

But we'll probably need to wait for the next core-updates cycle. I've
applied to locally to a core-updates-next branch but it would be great
if you kept it around for the next cycle :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAllOrdoACgkQJkb6MLrK
fwiBpRAAq+2qYW+qZsVmYuRVt+o0y1uhh+B1/tgdcQWy5Tw2Y6mWcJC42jY2a9FI
yWgHC9TX1aWDbbz1vrYFuE8NbY2RbNutMOFVShGEMlW2Vz+WNubWLYJepJ4Z07Mv
N9qEYwxqWz+P+37hFRbPbtYUJNXeyVXq4tP9tsF/c3q/4HkEZZMWXBh9iHzLy69K
5907qv+btEIczsWJgXR6RkIduy9pE+nL4H2b1FBFwKczAZhiFsCJiGCAf2OsK6U6
6+2Zmp4DYz4NI62Qc701A/oCGxD5HPq1/B4TC0NqcIhxUUH7xIhZ79Jog6HpNRKC
iBF5Tf+pI5prsOiGe69z8wlta28DHdyRDSfgqJOolr0RHXN0F50L+rQAkK24/O2j
PBarY2f94UOmcNJ7wbgevpat2g8kUhxjKCv5L6CvbZ1uIRANvt5X9v+bDEENYsyO
q5/+z7huDV+3R+xP/C0ouW5IgXBu3Q79wc7QzAFphHrJN/lXyPGievAwvSvteivD
TYWjE/QZP2W+wsMf3aqWdF3Fxx3OnkSlauF4mPKSG6Pqksd4xk0oTU4sMWe4v0RO
Fg/YXzV40wZ6r/6ef49qWwuoLX0qTH3cqv8y5+Z/o4hERFxGMw9aMrocpwEoZXlG
G4gCA7lesELgOsAJ4OLLqOGTwBKgT9lL6mmOPNKdY9TS5WNvahU=
=CChT
-----END PGP SIGNATURE-----


Kei Kebreau wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 27477@debbugs.gnu.org)
878tkebz88.fsf@openmailbox.org
Leo Famulari <leo@famulari.name> writes:

Toggle quote (10 lines)
> On Sat, Jun 24, 2017 at 02:06:06PM -0400, Kei Kebreau wrote:
>> * gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add
>> 'patch-tests' phase.
>
> Great!
>
> But we'll probably need to wait for the next core-updates cycle. I've
> applied to locally to a core-updates-next branch but it would be great
> if you kept it around for the next cycle :)

Cool. I'll hold on to the patch!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAllRGekACgkQ5qXuPBlG
eg0LXhAApIRwAxT/jWI5AAzCZdgtLluNaQxOt7RLZzh8MOmhqYdStzO7flzAB7Ak
1kMby3RDvldNS/PF1LMhJr7bG3u3K+DgwnqwpcBH3ODRnA7YcHbq/XA59ELufsvL
aOXph/I9Xu0Q3fCbrUG/Jf0/zbryNNAWxVX2qmkrJ71IqBBhoL0F7zZ+yf8QnMny
VdHtQ/Ls+OYZ1pBlkL+E+z5QjQ4p1SNbQc4YXj+SIpDs4i5r8hhKtNHqwtmERsye
79ZGrtRoUQGL3QyROyIUTDrZvHIqQRV911FZy6VsbxdSXQ+T3XLZ8JHuzIVVJyJF
YfmoH9TpRWUzUjys/ylNnfZ+NhWkLZhBBX7CDNpl7gHPQdmyJ/bNwBubhMczG8eD
paq/KI4RjRmzVWK07Ya0pneKGlkjJ9oyHcXvuKRSMG2Gt5EigNwJD5k3HvcUZLOp
Yhc/Np+P+E4aj73NnTPJ67jde88je5n0Zccu71tDckIcODmXKGAHJIZqN45ylomd
iN44OtFg89O07vzkLwXUDTfRy2/hHAxfjNiZufyKfXR1bL+RaiIlVCCk9eDQRCxA
WifCH5WuorS/Elf9dh4SjEm+g/Xq9uWZkXmUHyTfeyQq8zydbljEH3tbkpa0UooT
KjOIjCStHof4fvCauk9b3EYVegddSmghZIP7EkFLp3lJCOV/LHM=
=YOIK
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87wp5989y3.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (14 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> On Sat, Jun 24, 2017 at 02:06:06PM -0400, Kei Kebreau wrote:
>>> * gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add
>>> 'patch-tests' phase.
>>
>> Great!
>>
>> But we'll probably need to wait for the next core-updates cycle. I've
>> applied to locally to a core-updates-next branch but it would be great
>> if you kept it around for the next cycle :)
>
> Cool. I'll hold on to the patch!

Now is the time to try the patch on ‘core-updates’!

Ludo’.
Kei Kebreau wrote 7 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87vaklbdfq.fsf@posteo.net
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (20 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> Leo Famulari <leo@famulari.name> writes:
>>
>>> On Sat, Jun 24, 2017 at 02:06:06PM -0400, Kei Kebreau wrote:
>>>> * gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add
>>>> 'patch-tests' phase.
>>>
>>> Great!
>>>
>>> But we'll probably need to wait for the next core-updates cycle. I've
>>> applied to locally to a core-updates-next branch but it would be great
>>> if you kept it around for the next cycle :)
>>
>> Cool. I'll hold on to the patch!
>
> Now is the time to try the patch on ‘core-updates’!
>
> Ludo’.

Aw, I missed this becuase of my email migration. I'll catch it next time
as long as this message makes it to kkebreau@posteo.net instead of
kei@openmailbox.org.

Thanks in advance.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlm6iDoACgkQ5qXuPBlG
eg2nbhAAvW3/gSjU7VkXXajUSy/89GoOLrO7bMqvWZ80RmWtXQukjrMIvuPi90KG
8m4Zz9f5C1sFQa5KNSfJd5OK2jkUU4cPm3oQnapQLpqlydpSymmSYq7tsW1YCdaI
o6nauMf2i9mAWtS5VA6uLj/nIHkreuFBAgbGkqSGsx59Pccup/SG4ELQOvGAZi6F
Ph/dSFpw49v8ii0daZeIe+xuY82pFz9p8ydW87XnP2TGWhgworSF0FzhiOdxNbAB
iT5B1WZCrRp6j2nMfjtAKFG9fssHoF2xo/qAuuD70xQJ3/AqzSTMz6znuKkIJ86h
XvdhAjc1m/EgqIgOWq/eb87+z3nS1WnCTBsBWwDBGdYMGHGZxkScpcAvOum5txhd
CUSuaAHSHsV9nhT/vx2ohgPBBQHKef+CHiNP+6AluScErOvnXl96rwxRMWdky9Oa
hLj7QppIze+NUDCFOmpLG7pLPbgIajld/3V8qsmeE4qTbUMJKqqJzTJRsSphSpFw
rmt+vhBPtu4csJDTlXm4nd6MCPi4s58xmDqW0K9ECgvILapHB63sBK66BPbxYH0N
pqMf+2ZewML1f59ft5BdHpsfTa697ckqJ4Cf3N+jpbYOivl5rsXMuXAlHXNSgsxc
1pGpY2QwV7httgXdM/mtfGLqyxRC20nptNyteT+kBakxvKpWPu4=
=uzh2
-----END PGP SIGNATURE-----

Leo Famulari wrote 7 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)
20171104145233.GA11323@jasmine.lan
On Thu, Sep 14, 2017 at 09:46:33AM -0400, Kei Kebreau wrote:
Toggle quote (28 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
> > Kei Kebreau <kei@openmailbox.org> skribis:
> >
> >> Leo Famulari <leo@famulari.name> writes:
> >>
> >>> On Sat, Jun 24, 2017 at 02:06:06PM -0400, Kei Kebreau wrote:
> >>>> * gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add
> >>>> 'patch-tests' phase.
> >>>
> >>> Great!
> >>>
> >>> But we'll probably need to wait for the next core-updates cycle. I've
> >>> applied to locally to a core-updates-next branch but it would be great
> >>> if you kept it around for the next cycle :)
> >>
> >> Cool. I'll hold on to the patch!
> >
> > Now is the time to try the patch on ‘core-updates’!
> >
> > Ludo’.
>
> Aw, I missed this becuase of my email migration. I'll catch it next time
> as long as this message makes it to kkebreau@posteo.net instead of
> kei@openmailbox.org.
>
> Thanks in advance.

I amended this patch to apply and pushed it as
2d433b5363fecba0d63caa1844c937dec4ccc23b.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAln91DAACgkQJkb6MLrK
fwjHBRAApYWK7LinouAAfEpKBLh1SYD4ARxZpUPpawEtoS7fn0Z91k236+1IjmR6
uN/rmNoQeRztYm/QOHZK2U2HSNOKjJqUf69nbvi8JVgCpUjeTI10jSUlF0abvkBv
nuh8GOuuHU3zn5UaaKMq4pj45FKVSGilbw6KCJnPhktGZ/GW6gTewOH4/bhO5Qig
FvyBBnybLlBVZrcGKn48cuSmqafVbnpbwaZv2ca9E8DQ3ukAsvivt9g+xLyb3bMr
OEowQo00tgZdooWWRMkIDAMirzzpHxOaqWycVj53m+6Dkd9l/JAdWF4T2zOtedP4
Oa8aAW88+cbn8rvXENAecgrTwZDhijkNKf7i0lKDcvI4Ka1KQZtwyEwUGtjT7Don
NucMEcPdpoZHhnxTLytVfP5YlggGCBN9UjZJKU4L1q91PyCt/yxB8t9mPS+w6ZvC
5XFh7+tXEoKUZoGwwgW/jlj6euAGPP+do65lIuxjFl2DK0HM1CZyrAYtc6YGxdkn
gq2rOyIH1YB6bgXEUHQiTY9to76jy7yU4CNCrkXki7gN4db71/cN5SwNqWL1CZQv
AKTUq9C4GCiIDywOIjcS7moMr1fkYGTPmzI3J1TQxa+fXL/V7eDUSwQOhEC0aLCv
0vmP8ZBk0WmpMcA1GDH6KI8jmExVQRkyVNjm2yykVX6lpntEoh4=
=t6Jk
-----END PGP SIGNATURE-----


Closed
Kei Kebreau wrote 7 years ago
(name . Leo Famulari)(address . leo@famulari.name)
874lq9hf75.fsf@posteo.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (32 lines)
> On Thu, Sep 14, 2017 at 09:46:33AM -0400, Kei Kebreau wrote:
>> ludo@gnu.org (Ludovic Courtès) writes:
>>
>> > Kei Kebreau <kei@openmailbox.org> skribis:
>> >
>> >> Leo Famulari <leo@famulari.name> writes:
>> >>
>> >>> On Sat, Jun 24, 2017 at 02:06:06PM -0400, Kei Kebreau wrote:
>> >>>> * gnu/packages/acl.scm (acl)[arguments]: Enable tests. Add
>> >>>> 'patch-tests' phase.
>> >>>
>> >>> Great!
>> >>>
>> >>> But we'll probably need to wait for the next core-updates cycle. I've
>> >>> applied to locally to a core-updates-next branch but it would be great
>> >>> if you kept it around for the next cycle :)
>> >>
>> >> Cool. I'll hold on to the patch!
>> >
>> > Now is the time to try the patch on ‘core-updates’!
>> >
>> > Ludo’.
>>
>> Aw, I missed this becuase of my email migration. I'll catch it next time
>> as long as this message makes it to kkebreau@posteo.net instead of
>> kei@openmailbox.org.
>>
>> Thanks in advance.
>
> I amended this patch to apply and pushed it as
> 2d433b5363fecba0d63caa1844c937dec4ccc23b.

Thank you!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAln+Oc4ACgkQ5qXuPBlG
eg2DpxAAitRC2xIai+3Il4AS1OuuI9yY2QFwM1gphCoXxZ+WmLHTfXBg/ZBxYtpN
qeX5WM1dtjpADY5PVoFH+cSydjxpU/hmfTGcBvNr9Rxh/D8P6uNOEH9TgOhHDLg0
jHe5YvHnCIWgajg4Q5me++2/K4mBHgY/FeON3bKiuhCEjhSiMUh8OIwvJq16gPmS
J6AmRXeJOf5MPOOFUT62kJPrV8k+N6Ce4Sx1433IHMLIHCIcFTD1zIJyY5BWLcUW
8fyctezmXeSbybT2LG3O2bDRQknZ5BRHR2dIsDuC+09pqZLy8yWXJW5d+9p7DH8d
dEB9+bhxcnPXrYwPov4zcyLE6ZpIdzx9gbEVSv1N7r4y2zelIm5o8vNOy7FAuKTL
JHKlNe67ptSLZ6m3eNgwN+ykbpFkmco2YO4SweHStR42Eg18IRuqUVRaFWSlbXgd
Sr0Jp7qyCVzMTAL/nc28SrT6CFM1h/ZC6IorvYBmAC+7p17tFOZfhxK3LS0V1X91
C5khJGn27vHhFS6Yt8LCQUPTAeuNYFoDZOCBHhP9yZBV9tMEvbdJfAfIVtOPbQLM
Dyl7+6mbMKiroSdcDgw393fgPNHN5EAjwQYj/yhP062ongXovOhHFL/cb6kj7Io2
R9blE4XJdwa/yLgQOLdgwAlbi6Lk7D8Bxlyj0BEcA3QDkpGrlYs=
=PvFa
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27477@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27477
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help