Add kashmir, crypto++, opendht-with-msgpack-c++-11, and some updates.

  • Done
  • quality assurance status badge
Details
4 participants
  • Adonay Felipe Nogueira
  • Adonay Felipe Nogueira
  • Leo Famulari
  • Christopher Baines
Owner
unassigned
Submitted by
Adonay Felipe Nogueira
Severity
normal
A
A
Adonay Felipe Nogueira wrote on 24 Jun 2017 18:26
(address . guix-patches@gnu.org)
8737apqrlj.fsf@openmailbox.org
Hi Guix! :)

Here follows a series of patches, it's part of the attempt to package
GNU Ring. However, these contributions don't need custom patches from
Savir Faire Linux. The only doubt is in regards to the need to have a
variant of msgpack that uses C++ 11 instead, and have a variant of
opendht that makes use of such msgpack variant instead.


Respectfully, Adonay.
--
- Palestrante e consultor sobre /software/ livre (não confundir com
gratis).
- "WhatsApp"? Ele não é livre, por isso não uso. Iguais a ele prefiro
GNU Ring, ou Tox. Quer outras formas de contato? Adicione o vCard
que está no endereço acima aos teus contatos.
- Pretende me enviar arquivos .doc, .ppt, .cdr, ou .mp3? OK, eu
aceito, mas não repasso. Entrego apenas em formatos favoráveis ao
/software/ livre. Favor entrar em contato em caso de dúvida.
From 4622ca4c1ba0ef42c1b0db1070727c072365fbf6 Mon Sep 17 00:00:00 2001
From: Adonay Felipe Nogueira <adfeno@openmailbox.org>
Date: Sat, 24 Jun 2017 11:53:49 -0300
Subject: [PATCH] gnu: Add kashmir.

* gnu/packages/cpp.scm (kashmir): New variable.
---
gnu/packages/cpp.scm | 52 +++++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 51 insertions(+), 1 deletion(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index da19255..228be99 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
+;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,9 +21,58 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix build utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
- #:use-module (gnu packages autotools))
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages compression))
+
+(define-public kashmir
+ (let ((release "0")
+ (commit "2f3913f49c4ac7f9bff9224db5178f6f8f0ff3ee")
+ (revision 1))
+ (package
+ (name "kashmir")
+ (version (if (zero? revision)
+ release
+ (string-append release "-"
+ (number->string revision)
+ "." (string-take commit 7))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Corvusoft/" name
+ "-dependency/archive/" commit ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "11hbh3d7w74gng9qgz3hdrzvxjgil1pymk2bzxv1ajh9vp60xxs9"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((gzip (assoc-ref %build-inputs "gzip"))
+ (source (assoc-ref %build-inputs "source"))
+ (tar (assoc-ref %build-inputs "tar")))
+ (setenv "PATH" (string-append gzip "/bin:"
+ tar "/bin"))
+ (mkdir-p %output)
+ (system* "tar" "-xvf" source "-C" %output)
+ (chdir %output)
+ (for-each (lambda (file)
+ (rename-file file "kashmir-dependency"))
+ (find-files "." "kashmir-dependency-" #:directories? #t))))))
+ (native-inputs
+ `(("source" ,source)
+ ("tar" ,tar)
+ ("gzip" ,gzip)))
+ (synopsis "C++ library providing I/O, MD5, SHA-1, random number string, and UUID operations")
+ (description "The Kashmir Library provides features allowing usage of I/O formatting and state saving; MD5 and SHA-1 hashing; random number streams, and UUID generation.")
+ (home-page "https://github.com/corvusoft/kashmir-dependency")
+ (license license:boost1.0))))
(define-public libzen
(package
--
1.9.1
From b61ac13661a9188394285ac83991d5eb3853d1d6 Mon Sep 17 00:00:00 2001
From: Adonay Felipe Nogueira <adfeno@openmailbox.org>
Date: Sat, 24 Jun 2017 12:02:01 -0300
Subject: [PATCH] gnu: argon2: Update to 20161029-4.9e3ae0f.

* gnu/packages/password-utils.scm (argon2): Update to 20161029-4.9e3ae0f.
---
gnu/packages/password-utils.scm | 94 +++++++++++++++++++++++++++--------------
1 file changed, 62 insertions(+), 32 deletions(-)

Toggle diff (122 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9cfacdb..0c56acc 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
(define-module (gnu packages password-utils)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix download)
@@ -346,39 +348,67 @@ through the pass command.")
(license license:gpl2+)))
(define-public argon2
- (package
- (name "argon2")
- (version "20161029")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/P-H-C/phc-winner-argon2/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1rymikbysasdadm325jx69i0q19d9srqkny69jwmhswlidr4j07y"))))
- (build-system gnu-build-system)
- (arguments
- `(#:test-target "test"
- #:make-flags '("CC=gcc")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda _
- (let ((out (assoc-ref %outputs "out")))
- (install-file "argon2" (string-append out "/bin"))
- (install-file "libargon2.a" (string-append out "/lib"))
- (install-file "libargon2.so" (string-append out "/lib"))
- (copy-recursively "include"
- (string-append out "/include"))))))))
- (home-page "https://www.argon2.com/")
- (synopsis "Password hashing library")
- (description "Argon2 provides a key derivation function that was declared
+ (let ((release "20161029")
+ (commit "9e3ae0f5e91eced6de3c28a9b61f2d91200119e3")
+ (revision 4))
+ (package
+ (name "argon2")
+ (version (if (zero? revision)
+ release
+ (string-append release "-"
+ (number->string revision)
+ "." (string-take commit 7))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/P-H-C/phc-winner-argon2/archive/"
+ commit ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "Makefile"
+ (("ifneq \\(\\$\\(OPTTEST\\), 0\\)")
+ "ifneq (1, 0)"))))
+ (sha256
+ (base32
+ "122rpbrl2lbhgwj7sanbgyn81dnp3azr8ydxr5sc0rwqlyg3iqdp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-pkg-config-and-makefile
+ (lambda _
+ (substitute* "libargon2.pc"
+ (("/usr")
+ (assoc-ref %outputs "out"))
+ (("@HOST_MULTIARCH@")
+ ,(or (%current-target-system)
+ (%current-system)))
+ (("@UPSTREAM_VER@")
+ ,release))))
+ (replace 'install
+ (lambda _
+ (let ((out (assoc-ref %outputs "out")))
+ (install-file "argon2"
+ (string-append out "/bin"))
+ (install-file "libargon2.a"
+ (string-append out "/lib"))
+ (install-file "libargon2.so.0"
+ (string-append out "/lib"))
+ (install-file "libargon2.pc"
+ (string-append out "/lib/pkgconfig"))
+ (copy-recursively "include"
+ (string-append out "/include"))
+ (symlink (string-append out "/lib/libargon2.so.0")
+ (string-append out "/lib/libargon2.so"))))))))
+ (home-page "https://www.argon2.com/")
+ (synopsis "Password hashing library")
+ (description "Argon2 provides a key derivation function that was declared
winner of the 2015 Password Hashing Competition.")
- (license license:cc0)))
+ (license license:cc0))))
(define-public python-bcrypt
(package
--
1.9.1
A
A
Adonay Felipe Nogueira wrote on 22 Jul 2017 22:59
(address . 27475@debbugs.gnu.org)
87pocsur0w.fsf@openmailbox.org
Strange, no comments so far?
C
C
Christopher Baines wrote on 11 Oct 2017 16:50
control message for bug #27475
(address . control@debbugs.gnu.org)
87tvz5spql.fsf@cbaines.net
tags 27475 patch
C
C
Christopher Baines wrote on 11 Oct 2017 19:22
Re: [bug#27475] Add kashmir, crypto++, opendht-with-msgpack-c++-11, and some updates.
(name . Adonay Felipe Nogueira)(address . adfeno@openmailbox.org)(address . 27475@debbugs.gnu.org)
20171011182254.101c14ce@cbaines.net
On Sat, 24 Jun 2017 13:26:48 -0300
Adonay Felipe Nogueira <adfeno@openmailbox.org> wrote:

Toggle quote (6 lines)
> Here follows a series of patches, it's part of the attempt to package
> GNU Ring. However, these contributions don't need custom patches from
> Savir Faire Linux. The only doubt is in regards to the need to have a
> variant of msgpack that uses C++ 11 instead, and have a variant of
> opendht that makes use of such msgpack variant instead.

I've just noticed that no one has taken a look at this yet! Not quite
sure how that has happened. Here are my comments.

The first general comment is that these patches don't quite apply now,
so it would be useful to send another set which do apply cleanly.

Starting with the kashmir package.

Toggle quote (11 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/Corvusoft/"
> name
> + "-dependency/archive/" commit
> ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "11hbh3d7w74gng9qgz3hdrzvxjgil1pymk2bzxv1ajh9vp60xxs9"))))

Looks like this patch may have got caught up in the recent hash changes
from GitHub. I had to change the sha256 before this would build.

The directory structure in this package looks a little odd. The Debian
package has kashmir-dependency/kashmir as include/kashmir, which might
be a little more usual.

guix lint also reports some issues:

/home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4: kashmir@0-1.2f3913f: tabulation on line 39, column 0
+ more tab issues
/home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4: kashmir@0-1.2f3913f: tabulation on line 71, column 0
/home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4: kashmir@0-1.2f3913f: line 72 is way too long (98 characters)
/home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4: kashmir@0-1.2f3913f: line 73 is way too long (176 characters)


As for the crypto++ package.

guix lint reports lots of tabs.

Toggle quote (7 lines)
> + (add-after 'build 'build-shared
> + (lambda _
> + ;; By default, only the static
> + ;; library is built.
> + (zero?
> + (system* "make" "shared"))))

I think you could get rid of this phase by adding "shared" to the
#:make-flags.

I'm not sure why the binary is has .exe in the name? Even
the inbuilt help calls it cryptest:

Unrecognized command. Run "cryptest h" to obtain usage information.

I have no idea what this does, but running it in a container fails, as
it seems to be looking for data in the doc output:

→ guix environment --container --ad-hoc crypto++:bin -- cryptest.exe
CryptoPP::Exception caught: FileStore: error opening file for reading:
TestData/usage.dat


On to the opendht update.

Toggle quote (3 lines)
> + (let ((release "1.3.3")
> + (revision 5))

I'm not why this revision is being used?

Also, with the msgpack-c++-11 package, I built both msgpack and
msgpack-c++-11 and diffed the contents with diffoscope, and they are
practically identical as far as I can see. I'm guessing there was
supposed to be a difference?


Last but not least, for the argon2 package, for which I don't have any
questions or suggestions. Ignoring the tabs, I think it looks fine.

I hope this helps Adonay :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlneU25fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfesRAAqvy1n6AW3isidhUG6c0pY1l1fTYq54+er3l4USujQDwskO60ifXhJVjV
Za5Yroy0t+jWL2WpCdl77tCNuYilT00sbi/+a/d5/RCLNRR4Sp0+DWQIKW1ZT+87
o24ArNg1+LhaQLgmSL3eezgNuuhO4qL7xWZT6uZ5CjycCkIVXjTyobRbTbyYoFO9
cqvBdOTCKyJG7g3bLaBOJs/1WR3mRwp3oOKlbY1SQ9GT/7ug43pNh3FPisVudLRS
GJkTEe8LskybO9CgOU3gPHaEWMJ7MnVJmXQghJQAScu2KSS8n0bMN9r/KdlJ/H7D
XVBQmKMzy+8gNEyb46L3nbW5ewU+KIlldGNRPR1Av/XSE4hGYtKMIj5CaTPverph
zFI5Gr6ADsc4Uq3mjD3SndRICMQJAqVnG/gqukZvCqXvdao+w30B0zTsWibdS2C0
qtv25wZob9sSTk/uctZbTTxB3V/pF4AVvGMy8Sq/bYY2lMtyqAb4V5cqk56pA34J
ZHFlBre6fvIke9SYmDD9Aq2u0nNb2Yn4FQ0nj3mgELF3e/ricdTHsHzlJlTNDfSw
N2NytqlOIRB1vY5V5iTKJCj6mg8TINjOyy0V+O640bKJ/jBZde9XaXTLgRE16aVy
UxIAgxFiqoTfLE7wrn6GI7Seu2dd5Q7LGBh/8Am2DcUu4j7KWXM=
=i3gW
-----END PGP SIGNATURE-----


A
A
Adonay Felipe Nogueira wrote on 22 Nov 2017 03:16
(address . 27475@debbugs.gnu.org)
87h8tn3vo7.fsf@hyperbola.info
Thank you very much for the feedback! ;)

Here follows an updated patch.

The "release-revision.commit" is taken from [1], I just kept 'revision
as a number when let'ing, and now in this new patch also attempted to
make it so that 'version has checks for the existance of 'revision and
'commit.

As for any other detail (including: whether the msgpack "c++-11" variant
is really needed; or if the "upcoming" packages for GNU Ring will work
if these package definitions are based on the *stable* releases and what
are the drawbacks), I'll unfortunatelly not be able to answer these, as
I'm not a developer of these packages (neither of GNU Ring).

From here on you will be reading text that deserves to be discussed in
another thread.

Some months ago I made an implicit mention of GNU Guix in the GNU Ring
discussion resources, but so far I'm not aware of GNU Ring project
making package definitions for GNU Guix.

There are lots of people interested in using GNU Ring and I was also
made aware that some people downloaded the patches I made for
Guix. Although I don't know what those people interested do or what are
their current limitations, but at least in my case, I'm not a developer
and currently have some time constraints (because I'm looking for a job
and also having to work on my Bachelor's final work).

[1] [[info:guix#Version Numbers]]
2017-10-11T17:22:54+0100 Christopher Baines wrote:
Toggle quote (67 lines)
>
> I've just noticed that no one has taken a look at this yet! Not quite
> sure how that has happened. Here are my comments.
>
> The first general comment is that these patches don't quite apply now,
> so it would be useful to send another set which do apply cleanly.
>
> Starting with the kashmir package.
>
>
> Looks like this patch may have got caught up in the recent hash changes
> from GitHub. I had to change the sha256 before this would build.
>
> The directory structure in this package looks a little odd. The Debian
> package has kashmir-dependency/kashmir as include/kashmir, which might
> be a little more usual.
>
> guix lint also reports some issues:
>
> /home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4:
> kashmir@0-1.2f3913f: tabulation on line 39, column 0
> + more tab issues
> /home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4:
> kashmir@0-1.2f3913f: tabulation on line 71, column 0
> /home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4:
> kashmir@0-1.2f3913f: line 72 is way too long (98 characters)
> /home/chris/.config/guix/latest/gnu/packages/cpp.scm:36:4:
> kashmir@0-1.2f3913f: line 73 is way too long (176 characters)
>
>
> As for the crypto++ package.
>
> guix lint reports lots of tabs.
>
>
> I think you could get rid of this phase by adding "shared" to the
> #:make-flags.
>
> I'm not sure why the binary is has .exe in the name? Even
> the inbuilt help calls it cryptest:
>
> Unrecognized command. Run "cryptest h" to obtain usage information.
>
> I have no idea what this does, but running it in a container fails, as
> it seems to be looking for data in the doc output:
>
> → guix environment --container --ad-hoc crypto++:bin -- cryptest.exe
> CryptoPP::Exception caught: FileStore: error opening file for reading:
> TestData/usage.dat
>
>
> On to the opendht update.
>
>
> I'm not why this revision is being used?
>
> Also, with the msgpack-c++-11 package, I built both msgpack and
> msgpack-c++-11 and diffed the contents with diffoscope, and they are
> practically identical as far as I can see. I'm guessing there was
> supposed to be a difference?
>
>
> Last but not least, for the argon2 package, for which I don't have any
> questions or suggestions. Ignoring the tabs, I think it looks fine.
>
> I hope this helps Adonay :)

--
- Palestrante e consultor sobre /software/ livre (não confundir com
gratis).
- "WhatsApp"? Ele não é livre. Por favor, veja formas de se comunicar
instantaneamente comigo no endereço abaixo.
- Arquivos comuns aceitos (apenas sem DRM): Corel Draw, Microsoft
Office, MP3, MP4, WMA, WMV.
- Arquivos comuns aceitos e enviados: CSV, GNU Dia, GNU Emacs Org, GNU
GIMP, Inkscape SVG, JPG, LibreOffice (padrão ODF), OGG, OPUS, PDF
(apenas sem DRM), PNG, TXT, WEBM.
A
A
Adonay Felipe Nogueira wrote on 9 Jan 2018 14:41
Replace old submitters, make #27475 block #30041 and ask for help
(address . control@debbugs.gnu.org)
87r2qzcfoc.fsf@hyperbola.info
submitter 24550 adfeno@hyperbola.info
submitter 24834 adfeno@hyperbola.info
submitter 25034 adfeno@hyperbola.info
submitter 25035 adfeno@hyperbola.info
submitter 25037 adfeno@hyperbola.info
submitter 26202 adfeno@hyperbola.info
submitter 27475 adfeno@hyperbola.info
submitter 27582 adfeno@hyperbola.info
submitter 27590 adfeno@hyperbola.info
submitter 27686 adfeno@hyperbola.info
submitter 27711 adfeno@hyperbola.info
tags 27475 +help
tags 30041 +help
block 30041 27475
quit
A
A
Adonay Felipe Nogueira wrote on 9 Jan 2018 14:48
Add tags for help and make #30041 blocked by #27475
(address . control@debbugs.gnu.org)
87incbcfd0.fsf@hyperbola.info
tags 27475 + help
tags 30041 + help
block 30041 by 27475
quit
L
L
Leo Famulari wrote on 13 Feb 2019 00:57
Re: [bug#27475] Add kashmir, crypto++, opendht-with-msgpack-c++-11, and some updates.
(name . Adonay Felipe Nogueira)(address . adfeno@openmailbox.org)(address . 27475-done@debbugs.gnu.org)
20190212235749.GA1936@jasmine.lan
Like the other batch of old Ring patches, I'm closing this bug ticket
because there is a new effort to package Ring / Jami in our Git repo:

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlxjXX0ACgkQJkb6MLrK
fwjVJw/9H6mSijsGUa6NJyT/0L1cEScge6J8mz36mj1ORF7kh0Ey0uHOMT6VEHx2
0vU9UklUQqoIPEWWjrx2Qsmpjc2uDyIzRaY7r6Glnc6K7+uROMmlUvDIvKpRlUGN
B9fpqek9hgavwy25Vj7oNXtbpWdVKP/kWgW1KAW9QxWsFkA6ccP/nuzSCRT8iP2v
ynciMp3Y/FHYqoXiLIf0iXH933WiyvE1EI/lTmtFwDIXTEi2MgMLrUnTylP5wONb
D3DyIrEy/xdcdfTp1iEozPFPNm2Soz5FJOOqrwb8gdGssQAJIGqf/k3nwtG7FftN
KUWP8+iWePt1CD/vPmjBoZz3jEq4pqRGzSXak4yArchRAo4/vykOenkOv7L2jN13
KNdTYdOJ+xjTGlM9vPkNFxQ7lSeldZrCVliXbWTLybWOzdb0DDQh5vczglG3Zctz
GNn4kvpE94iXu3Jr8MFLVBphizpRiChA2UftOng6smn2YmF6iYh0tWtc+hlllzRo
uqzCdoBUgTpmkSnHhwh9NTaZ/r9Ce9sqOkvX5aZyP7ZzypJLLTvvMS7eSe8I8P8O
YsL2TubFUA+pLpk6Zm+qNVrQG423rqEP2tOF9vmV74+SIOKIaXS5kP46cd1nlFT8
hS9VA3zn3ekuRgGcKRt6wOQSe3iAy2NqCGEANfeTEHhDd3LZpFk=
=WWKr
-----END PGP SIGNATURE-----


Closed
?