[PATCH] gnu: Add python-uniseg.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170622192128.3186-1-kei@openmailbox.org
* gnu/packages/python.scm (python-uniseg, python2-uniseg): New
variables.
---
gnu/packages/python.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a63006a04..3c3b4056d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2017 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -987,6 +988,42 @@ Python 3 support.")
(define-public python2-setuptools
(package-with-python2 python-setuptools))
+(define-public python-uniseg
+ (package
+ (name "python-uniseg")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/emptypage/uniseg-python/"
+ "get/rel-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1df4gddnj2a0v8z35wb2ra5vvh1f1qyxs8fgd25c8g64031mna6x"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; The test suite requires network access.
+ (home-page
+ "https://bitbucket.org/emptypage/uniseg-python")
+ (synopsis
+ "Python library to determine Unicode text segmentations")
+ (description
+ "Uniseg is a Python package used to determine Unicode text segmentations.
+Supported segmentations include:
+@enumerate
+@item @dfn{Code point} (any value in the Unicode codespace)
+@item @dfn{Grapheme cluster} (user-perceived character made of a single or
+multiple Unicode code points, e.g. \"G\" + acute-accent)
+@item Word break
+@item Sentence break
+@item Line break
+@end enumerate")
+ (license license:expat)))
+
+(define-public python2-uniseg
+ (package-with-python2 python-uniseg))
+
;;; Pycrypto is abandoned upstream:
;;;
;;; https://github.com/dlitz/pycrypto/issues/173
--
2.13.1
Ludovic Courtès wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27451@debbugs.gnu.org)
87shirrf4z.fsf@gnu.org
Kei Kebreau <kei@openmailbox.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/python.scm (python-uniseg, python2-uniseg): New
> variables.

LGTM!

Ludo'.
Kei Kebreau wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27451-done@debbugs.gnu.org)
877f03spom.fsf@openmailbox.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (9 lines)
> Kei Kebreau <kei@openmailbox.org> skribis:
>
>> * gnu/packages/python.scm (python-uniseg, python2-uniseg): New
>> variables.
>
> LGTM!
>
> Ludo'.

Thanks! Pushed to master as fa56c7733d88d3821c92ea1c48d2681bd99aeba4.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAllML/kACgkQ5qXuPBlG
eg2UURAAw+quppdwku/M39IsH6kqz3Txt/tETCkoviIIAHlqVGvxOkvwngtWMfQa
ds63t1TZaimic+rNe2vPzTx0O4rO2kw5Y6Svp8W/j1mXBA1vVMpvH3+g0IL/Zh09
BURtdbBAqOngLyGCIHyxe//4zVQ4NIpxdHrHQdAUMHrb6AMKqnL+lEpxosCnE2Ll
x1DNUMWuDEeK8IfwAMnIA39A3FkJvFpNKrDXigyLePgbpwMD3VuDbyq8PT+LoCx8
v1TOlMXTRv2xgwq9BMiMpJ2a4sjUNkoYrIXHx05P7pYJscYJhK6+9GSpHTwjNrJg
pgEtv70duBAqlHi4lMbUBhp3zK9+WoAoxdJ/H7hV2dTgzIoQ0DaEb8ZQL8ypjZJ4
lBirtQFEPhoVkB5Rg34Z1sx+r5kXzt4GoyaL+NmUEVCyhQhDXjuW5arb0Bu+mbEU
5F+UMhZYfG+zXYr5kCXkj9hl5zpMqo/yI94LAoFKtgdiKbu4MVZDdTdh8KYsYB2O
0DnBowmJTjTm9k2yfef+7TarJOtCGlmf4eoBVNpHTj98foiRrSIm34oZGZqrKD7y
CN2D0OG1xrdEO6V8EPn7TvUIxIjuzQAISeuuLc+ZJ7J5qCtwUf9if+pWVCL9aH6T
oMqbyU+2+95aadK03IfgzHDM9i0CZb3eoCN3sOqDl8IQOW6cnwE=
=TL93
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27451@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27451
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help