Subject: [PATCH] gnu: Add fping.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 18 Jun 2017 00:59
(address . guix-patches@gnu.org)
87wp8a1ar4.fsf@xsteve.at
Hi there,

here is another tool.

I have an open question: Should I run setcap in the installation phase?
I grepped through the package definitions and found no setcap call.

Here is the relevant part of the Readme:

3. Make fping either setuid, or, if under Linux: sudo setcap cap_net_raw+ep fping
From ea5ea7adbf6fe840930c4fb86bedc51d725bd1a8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Stefan=20Reich=C3=B6r?= <stefan@xsteve.at>
Date: Sun, 18 Jun 2017 00:53:40 +0200
Subject: [PATCH] gnu: Add fping.

* gnu/packages/networking.scm (fping): New variable.
---
gnu/packages/networking.scm | 27 ++++++++++++++++++++++++++-
1 file changed, 26 insertions(+), 1 deletion(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5d1c432..d5acac9 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2015, 2016, 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -522,6 +522,31 @@ network frames.")
(license license:gpl2+)
(home-page "https://www.wireshark.org/")))
+(define-public fping
+ (package
+ (name "fping")
+ (version "4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://fping.org/dist/fping-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1kp81wchi79l8z8rrj602fpjrd8bi84y3i7fsaclzlwap5943sv7"))))
+ (build-system gnu-build-system)
+ (home-page "http://fping.org/")
+ (synopsis "Send ICMP ECHO_REQUEST packets to network hosts")
+ (description
+ "fping is a ping like program which uses the Internet Control Message
+Protocol (ICMP) echo request to determine if a target host is responding.
+fping differs from ping in that you can specify any number of targets on the
+command line, or specify a file containing the lists of targets to ping.
+Instead of sending to one target until it times out or replies, fping will
+send out a ping packet and move on to the next target in a round-robin
+fashion.")
+ (license license:expat)))
+
(define-public httping
(package
(name "httping")
--
2.7.4
R
R
Ricardo Wurmus wrote on 18 Jun 2017 12:43
(name . Stefan Reichör)(address . stefan@xsteve.at)(address . 27415-done@debbugs.gnu.org)
87efuh7f0k.fsf@elephly.net
Hi Stefan,

Toggle quote (8 lines)
> I have an open question: Should I run setcap in the installation phase?
> I grepped through the package definitions and found no setcap call.

> Here is the relevant part of the Readme:
>
> https://github.com/schweikert/fping/blob/develop/README.md
> 3. Make fping either setuid, or, if under Linux: sudo setcap cap_net_raw+ep fping

setuid packages are not supported when using Guix as a package manager
on a foreign distribution. On GuixSD setuid packages are separately
handled in the operating system configuration.

This is for security reasons.

The patch looks good to me, so I pushed it to master with commit
61253c4f9. Thanks!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27415@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27415
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch