[PATCH] gnu: Add f-seq.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ben Woodcroft
  • Ludovic Courtès
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 15 Jun 2017 17:26
(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . ricardo.wurmus@mdc-berlin.de)
20170615152624.26092-1-ricardo.wurmus@mdc-berlin.de
* gnu/packages/bioinformatics.scm (f-seq): New variable.
---
gnu/packages/bioinformatics.scm | 50 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c1c0faf24..4c81f0741 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9655,3 +9655,53 @@ browser.")
(license (license:non-copyleft
"http://genome.ucsc.edu/license/"
"The contents of this package are free for all uses."))))
+
+(define-public f-seq
+ (let ((commit "6ccded34cff38cf432deed8503648b4a66953f9b")
+ (revision "1"))
+ (package
+ (name "f-seq")
+ (version (string-append "1.1-" revision "." commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aboyle/F-seq.git")
+ (commit commit)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "1nk33k0yajg2id4g59bc4szr58r2q6pdq42vgcw054m8ip9wv26h"))
+ (modules '((guix build utils)))
+ ;; Remove bundled Java library archives.
+ (snippet
+ '(begin
+ (for-each delete-file (find-files "lib" ".*"))
+ #t))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((target (assoc-ref outputs "out"))
+ (doc (string-append target "/share/doc/f-seq/")))
+ (mkdir-p target)
+ (mkdir-p doc)
+ (substitute* "bin/linux/fseq"
+ (("java") (which "java")))
+ (install-file "README.txt" doc)
+ (install-file "bin/linux/fseq" (string-append target "/bin"))
+ (install-file "build~/fseq.jar" (string-append target "/lib"))
+ (copy-recursively "lib" (string-append target "/lib"))
+ #t))))))
+ (inputs
+ `(("perl" ,perl)
+ ("java-commons-cli" ,java-commons-cli)))
+ (home-page "http://fureylab.web.unc.edu/software/fseq/")
+ (synopsis "Feature density estimator for high-throughput sequence tags")
+ (description
+ "F-Seq is a software package that generates a continuous tag sequence
+density estimation allowing identification of biologically meaningful sites
+whose output can be displayed directly in the UCSC Genome Browser.")
+ (license license:gpl3+))))
--
2.13.0
B
B
Ben Woodcroft wrote on 17 Jun 2017 05:31
92b335f7-4066-4555-3d12-4b0c30f2604d@uq.edu.au
Hi Ricardo,


On 16/06/17 01:26, Ricardo Wurmus wrote:
Toggle quote (7 lines)
> * gnu/packages/bioinformatics.scm (f-seq): New variable.
> [..]
> + (synopsis "Feature density estimator for high-throughput sequence tags")
> + (description
> + "F-Seq is a software package that generates a continuous tag sequence
> +density estimation allowing identification of biologically meaningful sites
> +whose output can be displayed directly in the UCSC Genome Browser.")
"features" is a little vague for me. How about something like this

"F-Seq is a software package that generates a continuous tag sequence
density estimation allowing identification of biologically meaningful sites such as transcription factor binding sites (ChIP-seq) or regions of open chromatin (DNase-seq). Output can be displayed directly in the UCSC Genome Browser."


I also had some problems running this software in a container:

[env]# fseq
/gnu/store/xjfxqh6rp4y4jwr4smwbvjqnikjbivai-profile/bin/fseq: line 30:
sed: command not found
/gnu/store/xjfxqh6rp4y4jwr4smwbvjqnikjbivai-profile/bin/fseq: line 32:
sed: command not found
/gnu/store/xjfxqh6rp4y4jwr4smwbvjqnikjbivai-profile/bin/fseq: line 30:
sed: command not found
/gnu/store/xjfxqh6rp4y4jwr4smwbvjqnikjbivai-profile/bin/fseq: line 32:
sed: command not found
/gnu/store/xjfxqh6rp4y4jwr4smwbvjqnikjbivai-profile/bin/fseq: line 62:
dirname: command not found
Error: Could not find or load main class edu.duke.igsp.gkde.Main

(exitstatus 1)


Given that the exitstatus of the above is non-zero, what about adding a
cheap and cheerful test phase which simply runs "fseq -h" or similar?

Otherwise LGTM.

ben
L
L
Ludovic Courtès wrote on 8 Sep 2017 17:51
control message for bug #27377
(address . control@debbugs.gnu.org)
871snh9oja.fsf@gnu.org
tags 27377 moreinfo
R
R
Ricardo Wurmus wrote on 18 Oct 2017 23:54
(address . control@debbugs.gnu.org)
1db70fd2-3c92-427c-93cf-9e3e55e40cad@HTCAONE.mdc-berlin.net
tags 27377 fixed
close 27377
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27377@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27377
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch