[PATCH 1/2] gnu: stellarium: Fix build with Qt 5.9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Kei Kebreau
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170610222318.12878-2-dannym@scratchpost.org
* gnu/packages/astronomy.scm (stellarium)[arguments]:
Add phase "patch-version-check".
---
gnu/packages/astronomy.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2aa65d588..6c486469d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -141,6 +141,14 @@ programs for the manipulation and analysis of astronomical data.")
(arguments
`(#:test-target "tests"
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-version-check
+ (lambda _
+ ;; Previously-deprecated cmake variable vanished in
+ ;; Qt 5.9.
+ ;; See <https://bugreports.qt.io/browse/QTBUG-60936>.
+ (substitute* "CMakeLists.txt"
+ (("Qt5Core_VERSION_STRING") "Qt5Core_VERSION"))
+ #t))
(add-before 'check 'set-offscreen-display
(lambda _
;; make Qt render "offscreen", required for tests
Kei Kebreau wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27318@debbugs.gnu.org)
87poea4eoa.fsf@openmailbox.org
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (26 lines)
> * gnu/packages/astronomy.scm (stellarium)[arguments]:
> Add phase "patch-version-check".
> ---
> gnu/packages/astronomy.scm | 8 ++++++++
> 1 file changed, 8 insertions(+)
>
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index 2aa65d588..6c486469d 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -141,6 +141,14 @@ programs for the manipulation and analysis of astronomical data.")
> (arguments
> `(#:test-target "tests"
> #:phases (modify-phases %standard-phases
> + (add-after 'unpack 'patch-version-check
> + (lambda _
> + ;; Previously-deprecated cmake variable vanished in
> + ;; Qt 5.9.
> + ;; See <https://bugreports.qt.io/browse/QTBUG-60936>.
> + (substitute* "CMakeLists.txt"
> + (("Qt5Core_VERSION_STRING") "Qt5Core_VERSION"))
> + #t))
> (add-before 'check 'set-offscreen-display
> (lambda _
> ;; make Qt render "offscreen", required for tests

LGTM.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlk9fbUACgkQ5qXuPBlG
eg0fERAAimcevLUqZM2iQ+pChE7GDWbPXYf62WmuR4w3q8JAjwyOKMZdr8xncM+y
VVCz3+J44tCu6znRvXGdAAM2IVxtBcGb+WU0mb+496q1pACmOaHQSkcVrcE7/+ct
kWFf7ULndDQ9cty8uxu+EJIQ+4ewLj+aKMYJbFnUa/rfKtBszCGNH8yvuNhTPKuO
gcj2wMV2Pxwdk4nj4Xv8W9CKbDNVmqPsgSGyNl5wgPJUX6Ns7D+EEJLlhTgF19M3
wEhbcRSiKJ8f/dAyj9O7SVuLJ9zbj0q+Z6WTk4c1dBKmAlkULhERrbAr8fMUclE2
4+lBWeHGgzTW+TgBp3ZVGE0U45+iMPOvmqV6ID5IYESp+30UDV3fjCgH+/3jTT34
YuAWEi8tSS2YJEZdHymP0ojGnXElDn0Cz14O9x3qSdptCJs4x8HGVyh9F9jxpUSz
RBZPILCSjxPrVBcus1oX2fPE95KCCf9dxHdINXQCte6FLhrsmSax6LEhZe9cKqSJ
aSBlNLeIl8arsvBDB70Piokc90E00+w63xhu1HM41iJhajuAUa9hypB61gzWakmO
s6ea0Lerhb/0Vz9L8n5Lrj9dXTeBrW1dCs8V4y5EMsEpn2Hby2GUIh0OCxKQn9wD
mqK9I2mcgbwVJL3tsAft7TQhosTxospuVZLajv3zqbLXCeu7v7I=
=kMSF
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170612073416.72155d13@scratchpost.org
close 27319
close 27318
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27318@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27318
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help