[PATCH] gnu: Add minicom.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170610140634.19849-1-dannym@scratchpost.org
* gnu/packages/engineering.scm (minicom): New variable.
---
gnu/packages/engineering.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 7ad93653e..7568a1a9c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages linux) ;FIXME: for pcb
#:use-module (gnu packages m4)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -812,3 +813,32 @@ the 'showing the effect of'-style of operation.")
for mathematical functions. It also provides an machine-independent
interface to select the best such procedures to use on a given system.")
(license license:gpl3+)))
+
+(define-public minicom
+ (package
+ (name "minicom")
+ (version "2.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://alioth.debian.org/frs/download.php/"
+ "file/4215/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wa1l36fa4npd21xa9nz60yrqwkk5cq713fa3p5v0zk7g9mq6bsk"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--enable-lock-dir=/var/lock")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-lock-check
+ (lambda _
+ (substitute* "configure"
+ (("test -d [$]UUCPLOCK") "true"))
+ #t)))))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "https://alioth.debian.org/projects/minicom/")
+ (synopsis "Serial terminal emulator")
+ (description "@code{minicom} is a serial terminal emulator.")
+ (license license:gpl2+)))
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27309@debbugs.gnu.org)
87vao2qp7q.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/engineering.scm (minicom): New variable.

LGTM, thanks!

Ludo'.
Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170612073518.0978fda4@scratchpost.org
close 27309
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27309@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27309
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help