Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/build/file-systems.scm (string->ext2-uuid, string->ext3-uuid,
string->ext4-uuid, string->btrfs-uuid): New variables. Export them.
---
gnu/build/file-systems.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Toggle diff (27 lines)
diff --git a/gnu/build/file-systems.scm b/gnu/build/file-systems.scm
index 1c733f43b..08f7d478e 100644
--- a/gnu/build/file-systems.scm
+++ b/gnu/build/file-systems.scm
@@ -44,6 +44,10 @@
uuid->string
string->uuid
string->iso9660-uuid
+ string->ext2-uuid
+ string->ext3-uuid
+ string->ext4-uuid
+ string->btrfs-uuid
bind-mount
@@ -552,6 +556,11 @@ UUID representation."
(time-low 4) (time-mid 2) (time-hi 2)
(clock-seq 2) (node 6)))))))
+(define string->ext2-uuid string->uuid)
+(define string->ext3-uuid string->uuid)
+(define string->ext4-uuid string->uuid)
+(define string->btrfs-uuid string->uuid)
+
(define* (canonicalize-device-spec spec #:optional (title 'any))
"Return the device name corresponding to SPEC. TITLE is a symbol, one of