[PATCH] file-systems: Provide string->ext*-uuid, string->btrfs-uuid.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170609184212.23317-1-dannym@scratchpost.org
* gnu/build/file-systems.scm (string->ext2-uuid, string->ext3-uuid,
string->ext4-uuid, string->btrfs-uuid): New variables. Export them.
---
gnu/build/file-systems.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/build/file-systems.scm b/gnu/build/file-systems.scm
index 1c733f43b..08f7d478e 100644
--- a/gnu/build/file-systems.scm
+++ b/gnu/build/file-systems.scm
@@ -44,6 +44,10 @@
uuid->string
string->uuid
string->iso9660-uuid
+ string->ext2-uuid
+ string->ext3-uuid
+ string->ext4-uuid
+ string->btrfs-uuid
bind-mount
@@ -552,6 +556,11 @@ UUID representation."
(time-low 4) (time-mid 2) (time-hi 2)
(clock-seq 2) (node 6)))))))
+(define string->ext2-uuid string->uuid)
+(define string->ext3-uuid string->uuid)
+(define string->ext4-uuid string->uuid)
+(define string->btrfs-uuid string->uuid)
+
(define* (canonicalize-device-spec spec #:optional (title 'any))
"Return the device name corresponding to SPEC. TITLE is a symbol, one of
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27301@debbugs.gnu.org)
87poebyl97.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (3 lines)
> * gnu/build/file-systems.scm (string->ext2-uuid, string->ext3-uuid,
> string->ext4-uuid, string->btrfs-uuid): New variables. Export them.

OK!

Ludo'.
Danny Milosavljevic wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
20170610192236.2fefedba@scratchpost.org
close 27301
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27301@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27301
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help