Enable XPS file support in Evince

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)
87a85hdpd2.fsf@openmailbox.org
The following patches enable XPS file support in Evince.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlk631oACgkQ5qXuPBlG
eg2cKxAAs9aqfytdSg+NA+jt5D8VWD6o+8h+xWPY91hD4YJ58nuxraZQSTJ+rsJb
MAoR6qsN8wGLf5EjIefDDOLOz0Xfmsptf84ngFCOIJt4duJJSOVSE5ARr5LFFUKT
SZQJl8iPf8wabxr26GqGlLUf5f+jNur6ugGT3S2wjWj1GnitPmsVH/xPbWGklweV
YV1mgbnpbOWcUmuuo+egAX+UQkFQMA4NgR8g4KrMHXySeS456KbGkLqvVPDQuXsz
N35r0qmuoY0iXNQYEL7hN7Cl1p/8Egx+vLXtL65D8ZH1yKsbcMV3ucWjfnCDFjuJ
uL7XzD1D2A8Yv14tjRgB8RGHwswPnDVbzlU4BaNtZLC1czWeIC2rMsAImJ1cvQuF
oczAz9/dqQb8WzekhLMpZwb7dmFO42ofj0Tg8IlZ3Ke8gWBJCjwRaf4urRztVbrG
TwvvqeX8Xi4KeqZcUEUZDWCZ8/8E1TL6f/96lbgHAwWr+gqmPM2SectX9jF2t867
jWsihW3T62CAnBYZNu1eUGCgM3EW3XEUE9pIp1vU2IEni/cHhufbKhZsYDO5+ayi
K4VZfz/qZGJvdZc96QCplrew00374rW/k2dkBQtiKBx1CubFTs0YCk7vYv5OJvVs
tr9zOHG6rePivoDbhjJG0C+4VEuQRf3gls/N+6snLg3i6E596Os=
=DJtf
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
[PATCH 1/3] gnu: Add liblcms2.
(address . 27299@debbugs.gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170609175143.20770-1-kei@openmailbox.org
* gnu/packages/image.scm (liblcms2): New variable.
---
gnu/packages/image.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index f6337e0fc..508a24b70 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -64,6 +64,31 @@
#:use-module (guix build-system cmake)
#:use-module (srfi srfi-1))
+(define-public liblcms2
+ (package
+ (name "liblcms2")
+ (version "2.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/lcms/lcms/"
+ version "/lcms2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08pvl289g0mbznzx5l6ibhaldsgx41kwvdn2c974ga9fkli2pl36"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("zlib" ,zlib)))
+ (home-page "http://www.littlecms.com")
+ (synopsis "Color management engine based on the ICC standard.")
+ (description
+ "Little CMS intends to be a small-footprint color management engine, with
+special focus on accuracy and performance. It uses the International Color
+Consortium standard (ICC), which is the modern standard when regarding to color
+management.")
+ (license license:expat)))
+
(define-public libpng
(package
(name "libpng")
--
2.13.0
Kei Kebreau wrote 8 years ago
[PATCH 2/3] gnu: Add libgxps.
(address . 27299@debbugs.gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170609175143.20770-2-kei@openmailbox.org
* gnu/packages/gnome.scm (libgxps): New variable.
---
gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9ea3bb07a..5a57d4cbf 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -288,6 +288,38 @@ the GData protocol — most notably, Google's services. It provides APIs to
access the common Google services, and has full asynchronous support.")
(license license:lgpl2.1+)))
+(define-public libgxps
+ (package
+ (name "libgxps")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "184r06s8g20cfigg7m169n42jjsc9wmzzlycr4g1fxxhr72r8x9y"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("glib" ,glib)
+ ("libarchive" ,libarchive)
+ ("libjpeg" ,libjpeg)
+ ("liblcms2" ,liblcms2)
+ ("libtiff" ,libtiff)
+ ("nettle" ,nettle)))
+ (home-page "https://wiki.gnome.org/Projects/libgxps")
+ (synopsis "GObject-based library for handling and rendering XPS documents")
+ (description
+ "libgxps is a GObject-based library for handling and rendering XPS
+documents. This package also contains binaries that can convert XPS documents
+to other formats.")
+ (license license:lgpl2.1+)))
+
(define-public gnome-common
(package
(name "gnome-common")
--
2.13.0
Kei Kebreau wrote 8 years ago
[PATCH 3/3] gnu: evince: Enable XPS document support.
(address . 27299@debbugs.gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170609175143.20770-3-kei@openmailbox.org
* gnu/packages/gnome.scm (evince)[arguments]: Add "--enable-xps" to
configure-flags.
[inputs]: Add libarchive and libgxps.
---
gnu/packages/gnome.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5a57d4cbf..4dc907e8d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -615,7 +615,7 @@ forgotten when the session ends.")
"13yw0i68dgqp9alyliy3zifszh7rikkpi1xbz5binvxxgfpraf04"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:configure-flags '("--disable-nautilus")
+ `(#:configure-flags '("--disable-nautilus" "--enable-xps")
#:phases
(modify-phases %standard-phases
(add-before 'install 'skip-gtk-update-icon-cache
@@ -625,13 +625,14 @@ forgotten when the session ends.")
(("gtk-update-icon-cache") "true"))
#t)))))
(inputs
- `(("libspectre" ,libspectre)
+ `(("libarchive" ,libarchive)
+ ("libgxps" ,libgxps)
+ ("libspectre" ,libspectre)
("djvulibre" ,djvulibre)
("ghostscript" ,ghostscript)
("poppler" ,poppler)
("libtiff" ,libtiff)
;; TODO:
- ;; Add libgxps for XPS support.
;; Build libkpathsea as a shared library for DVI support.
;; ("libkpathsea" ,texlive-bin)
("gnome-desktop" ,gnome-desktop)
--
2.13.0
Marius Bakke wrote 8 years ago
Re: bug#27299: [PATCH 1/3] gnu: Add liblcms2.
(name . Kei Kebreau)(address . kei@openmailbox.org)
878tl0n7dw.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (2 lines)
> * gnu/packages/image.scm (liblcms2): New variable.

This is already available in (gnu packages ghostscript).
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlk7G9wACgkQoqBt8qM6
VPqpaAf9GtP4kxSiJQVJd/x7hjSImmMEqk5EdFymAZprZsNWjr666QOVJVchdtw1
JsuGwwLN36O21j3joMyTOkre3Uaz3v9fL3R3vrial/YfGExDwDHjxqP04telLtWl
0NkmjimGn2WtEmjAG4qtheMCE3rc/VDGnHKoeQRR+5LNcMEmD1hEWnsZ4KPQl/Pv
iprRRN12TSWwK36VIQn7RR57vQCPJEj5ImS8owK6HlrP5vM2N7CoOcjeDyaWAbvI
Uoqipc8bBuz/jb5Gjz1vmRwoU3/PXoMOVYVEiFdsG+hITqunNL6SwGIWeloqAjgU
o1RpBrnIWwS8Bf/uGxAq+nPwwICt+Q==
=qjBF
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#27299: [PATCH 2/3] gnu: Add libgxps.
(name . Kei Kebreau)(address . kei@openmailbox.org)
8760g4n7bv.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (libgxps): New variable.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlk7HCQACgkQoqBt8qM6
VPqaWQf+KeahvJmJzyYEBE8kWmqhYkX6zL8ITqiFITPOyikiMfT9ncp+wbeItZjU
tPBkQZdLMxKCPZNSavciAlAJHCjuZetpICrRypE0rIIDuHbed94VEnOke/X8MF0r
aVMmO2iCMPNWv1+gIz+3zm3Asfvvv/UXU5KlUrSrzCqoHpAnZfJG6SbfxfUSz1dD
njuQCC8SomoKU6kR4ioG9MwMw8V49qZJbTW6bsLnRmiHKJ0ZYgLGkQB9afvHJXB8
zJxsHOGdbKSr9P6AxItUeJE60puwrmWRgIFZnpSW6R9dgD238qPxYwsuFEw0/aAL
1ZZnFgBp/289z0u78+9qFwcx5MFZng==
=U1i8
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#27299: [PATCH 3/3] gnu: evince: Enable XPS document support.
(name . Kei Kebreau)(address . kei@openmailbox.org)
8737b8n7ag.fsf@fastmail.com
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (4 lines)
> * gnu/packages/gnome.scm (evince)[arguments]: Add "--enable-xps" to
> configure-flags.
> [inputs]: Add libarchive and libgxps.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEyBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlk7HFcACgkQoqBt8qM6
VPohGQf4sKq7s9Qn+EhyeooAmwAkBQsXR08JYRZgSoz0eCgj33Rvh75M0AaCj3dA
el1KVlr3IOBZHyERaGrne8i4tRA3pw3iwDk+2MZcopFLO1i8YV23uTDu+w5vBG6o
jrg97zDJZQPgNcEPJ9obOnKuOBJrP7W36wBgkdIdCrlcwb6acIytll4tDPuvkhrN
QVpxXm8th3lMJobh8RY1ONZoLt5y8WcnHQedThxc0jaVqzQ8YRf8H4roM+pkf7d5
oTM+xrOPCEvT/K0Bt2bIxGRip8gruz19FzKbJvsWia6Be2syRTytnsWuqclwP7F4
8AbTYyPjm2/pUd0LZn7v/ueuulaF
=Nqac
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
Re: bug#27299: [PATCH 1/3] gnu: Add liblcms2.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 27299@debbugs.gnu.org)
8760g4elxt.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (6 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/image.scm (liblcms2): New variable.
>
> This is already available in (gnu packages ghostscript).

Huh. It's a wonder that I missed it. Thanks for the tip.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlk7Om8ACgkQ5qXuPBlG
eg0bww/+M3RWML5BTgDFZHnHaL74NN4zAJu4OD5kN/k3v++qdvdgFNKOoJ/QkNJ0
mpIsjX3ZouxgRqVcHq/TDzWVSeHnjFsCYfZmnSm47Fk1kfq9+Vk7lc0TQbV5+GtZ
VZULgpYNcXIrHw40aYoxQvKHUmyYQYYoQ4W95hJbBR9XrEW/0ccEbYBgUnEGk976
xHfaID/hE0B07Xw7Y9iMVTNi135zwqVDyrflWoqOR+q+6UQA4qSvi+dHOU7Q8TzS
67R3liK0VM6KPvXZ/O9q/OMPkBbbDwNAQ4OD2boy7Y8zREmC/Zm68wM32efWYzwC
C1WBFWvvmduC0l2vm5qTsOFAmKGHp2xJbpnABY4JM/6axbh1J6SelYF/KgWBgudC
8z8hCSCD8lytt06JxQ4L9PTQf8l3wnr3+0qOc1+hbUHEnavuMizaSeOSMKSdtl0o
OqL5uIts7/+REpkYQsnT6yLQOsLslwA0Iui4CXqg94fT1HEAiRgMzWpXDdfC7Ebu
Ya1ZOknRUBHzgdgmz7bSjH4PF+0MgEn9Od8uNCl95J2Gdn466zDxZXf5vI9ohZEU
smr8jUlsW96h/tLNy2mVs4bSYZPoSzFAWn5M4jsjLgWJE4NXmYHIT1/aBTMhVS5T
AuqVCNchGbo1n0yjZWC8ZS31k2Q+GL43N3IsVqQTyb/VDqbOZKA=
=CsAl
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
Re: bug#27299: [PATCH 3/3] gnu: evince: Enable XPS document support.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 27299-done@debbugs.gnu.org)
87zidgd52n.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (8 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/gnome.scm (evince)[arguments]: Add "--enable-xps" to
>> configure-flags.
>> [inputs]: Add libarchive and libgxps.
>
> LGTM.

Pushed to master with unnecessary parts removed. Thanks for the review!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlk7RhAACgkQ5qXuPBlG
eg0/nw//SN+NcuRuU9Vf1CEr6g4j0h3vyc1LkiFwAEaehAVhLIT7qZqf7mpHJ1QE
T371PwYJ37k3m4eDw/o1UzvUueIMXLZGL5NwoqvHcqAgRRsjq3u2vxvRsnA3h7sq
1zYcpYDBXzFnAEsigvf16Lv5xtP6xchOpajd2JSsYb88z24+UG7l/S9S9X1FLvLi
oCf8HvimrSH59WriDut4c16PFnF+K3/1IrEATrTr1uMIRICRSG0jqsVnv8iVINnT
Rz82TWw39TOHEEYP6N4Oq/ZzbUOTTW5YPoK80MIeTeXUpA8/13byWxzZuzLjNIju
W435n3UYKSG/i3tf0btPOxfDNXbBpQRBZHM3LyaDq0Q8AWcHg5Ptnl0hNZWH3VKv
3xA3tYeelS7yN9oSU7TvS15lKqvYCTJhvHrPKGv90FOGlHgYRzqYiUKIB8Fx2OcD
2iQ71gcDLtV4LG1PLX0kxUhVjd/UufUaRbO6SmME9CleIex+s6/1QeOSEw5KtKbu
icMF6xW2Hm+hX1Yvks2FpWIbu950+gqaOU8uymQnPaC49Eq4FeOfdcXXg1cc/lK5
taJMFGBX4+UDhIPqYO/Mz+n84thcAHnE6yv8paJuvab4WuJb9GB6lO8Yqbs45Dxa
B5FotbKL44PDquj6Xuz4H7iFJjJPq+MJTkI6T7OApTBsorS7Jnc=
=XewO
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27299@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27299
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help