[PATCH] gnu: postgresql: Enable contributed extensions.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Ludovic Courtès
  • Roel Janssen
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170605161806.23379-1-dannym@scratchpost.org
* gnu/packages/databases.scm (postgresql)[arguments]: Add "build-contrib",
"install-contrib" phases. Add configure-flags.
[inputs]: Add libuuid.
---
gnu/packages/databases.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c46e917b8..963d209a4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -459,7 +459,8 @@ as a drop-in replacement of MySQL.")
"1imrjp4vfslxj5rrvphcrrk21zv8kqw3gacmwradixh1d5rv6i8n"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("--with-uuid=e2fs")
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-/bin/sh
(lambda _
@@ -467,9 +468,16 @@ as a drop-in replacement of MySQL.")
(substitute* '("src/bin/pg_ctl/pg_ctl.c"
"src/bin/psql/command.c")
(("/bin/sh") (which "sh")))
- #t)))))
+ #t))
+ (add-after 'build 'build-contrib
+ (lambda _
+ (zero? (system* "make" "-C" "contrib"))))
+ (add-after 'install 'install-contrib
+ (lambda _
+ (zero? (system* "make" "-C" "contrib" "install")))))))
(inputs
`(("readline" ,readline)
+ ("libuuid" ,util-linux)
("zlib" ,zlib)))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")
Roel Janssen wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27256@debbugs.gnu.org)
87bmq2m4yx.fsf@gnu.org
Danny Milosavljevic writes:

Toggle quote (40 lines)
> * gnu/packages/databases.scm (postgresql)[arguments]: Add "build-contrib",
> "install-contrib" phases. Add configure-flags.
> [inputs]: Add libuuid.
> ---
> gnu/packages/databases.scm | 12 ++++++++++--
> 1 file changed, 10 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index c46e917b8..963d209a4 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -459,7 +459,8 @@ as a drop-in replacement of MySQL.")
> "1imrjp4vfslxj5rrvphcrrk21zv8kqw3gacmwradixh1d5rv6i8n"))))
> (build-system gnu-build-system)
> (arguments
> - `(#:phases
> + `(#:configure-flags '("--with-uuid=e2fs")
> + #:phases
> (modify-phases %standard-phases
> (add-before 'configure 'patch-/bin/sh
> (lambda _
> @@ -467,9 +468,16 @@ as a drop-in replacement of MySQL.")
> (substitute* '("src/bin/pg_ctl/pg_ctl.c"
> "src/bin/psql/command.c")
> (("/bin/sh") (which "sh")))
> - #t)))))
> + #t))
> + (add-after 'build 'build-contrib
> + (lambda _
> + (zero? (system* "make" "-C" "contrib"))))
> + (add-after 'install 'install-contrib
> + (lambda _
> + (zero? (system* "make" "-C" "contrib" "install")))))))
> (inputs
> `(("readline" ,readline)
> + ("libuuid" ,util-linux)
> ("zlib" ,zlib)))
> (home-page "https://www.postgresql.org/")
> (synopsis "Powerful object-relational database system")

LGTM!

Kind regards,
Roel Janssen
Ludovic Courtès wrote 8 years ago
(name . Roel Janssen)(address . roel@gnu.org)
87tw27wja4.fsf@gnu.org
Roel Janssen <roel@gnu.org> skribis:

Toggle quote (44 lines)
> Danny Milosavljevic writes:
>
>> * gnu/packages/databases.scm (postgresql)[arguments]: Add "build-contrib",
>> "install-contrib" phases. Add configure-flags.
>> [inputs]: Add libuuid.
>> ---
>> gnu/packages/databases.scm | 12 ++++++++++--
>> 1 file changed, 10 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
>> index c46e917b8..963d209a4 100644
>> --- a/gnu/packages/databases.scm
>> +++ b/gnu/packages/databases.scm
>> @@ -459,7 +459,8 @@ as a drop-in replacement of MySQL.")
>> "1imrjp4vfslxj5rrvphcrrk21zv8kqw3gacmwradixh1d5rv6i8n"))))
>> (build-system gnu-build-system)
>> (arguments
>> - `(#:phases
>> + `(#:configure-flags '("--with-uuid=e2fs")
>> + #:phases
>> (modify-phases %standard-phases
>> (add-before 'configure 'patch-/bin/sh
>> (lambda _
>> @@ -467,9 +468,16 @@ as a drop-in replacement of MySQL.")
>> (substitute* '("src/bin/pg_ctl/pg_ctl.c"
>> "src/bin/psql/command.c")
>> (("/bin/sh") (which "sh")))
>> - #t)))))
>> + #t))
>> + (add-after 'build 'build-contrib
>> + (lambda _
>> + (zero? (system* "make" "-C" "contrib"))))
>> + (add-after 'install 'install-contrib
>> + (lambda _
>> + (zero? (system* "make" "-C" "contrib" "install")))))))
>> (inputs
>> `(("readline" ,readline)
>> + ("libuuid" ,util-linux)
>> ("zlib" ,zlib)))
>> (home-page "https://www.postgresql.org/")
>> (synopsis "Powerful object-relational database system")
>
> LGTM!

Danny, don’t forget to commit. :-)

Ludo’.
Danny Milosavljevic wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
20170720131157.172de135@scratchpost.org
Hi Ludo,

I think I did. Does it show up for you?

commit b7aa3f5d2e04800b60ece895c88dd753d2c3dfcc
Author: Danny Milosavljevic <dannym@scratchpost.org>
Date: Mon Jun 5 18:18:06 2017 +0200

gnu: postgresql: Enable contributed extensions.
* gnu/packages/databases.scm (postgresql)[arguments]: Add "build-contrib",
"install-contrib" phases. Add configure-flags.
[inputs]: Add libuuid.
Closed
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87o9sfusgg.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (8 lines)
> I think I did. Does it show up for you?
>
> commit b7aa3f5d2e04800b60ece895c88dd753d2c3dfcc
> Author: Danny Milosavljevic <dannym@scratchpost.org>
> Date: Mon Jun 5 18:18:06 2017 +0200
>
> gnu: postgresql: Enable contributed extensions.

It does, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27256@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27256
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help