[PATCH] gnu: gnome: Add deja-dup.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
Blocked by

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170605071241.1825-1-mail@cbaines.net
* gnu/packages/gnome.scm (deja-dup): New variable.
---
gnu/packages/gnome.scm | 79 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 79 insertions(+)

Toggle diff (99 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c1c73f0f7..ab2735686 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -58,6 +58,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages cups)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
@@ -188,6 +189,84 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public deja-dup
+ (package
+ (name "deja-dup")
+ (version "34.3")
+ (source (origin
+ (method url-fetch)
+ (uri "https://launchpadlibrarian.net/295170991/deja-dup-34.3.tar.xz")
+ (sha256
+ (base32
+ "1xqcr61hpbahbla7gdjn4ngjfz7w6f57y7f5pkb77yk05f60j2n9"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:modules ((guix build gnu-build-system)
+ ((guix build cmake-build-system) #:prefix cmake:)
+ (guix build glib-or-gtk-build-system)
+ (guix build utils))
+ #:imported-modules (,@%glib-or-gtk-build-system-modules
+ (guix build cmake-build-system))
+ #:test-target "test"
+ #:configure-flags (list (string-append
+ "-DCMAKE_INSTALL_FULL_DATADIR=" %output)
+ (string-append
+ "-DCMAKE_INSTALL_LIBEXECDIR=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-lockfile-deletion
+ (lambda rest
+ (substitute* "libdeja/tools/duplicity/DuplicityInstance.vala"
+ (("/bin/rm")
+ (which "rm")))))
+ (replace 'configure
+ (assoc-ref cmake:%standard-phases 'configure))
+ (add-before 'check 'set-ctest-output-on-failure
+ (lambda args
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")))
+ (add-after 'install 'wrap-deja-dup
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((python (assoc-ref inputs "python"))
+ (python-path (getenv "PYTHONPATH"))
+ (duplicity (assoc-ref inputs "duplicity"))
+ (out (assoc-ref outputs "out")))
+ (for-each
+ (lambda (program)
+ (wrap-program program
+ `("PATH" ":" prefix (,(string-append python "/bin")
+ ,(string-append duplicity "/bin"))))
+ (wrap-program program
+ `("PYTHONPATH" ":" prefix (,python-path))))
+
+ (find-files (string-append out "/bin")))
+ #t))))))
+ (propagated-inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gobject-introspection" ,gobject-introspection)
+ ("duplicity" ,duplicity)
+ ("python" ,python2-minimal)
+ ("python-pygobject" ,python2-pygobject)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libnotify" ,libnotify)
+ ("libpeas" ,libpeas)
+ ("libsecret" ,libsecret)
+ ("itstool" ,itstool)
+ ("packagekit" ,packagekit)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("vala" ,vala)
+ ("gettext" ,gettext-minimal)
+ ("intltool" ,intltool)
+ ("cmake", cmake)))
+ (home-page "https://launchpad.net/deja-dup")
+ (synopsis "Simple backup tool, for regular encrypted backups")
+ (description
+ "Déjà Dup is a simple backup tool, for regular encrypted backups. It uses
+duplicity as the backend, which supports incremental backups and storage
+either on a local, or remote machine via a number of methods.")
+ (license license:gpl3+)))
+
(define-public dia
;; This version from GNOME's repository includes fixes for compiling with
;; recent versions of the build tools. The latest activity on the
--
2.13.0
Christopher Baines wrote 8 years ago
(no subject)
(address . control@debbugs.gnu.org)
2ca860f8-12af-af00-9719-caa7c9eba58a@cbaines.net
block 27249 by 27247
thanks
Ludovic Courtès wrote 8 years ago
Re: bug#27249: [PATCH] gnu: gnome: Add deja-dup.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 27249@debbugs.gnu.org)
87r2yw2bq7.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (deja-dup): New variable.

There’s a couple of lint warnings fixed by the patch below:
Toggle diff (26 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ab0c57d31..cd78e6015 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -252,19 +252,19 @@ features to enable users to create their discs easily and quickly.")
("libnotify" ,libnotify)
("libpeas" ,libpeas)
("libsecret" ,libsecret)
- ("itstool" ,itstool)
("packagekit" ,packagekit)))
(native-inputs
`(("pkg-config" ,pkg-config)
("vala" ,vala)
("gettext" ,gettext-minimal)
+ ("itstool" ,itstool)
("intltool" ,intltool)
("cmake", cmake)))
(home-page "https://launchpad.net/deja-dup")
(synopsis "Simple backup tool, for regular encrypted backups")
(description
- "Déjà Dup is a simple backup tool, for regular encrypted backups. It uses
-duplicity as the backend, which supports incremental backups and storage
+ "Déjà Dup is a simple backup tool, for regular encrypted backups. It
+uses duplicity as the backend, which supports incremental backups and storage
either on a local, or remote machine via a number of methods.")
(license license:gpl3+)))
Regarding propagated inputs:

Toggle quote (7 lines)
> + (propagated-inputs
> + `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
> + ("gobject-introspection" ,gobject-introspection)
> + ("duplicity" ,duplicity)
> + ("python" ,python2-minimal)
> + ("python-pygobject" ,python2-pygobject)))

Could you add a comment explaining why all this needs to be propagated?
If there’s a way to avoid it, it’s even better (for instance, if
deja-dup execs duplicity, we could hard-code the absolute file name of
duplicity.)

TIA!

Ludo’.
Christopher Baines wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27249@debbugs.gnu.org)
eb9303e5-0306-357d-e18d-6230d7b80479@cbaines.net
On 07/06/17 14:01, Ludovic Courtès wrote:
Toggle quote (53 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/gnome.scm (deja-dup): New variable.
>
> There’s a couple of lint warnings fixed by the patch below:
>
>
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index ab0c57d31..cd78e6015 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -252,19 +252,19 @@ features to enable users to create their discs easily and quickly.")
> ("libnotify" ,libnotify)
> ("libpeas" ,libpeas)
> ("libsecret" ,libsecret)
> - ("itstool" ,itstool)
> ("packagekit" ,packagekit)))
> (native-inputs
> `(("pkg-config" ,pkg-config)
> ("vala" ,vala)
> ("gettext" ,gettext-minimal)
> + ("itstool" ,itstool)
> ("intltool" ,intltool)
> ("cmake", cmake)))
> (home-page "https://launchpad.net/deja-dup")
> (synopsis "Simple backup tool, for regular encrypted backups")
> (description
> - "Déjà Dup is a simple backup tool, for regular encrypted backups. It uses
> -duplicity as the backend, which supports incremental backups and storage
> + "Déjà Dup is a simple backup tool, for regular encrypted backups. It
> +uses duplicity as the backend, which supports incremental backups and storage
> either on a local, or remote machine via a number of methods.")
> (license license:gpl3+)))
>
>
>
>
>
> Regarding propagated inputs:
>
>> + (propagated-inputs
>> + `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
>> + ("gobject-introspection" ,gobject-introspection)
>> + ("duplicity" ,duplicity)
>> + ("python" ,python2-minimal)
>> + ("python-pygobject" ,python2-pygobject)))
>
> Could you add a comment explaining why all this needs to be propagated?
> If there’s a way to avoid it, it’s even better (for instance, if
> deja-dup execs duplicity, we could hard-code the absolute file name of
> duplicity.)

Thanks for your review Ludo, hopefully I can get around to looking at
deja-dup again at the weekend :)
Attachment: signature.asc
Ludovic Courtès wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 27249@debbugs.gnu.org)
87pocvwj84.fsf@gnu.org
Heya Christopher,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (7 lines)
> On 07/06/17 14:01, Ludovic Courtès wrote:
>> Christopher Baines <mail@cbaines.net> skribis:
>>
>>> * gnu/packages/gnome.scm (deja-dup): New variable.
>>
>> There’s a couple of lint warnings fixed by the patch below:

[...]

Toggle quote (17 lines)
>> Regarding propagated inputs:
>>
>>> + (propagated-inputs
>>> + `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
>>> + ("gobject-introspection" ,gobject-introspection)
>>> + ("duplicity" ,duplicity)
>>> + ("python" ,python2-minimal)
>>> + ("python-pygobject" ,python2-pygobject)))
>>
>> Could you add a comment explaining why all this needs to be propagated?
>> If there’s a way to avoid it, it’s even better (for instance, if
>> deja-dup execs duplicity, we could hard-code the absolute file name of
>> duplicity.)
>
> Thanks for your review Ludo, hopefully I can get around to looking at
> deja-dup again at the weekend :)

It’s been a long week-end. ;-) Could you take a look again so we can
save this patch from bitrot?

TIA!

Ludo’.
Christopher Baines wrote 8 years ago
[PATCH] gnu: gnome: Add deja-dup.
(address . 27249@debbugs.gnu.org)
20170722093018.30707-1-mail@cbaines.net
* gnu/packages/gnome.scm (deja-dup): New variable.
* gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add patch file entry.
---
gnu/local.mk | 1 +
gnu/packages/gnome.scm | 78 ++++++++++++++++++++++
.../deja-dup-use-ref-keyword-for-iter.patch | 41 ++++++++++++
3 files changed, 120 insertions(+)
create mode 100644 gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch

Toggle diff (157 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 6d9e57062..bb73a54d8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -563,6 +563,7 @@ dist_patch_DATA = \
%D%/packages/patches/cyrus-sasl-CVE-2013-4122.patch \
%D%/packages/patches/dblatex-remove-multirow.patch \
%D%/packages/patches/dbus-helper-search-path.patch \
+ %D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
%D%/packages/patches/diffutils-gets-undeclared.patch \
%D%/packages/patches/doc++-include-directives.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index be00fcff5..1ab59a630 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages cups)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
@@ -193,6 +194,83 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public deja-dup
+ (package
+ (name "deja-dup")
+ (version "34.3")
+ (source (origin
+ (method url-fetch)
+ (uri "https://launchpadlibrarian.net/295170991/deja-dup-34.3.tar.xz")
+ (sha256
+ (base32
+ "1xqcr61hpbahbla7gdjn4ngjfz7w6f57y7f5pkb77yk05f60j2n9"))
+ (patches
+ (search-patches "deja-dup-use-ref-keyword-for-iter.patch"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:modules ((guix build gnu-build-system)
+ ((guix build cmake-build-system) #:prefix cmake:)
+ (guix build glib-or-gtk-build-system)
+ (guix build utils))
+ #:imported-modules (,@%glib-or-gtk-build-system-modules
+ (guix build cmake-build-system))
+ #:test-target "test"
+ #:configure-flags (list (string-append
+ "-DCMAKE_INSTALL_FULL_DATADIR=" %output)
+ (string-append
+ "-DCMAKE_INSTALL_LIBEXECDIR=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-lockfile-deletion
+ (lambda rest
+ (substitute* "libdeja/tools/duplicity/DuplicityInstance.vala"
+ (("/bin/rm")
+ (which "rm")))))
+ (replace 'configure
+ (assoc-ref cmake:%standard-phases 'configure))
+ (delete 'check) ;; Fails due to issues with DBus
+ (add-after 'install 'wrap-deja-dup
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((python (assoc-ref inputs "python"))
+ (python-path (getenv "PYTHONPATH"))
+ (duplicity (assoc-ref inputs "duplicity"))
+ (out (assoc-ref outputs "out")))
+ (for-each
+ (lambda (program)
+ (wrap-program program
+ `("PATH" ":" prefix (,(string-append python "/bin")
+ ,(string-append duplicity "/bin"))))
+ (wrap-program program
+ `("PYTHONPATH" ":" prefix (,python-path))))
+
+ (find-files (string-append out "/bin")))
+ #t))))))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gobject-introspection" ,gobject-introspection)
+ ("duplicity" ,duplicity)
+ ("python" ,python2-minimal)
+ ("python-pygobject" ,python2-pygobject)
+ ("gtk+" ,gtk+)
+ ("libnotify" ,libnotify)
+ ("libpeas" ,libpeas)
+ ("libsecret" ,libsecret)
+ ("packagekit" ,packagekit)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("vala" ,vala)
+ ("gettext" ,gettext-minimal)
+ ("itstool" ,itstool)
+ ("intltool" ,intltool)
+ ("cmake", cmake)))
+ (home-page "https://launchpad.net/deja-dup")
+ (synopsis "Simple backup tool, for regular encrypted backups")
+ (description
+ "Déjà Dup is a simple backup tool, for regular encrypted backups. It
+uses duplicity as the backend, which supports incremental backups and storage
+either on a local, or remote machine via a number of methods.")
+ (license license:gpl3+)))
+
(define-public dia
;; This version from GNOME's repository includes fixes for compiling with
;; recent versions of the build tools. The latest activity on the
diff --git a/gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch b/gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch
new file mode 100644
index 000000000..a03e0c548
--- /dev/null
+++ b/gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch
@@ -0,0 +1,41 @@
+From 5676766be5e845ccb6cdf46cfa8722497f151752 Mon Sep 17 00:00:00 2001
+From: Jeremy Bicha <jbicha@ubuntu.com>
+Date: Fri, 16 Jun 2017 15:11:37 -0400
+Subject: Use 'ref' keyword for iter, requires vala 0.36
+
+
+diff --git a/deja-dup/widgets/ConfigList.vala b/deja-dup/widgets/ConfigList.vala
+index 15de2d6..02cd81a 100644
+--- a/deja-dup/widgets/ConfigList.vala
++++ b/deja-dup/widgets/ConfigList.vala
+@@ -333,7 +333,7 @@ public class ConfigList : ConfigWidget
+
+ model.row_deleted.disconnect(write_to_config);
+ foreach (Gtk.TreeIter iter in iters) {
+- (model as Gtk.ListStore).remove(iter);
++ (model as Gtk.ListStore).remove(ref iter);
+ }
+ model.row_deleted.connect(write_to_config);
+
+diff --git a/deja-dup/widgets/ConfigLocation.vala b/deja-dup/widgets/ConfigLocation.vala
+index 869e2a8..d21c556 100644
+--- a/deja-dup/widgets/ConfigLocation.vala
++++ b/deja-dup/widgets/ConfigLocation.vala
+@@ -397,12 +397,12 @@ public class ConfigLocation : ConfigWidget
+ if (uuid == saved_uuid)
+ return;
+
+- store.remove(iter);
++ store.remove(ref iter);
+
+ if (--num_volumes == 0) {
+ Gtk.TreeIter sep_iter;
+ if (store.get_iter_from_string(out sep_iter, index_vol_sep.to_string())) {
+- store.remove(sep_iter);
++ store.remove(ref sep_iter);
+ index_vol_sep = -2;
+ }
+ }
+--
+cgit v0.10.2
+
--
2.13.1
Christopher Baines wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27249@debbugs.gnu.org)
20170722103351.06f40102@cbaines.net
On Thu, 20 Jul 2017 11:28:11 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (33 lines)
> Heya Christopher,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
> > On 07/06/17 14:01, Ludovic Courtès wrote:
> >> Christopher Baines <mail@cbaines.net> skribis:
> >>
> >>> * gnu/packages/gnome.scm (deja-dup): New variable.
> >>
> >> There’s a couple of lint warnings fixed by the patch below:
>
> [...]
>
> >> Regarding propagated inputs:
> >>
> >>> + (propagated-inputs
> >>> + `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
> >>> + ("gobject-introspection" ,gobject-introspection)
> >>> + ("duplicity" ,duplicity)
> >>> + ("python" ,python2-minimal)
> >>> + ("python-pygobject" ,python2-pygobject)))
> >>
> >> Could you add a comment explaining why all this needs to be
> >> propagated? If there’s a way to avoid it, it’s even better (for
> >> instance, if deja-dup execs duplicity, we could hard-code the
> >> absolute file name of duplicity.)
> >
> > Thanks for your review Ludo, hopefully I can get around to looking
> > at deja-dup again at the weekend :)
>
> It’s been a long week-end. ;-) Could you take a look again so we can
> save this patch from bitrot?

Yep, its so long ago, I forget what I ended up doing that weekend!

I've sent another patch now. I think vala and dbus may have moved in
the mean time, so this one includes a patch from upstream to fix
compilation issues with vala 0.36, and the check stage had to be
disabled, as the tests no longer pass due to an issue with DBus.

As for the propagated-inputs, I made them all inputs, and tested the
application, and I couldn't see any problems.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAllzG/9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfT/A/+ItKvBfLuPYoh584Q5ri4hRUv6GF46bNWZ7a5qiw65L1B6K5eoiJYnWc0
5bk9CLmD7oYjS5FjvopTFH1fv30BpKO3dRfOcAyHMtTjJZFh5FFMWNoj46/i71xS
rJrvleCobyYFsF32SyTj3r++TghDgi+P2CThi6gd5QC7oa5urt5ZSZwg3AWt1fRW
JJihT/2Bd/jkL+aB8jxd5MnLYQ5TsmwRBAkj3RapNjOS1VtCEBA3t4uyI/prbT+q
s3eobAdivEXUY819JNSGY6jG7VfniPfv8pAuS8Wh76uNZzwQqSs9A3k8qNWRFn3Q
3eLjLMcaKWNnLbs4SCYNtTKj8h7srKfDXmZjw9erAKetZXkCC3RdeCGARZU8GNer
tbpdO2dRnQ63fkQviMo5JtxjDkBHgW7X1wj648BDu+D9RL86b0dQ1VAfdB1iu0XV
kFx5BuCQp3sfZGTWRB30pe/GV9OJQ3zu5BKpfEGucozwkKjSgz22Eft/Jb/WkdqD
Mq6eOAWu4xoUxV7/LtN0g5YHQ3jJTCOZc572yt628Rlg3WuQBgies/ZxXEUQRbYd
qCHa7hpNYT5/1pgIhvugxY3LXfS33sKHSye9e7AzGl5VFXKF8U7+rKJxi1E91X82
Y4GwwOkQKvMaxhdXi8hu5JdBc148P2xZfZbnKqW6VTN4E3xTxh0=
=HSo2
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 8 years ago
Re: [bug#27249] [PATCH] gnu: gnome: Add deja-dup.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 27249-done@debbugs.gnu.org)
87a83um22a.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/gnome.scm (deja-dup): New variable.
> * gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add patch file entry.

Awesome. Applied, thanks!

Ludo'.
Closed
Ludovic Courtès wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 27249@debbugs.gnu.org)
8760eim21c.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/gnome.scm (deja-dup): New variable.
> * gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add patch file entry.

Oh you actually have commit access now, so please push!
Christopher Baines wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 27249@debbugs.gnu.org)
20170724210011.271ee7e6@cbaines.net
On Mon, 24 Jul 2017 14:50:55 +0200
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (9 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
> > * gnu/packages/gnome.scm (deja-dup): New variable.
> > * gnu/packages/patches/deja-dup-use-ref-keyword-for-iter.patch: New
> > file.
> > * gnu/local.mk (dist_patch_DATA): Add patch file entry.
>
> Oh you actually have commit access now, so please push!

Done! Thanks again for your review :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAll2UctfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XecURAAiIaxl7fVxDdfzMpFcItomVGqq5qGidLbmcbq4VNOcYfxDJggpydVCLcR
rcptQuBJuJVmrl6FMbdVxE95Rknox1A7WucpGCtDWM/Cyv2IRz/iL0w1M+K3Y03m
IyUyFWhybF6Z/Iqjx1aPc/nVI99R/772by9K5E2l053APLcRI2p6SLaYtz6ZAVdA
+UvRUqpbAjOWZg5z+HER8Ubz80C7F+75UYusM2C+PEsji/nG3XjJdip73A1pNNza
jN031Gpp3vj7AneI2Er7X1ZM0uKbJzjQ5z+OA/27flnRH9408af3kqd32WTjcHXd
ejPGHNGYNY2KwHQoBYNMgAspqfkPFbK7hbwQbw1j0AJL2q5lxWRZ/jSsnwQ4Vq3f
NHiSpRluNYjDSL1qd+nK9wPbd1h3kXOoy/FahYUdd/ja4IH2Td3fBoVXNj4pAosa
K0YqA0wgC4NACYm3hRUbEXZAWbk72pmlCQ4d6g91Y1mIJW5GNThpnBhJsOKY0zBC
h/dq1l1Z24j43Pm/Op2h1QsYW0mcsC1w/19rYCzRKVQcu3KwV8vUFp86VZKZUXqh
bH1O+uzftykXt00CO26XD4hE4UpGb7S8DLMFcMMTy/w8G+50Y3skeJQOl7zwIAve
5HjohauqcOAcZX0/o4606a5aRTL+Du4ySQW4A4l2xMn4Pkk4p50=
=k9BQ
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 27249@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27249
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help