[PATCH] gnu: Add emacs-inf-ruby

  • Done
  • quality assurance status badge
Details
4 participants
  • Alex Kost
  • Leo Famulari
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
20170604125328.19705-1-mail@cbaines.net
* gnu/packages/emacs.scm (emacs-inf-ruby): New variable.
---
gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 81a74d1fb..d067719c5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1740,6 +1740,29 @@ keep pressing the key until it selects what you want. There's also
column by drawing a thin line down the length of the editing window.")
(license license:gpl3+)))
+(define-public emacs-inf-ruby
+ (package
+ (name "emacs-inf-ruby")
+ (version "2.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nonsequitur/inf-ruby/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m7323k649ckxql1grsdnf71bjhys7l4qb8wbpphb1mr1q8i4066"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/nonsequitur/inf-ruby")
+ (synopsis "Provides a REPL buffer connected to a Ruby subprocess in Emacs")
+ (description
+ "@code{inf-ruby} provides a Read Eval Print Loop (REPL) buffer, allowing
+for easy interaction with a ruby subprocess. Features include support for
+detecting specific uses of Ruby, e.g. when using rails, and using a
+appropriate console.")
+ (license license:gpl3+)))
+
(define-public emacs-znc
(package
(name "emacs-znc")
--
2.13.0
Leo Famulari wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 27233@debbugs.gnu.org)
20170604174044.GA524@jasmine
On Sun, Jun 04, 2017 at 01:53:28PM +0100, Christopher Baines wrote:
Toggle quote (2 lines)
> * gnu/packages/emacs.scm (emacs-inf-ruby): New variable.

LGTM
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlk0RhUACgkQJkb6MLrK
fwhQhA//a6ppGz/7wrFD2KMFHVqFhAImDulum4fgMws4aXqqR0z7oyqEEnB/8kGZ
+pc9kgRKWfSGOcEzBauE9216nzdBqcyLGUZ4yS8OtjBpDCmnA17aBSfY1DS2MnaU
gIg7ivQp97Ul0sk+RkWp7hbAqyZtTwgrQhfDPTp3bi5ozLTRhbsgOKQjvsCMut9q
cXIhBRitIgdr9qJO2yASsTDFL8rcudEiTJQJMtwaBpjcxstBlXn58jYCpNdhdLjP
sMPHDcw2LoUek2bJHZxwyNDTVlGinvYw7xsRxdVD4vyFwTX/vwh8FO2LhZmvruCQ
7bIRk+khtoi2N2MCPH9ljqP6+65Hf5zFkyl5umMxUj2TFnc/qM7t0aVpLg/DOOWo
pYbwjoj+gnTs5wThdPWjkNQMHl5Y0sA25eDzrwOif9rDfRVD1qovWRweBknFCXGd
1D+1IwM0f27QOvY3QHxT+1jjs76jjByYb/om35QrrDj8jwlTR6UyBav6eXcfyixI
TUDgenHinfMg2sd1IS/4vU5/K8YWoDRLAc13LkHisdywpNQZqC6nwysari+jU0cW
Cf/+Ug9ewIxDDEwuNBeNKtYlymNLZLDJOg5KKfrNwBZgaUpQ9n9pBk3efnB2/KEP
TW9qtyGhik1KeZ9bYM8Fm3HhhhrTdhUoRPjLRv7x95EOtALtd4U=
=3tz+
-----END PGP SIGNATURE-----


Alex Kost wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 27233-done@debbugs.gnu.org)
87k24cnki5.fsf@gmail.com
Christopher Baines (2017-06-04 13:53 +0100) wrote:

Toggle quote (5 lines)
> * gnu/packages/emacs.scm (emacs-inf-ruby): New variable.
> ---
> gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)

Committed, thanks! Sorry for the delay, I thought (and probably Leo as
well) that you have commit access to the guix repo.

If you would like to be able to push commits yourself, I'm sure Ludovic
or Ricardo will provide you these rights :-)

--
Alex
Closed
Ludovic Courtès wrote 8 years ago
(address . 27233@debbugs.gnu.org)
87a858f4qq.fsf@gnu.org
Howdy!

Alex Kost <alezost@gmail.com> skribis:

Toggle quote (3 lines)
> If you would like to be able to push commits yourself, I'm sure Ludovic
> or Ricardo will provide you these rights :-)

I think I proposed it before, or at least I thought about it. Anyway,
what’s your Savannah account Christopher? :-)

BTW, I think other committers can feel entitled to add new hackers to
the list of committers. That will help the project scale better.

Thanks,
Ludo’.
Christopher Baines wrote 8 years ago
(name . Alex Kost)(address . alezost@gmail.com)(address . 27233-done@debbugs.gnu.org)
d41ff419-ef8b-52c2-98f7-b383271b8987@cbaines.net
On 16/06/17 14:13, Alex Kost wrote:
Toggle quote (10 lines)
> Christopher Baines (2017-06-04 13:53 +0100) wrote:
>
>> * gnu/packages/emacs.scm (emacs-inf-ruby): New variable.
>> ---
>> gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
>> 1 file changed, 23 insertions(+)
>
> Committed, thanks! Sorry for the delay, I thought (and probably Leo as
> well) that you have commit access to the guix repo.

Great, thanks.
Attachment: signature.asc
Closed
Christopher Baines wrote 8 years ago
7eebd181-88eb-4ff5-6184-d94fe9dbb79c@cbaines.net
On 16/06/17 14:21, Ludovic Courtès wrote:
Toggle quote (10 lines)
> Howdy!
>
> Alex Kost <alezost@gmail.com> skribis:
>
>> If you would like to be able to push commits yourself, I'm sure Ludovic
>> or Ricardo will provide you these rights :-)
>
> I think I proposed it before, or at least I thought about it. Anyway,
> what’s your Savannah account Christopher? :-)

I did get a message on IRC, but I missed it by a few days. My Savannah
account username is cbaines.
Attachment: signature.asc
Ludovic Courtès wrote 8 years ago
(name . Christopher Baines)(address . mail@cbaines.net)
87mv98dlv7.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (14 lines)
> On 16/06/17 14:21, Ludovic Courtès wrote:
>> Howdy!
>>
>> Alex Kost <alezost@gmail.com> skribis:
>>
>>> If you would like to be able to push commits yourself, I'm sure Ludovic
>>> or Ricardo will provide you these rights :-)
>>
>> I think I proposed it before, or at least I thought about it. Anyway,
>> what’s your Savannah account Christopher? :-)
>
> I did get a message on IRC, but I missed it by a few days. My Savannah
> account username is cbaines.

Awesome, I’ve added you. Could you reply to this message, signed with
the OpenPGP key that you’ll use to sign commit (which presumably is the

After that please make sure to (re)read ‘HACKING’ and you’ll be all set.

Thank you, and “welcome” if that’s something we can say to an old timer!
;-)

Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEPORkVYqE/cadtAz7CQsRmT2a67UFAllD8QwACgkQCQsRmT2a
67UTQw//aRH4bFN/6Mqc4b6aRX6ZL68Mi44dL3WQ3fKBUcsCxx3boLJzPbMRpWNb
cCOfp9tCbHEzbN87gdSleDRPxx+uzAKQH0uVVqt2ouSt4oKJek1jmAdNcLHlHqzR
XIrIcfbE9Rjq5KkPUnZLfxAZ00vcqqTXnH3xR39EPDIGuSQJkctHdqu9QdPh+7u2
O5Qu/aBbE3qu7GT1GiLlgfFWDjrKhqmnxH8Kk6auDT7Mv4o1gqbvuezqT4VhUuou
wOZ0yiKMaUVy7MbuWu+ecTejvtqAYlN0JdAa6kej7KFxJ7efRGWNtipzl7E83fCp
DXj+W/f/vMd91DXmAwDIrhofUYDvUXkOcDf4+yKkFLSrJTHFVT70NDqWojTpUuEF
SxwZP89CpizQbQQt6gn3Up+u/GZcfHNL7hg46p31DprqbN5kAfrriU09cos5H3nq
g//ZcI2tqJg1NCSXmdiZ7+8u82qhOOvqTczd+js9K67bNONTAUTzpIHbFd42ejJg
zZh7RzXQp34veXkzUJBnaRNkDAemcJMIYORWv94YhcoIKboWaHPfVI3vj35qT/W6
a8H5igASjrBwU+UxnBCH0MAwGaDxd0CmU2RnOTaHAYL4caQgUegE2J/a1sp2O8ET
zjgEgaHJqLV6gMyCd53CRox4N2dUldnMlc7ZHWyg6y2lFYD4Jtw=
=DYLd
-----END PGP SIGNATURE-----

Christopher Baines wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
5187b72f-6730-daef-1be9-9aad4de80abc@cbaines.net
On 16/06/17 15:54, Ludovic Courtès wrote:
Toggle quote (20 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> On 16/06/17 14:21, Ludovic Courtès wrote:
>>> Howdy!
>>>
>>> Alex Kost <alezost@gmail.com> skribis:
>>>
>>>> If you would like to be able to push commits yourself, I'm sure Ludovic
>>>> or Ricardo will provide you these rights :-)
>>>
>>> I think I proposed it before, or at least I thought about it. Anyway,
>>> what’s your Savannah account Christopher? :-)
>>
>> I did get a message on IRC, but I missed it by a few days. My Savannah
>> account username is cbaines.
>
> Awesome, I’ve added you. Could you reply to this message, signed with
> the OpenPGP key that you’ll use to sign commit (which presumably is the
> one you uploaded at <https://savannah.gnu.org/users/cbaines>)?

Great :) This email should be signed. Ignore the key on Savannah as it
appears to be incomplete and I haven't worked out yet how to fix it
(when I attempt to paste the key in to the box, it's truncated...).

Toggle quote (5 lines)
> After that please make sure to (re)read ‘HACKING’ and you’ll be all set.
>
> Thank you, and “welcome” if that’s something we can say to an old timer!
> ;-)

Thanks :)
Attachment: signature.asc
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27233@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27233
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help