[PATCH] gnu: python-apsw: Build with all extensions.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Jelle Licht
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jelle Licht
Severity
normal

Debbugs page

Jelle Licht wrote 8 years ago
(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
20170604124903.3567-1-jlicht@fsfe.org
* gnu/packages/python.scm (python-apsw)[phases]: Replace build phase; add flag
to build all extensions.
---
gnu/packages/python.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (17 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7617490bd..4ce56d45c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5725,6 +5725,10 @@ implementation of D-Bus.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (zero?
+ (system* "python" "setup.py" "build" "--enable-all-extensions"))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.13.0
Danny Milosavljevic wrote 8 years ago
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 27232@debbugs.gnu.org)
20170604181924.2816ac6d@scratchpost.org
It works. LGTM.

I get the following message though:

Not doing LoadExtension test. You need to compile the extension first
gcc -fPIC -shared -o ./testextension.sqlext -I. -Isqlite3 src/testextension.c
Ludovic Courtès wrote 8 years ago
(name . Jelle Licht)(address . jlicht@fsfe.org)
87bmow70ww.fsf@gnu.org
Hi Jelle!

As proposed earlier, I’ve added you as a committer on Savannah.
Hopefully that will allow you to push all the patches that people have
already okayed but not pushed thinking that you’d do it. :-)

Please make sure the OpenPGP key at
https://savannah.gnu.org/users/jlicht is what you’ll use to sign
commits. Could you reply to this message signed with this key?

Also please read ‘HACKING’.

That’s it! Happy hacking, and welcome again! :-)

Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEPORkVYqE/cadtAz7CQsRmT2a67UFAllfoJ8ACgkQCQsRmT2a
67X6/BAAjHBkCm3tRw0SfEtqTti5HnyEoNVimpy3IPkB77scMXUyHcGGVAbOxfmG
druRHiTJsr36Zb94QYGqcwdznnP5Crfs/EvBattnmWGvcWq/0N9XwVZxUff6d2ji
KPJmZ3LQ1uIZ0Y1vKNfTYzqqXHehzhGpM0BoNNd6PRyz53ZIUQuFkt7AZeDvLSjn
reRzFdu9+tkBepGL17VldjJqXVUXwnAkh2SZAkr1p3A8GwyoUhlLs7UawsMTfdS4
3ghfVJk7ZmHoMWW8NVV28BwB4vkBxv9I5nV4J3wedgDONaepzuIPwyAlVtW/+8/B
foYLsxxgjHn/yFWt7IGJ98N37pLmPQwqcPXifHTGugX9iKRfBTCYBIS9aEg4VpbW
1/h3wZtCkYUKmj2aremi+gtQoqqPU89e3T8N/0JtfGYwDkdYKZMQKsFqAGnDt9zc
hI5uN9gcAYFh2bWPBNVpbBS/qZhNSNsJRy5nNtm5iPx5a2SXRbyaObgLCXIlJVNl
ljIXYs1TEQFkqZsGcTC35BiMPXA++qDAOojhZxmCq2MPi3aP/4JpGHnxSH7ApkI4
qmxVeETYPLHUH6qrpFZC/nqHuPakNXm78UwKuxWcYZEsI3Kv6CMwlmU6oA+PmWVy
+MOYTxnLJuMNqqFJIAbz5LN06npdTEaCN83foUDINSoqVHVrZ2I=
=GB4J
-----END PGP SIGNATURE-----

Jelle Licht wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87mv8f23g9.fsf@gmail.com
Hi Ludo,

Still being a bit unused at integrating gpg into my workflow, but I
should have it all working now.

- Jelle

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEE4x2d3uulShSKIEVQ2kWX+Ue0ECUFAllgIwYACgkQ2kWX+Ue0
ECWznQf/VXoyRVTvTTbtFqD9y7Neg1RaHLVomN7JEOL6V5aJG+Uu9heqsYdNW9e6
ZOwpb1ivA2KwWdobKAAfPn5BEwD82Nbpr9lHNfokUzLnQeMYeH0CA5c/jnV2/h/o
nWM9FGhTPlFGtJkKxSYzEyvTWGZBoWlcMHkp1uqfLIW0vaDkjLi+UQFJvvIzN1Vk
Ip1j91j1vR8u+ejGlWvzkKJMYwAsC4ZZEKgmisXeiXBduikPF4XrO1qaJGBCrEg4
u6zkX4nP8TzKbrA6W8HdzNU7ig+FsbfrC9pjJO/b5UIsQ9/xd3CrqGKEbb4efJzO
Ks7ybVhCvptsJ8iwWFGZESGPm8hdJw==
=7hwO
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Jelle Licht)(address . jlicht@fsfe.org)(address . 27232@debbugs.gnu.org)
87podax5sa.fsf@gnu.org
Hi Jelle,

Jelle Licht <jlicht@fsfe.org> skribis:

Toggle quote (3 lines)
> Still being a bit unused at integrating gpg into my workflow, but I
> should have it all working now.

This looks good, except that you signed an empty MIME part, not the body
of your message. :-)

Ludo’.
Ludovic Courtès wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87lgnjwj6p.fsf@gnu.org
Hello,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (7 lines)
> It works. LGTM.
>
> I get the following message though:
>
> Not doing LoadExtension test. You need to compile the extension first
> gcc -fPIC -shared -o ./testextension.sqlext -I. -Isqlite3 src/testextension.c

Jelle, could you check and possibly commit this patch?

Thanks!

Ludo’.
Jelle Licht wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAPsKtfL78HC9qPa8kFmvB-P4_4ORhwXM3D+oXRhdyXzzkc0tCA@mail.gmail.com
I add this command in a phase after build, and adjusted the attached patch
accordingly.
If there are no further issues, I will commit this at the end of this week.


2017-07-20 11:29 GMT+02:00 Ludovic Courtès <ludo@gnu.org>:

Toggle quote (18 lines)
> Hello,
>
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
> > It works. LGTM.
> >
> > I get the following message though:
> >
> > Not doing LoadExtension test. You need to compile the extension first
> > gcc -fPIC -shared -o ./testextension.sqlext -I. -Isqlite3
> src/testextension.c
>
> Jelle, could you check and possibly commit this patch?
>
> Thanks!
>
> Ludo’.
>
Attachment: file
From 3e2176ce3053c6aa6ec84352f417292ccf89e16e Mon Sep 17 00:00:00 2001
From: Jelle Licht <jlicht@fsfe.org>
Date: Sat, 22 Jul 2017 14:23:18 +0200
Subject: [PATCH] gnu: python-apsw: Build with all extensions.

* gnu/packages/python.scm (python-apsw)[phases]: Replace build phase; add flag
to build all extensions. Add build-test-helper to allow testing of
extensions.
---
gnu/packages/python.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7974dfa58..75046e845 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6025,6 +6025,16 @@ implementation of D-Bus.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (zero?
+ (system* "python" "setup.py" "build" "--enable-all-extensions"))))
+ (add-after 'build 'build-test-helper
+ (lambda _
+ (zero?
+ (system
+ (string-append "gcc -fPIC -shared -o ./testextension.sqlext"
+ "-I. -Isqlite3 src/testextension.c") ))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.13.3
Ludovic Courtès wrote 8 years ago
Re: [bug#27232] [PATCH] gnu: python-apsw: Build with all extensions.
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87377x9ojq.fsf@gnu.org
Hello Jelle,

ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (11 lines)
> Danny Milosavljevic <dannym@scratchpost.org> skribis:
>
>> It works. LGTM.
>>
>> I get the following message though:
>>
>> Not doing LoadExtension test. You need to compile the extension first
>> gcc -fPIC -shared -o ./testextension.sqlext -I. -Isqlite3 src/testextension.c
>
> Jelle, could you check and possibly commit this patch?

Ping! :-)

Please close it if it’s no longer relevant.

Ludo’.
Jelle Licht wrote 8 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAPsKtf+emw7i2YdOv+02UXZMLwTMiVP2aoXrtGjXS2Pj9thedA@mail.gmail.com
2017-09-08 17:51 GMT+02:00 Ludovic Courtès <ludo@gnu.org>:

Toggle quote (22 lines)
> Hello Jelle,
>
> ludo@gnu.org (Ludovic Courtès) skribis:
>
> > Danny Milosavljevic <dannym@scratchpost.org> skribis:
> >
> >> It works. LGTM.
> >>
> >> I get the following message though:
> >>
> >> Not doing LoadExtension test. You need to compile the extension first
> >> gcc -fPIC -shared -o ./testextension.sqlext -I. -Isqlite3
> src/testextension.c
> >
> > Jelle, could you check and possibly commit this patch?
>
> Ping! :-)
>
> Please close it if it’s no longer relevant.
>
> Ludo’.
>
Done!
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27232@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27232
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help