Jelle Licht wrote 8 years ago
(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
* gnu/packages/python.scm (python-apsw)[phases]: Replace build phase; add flag
to build all extensions.
---
gnu/packages/python.scm | 4 ++++
1 file changed, 4 insertions(+)
Toggle diff (17 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7617490bd..4ce56d45c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5725,6 +5725,10 @@ implementation of D-Bus.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (zero?
+ (system* "python" "setup.py" "build" "--enable-all-extensions"))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.13.0