[PATCH] gnu: Add retux.

  • Done
  • quality assurance status badge
Details
One participant
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170601174844.4306-1-kei@openmailbox.org
* gnu/packages/games.scm (retux): New variable.
---
gnu/packages/games.scm | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 60d885500..aaae1e54b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -331,6 +331,63 @@ Chess). It is similar to standard chess but this variant is far more complicate
"PrBoom+ is a Doom source port developed from the original PrBoom project.")
(license license:gpl2+)))
+(define-public retux
+ (package
+ (name "retux")
+ (version "1.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/retux/"
+ (version-major+minor version) "/retux-"
+ version "-src.tar.gz"))
+ (sha256
+ (base32
+ "1wgvh3q96kfgymb2jpd58xsms9hmckhhc4fq7v2k61gh2l11cvdj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ ;; no setup.py script
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (data (string-append out "/share/retux"))
+ (doc (string-append out "/share/doc/retux")))
+ (mkdir-p bin)
+
+ (substitute* "retux.py"
+ ;; Use the correct data directory.
+ (("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
+ (string-append "\"" data "\","))
+ ;; Use Python 3 so the patch-shebangs phase works properly.
+ ((".*python2.*") "#!/usr/bin/python3"))
+
+ (copy-file "retux.py" (string-append bin "/retux"))
+
+ (copy-recursively "data" data)
+
+ (install-file "COPYING" doc)))))))
+ (inputs `(("python-sge-pygame" ,python-sge-pygame)
+ ("python-six" ,python-six)
+ ("python-xsge" ,python-xsge)))
+ (home-page "http://retux.nongnu.org")
+ (synopsis "Action platformer game")
+ (description
+ "ReTux is an action platformer loosely inspired by the Mario games,
+utilizing the art assets from the @code{SuperTux} project.")
+ ;; GPL version 3 or later is the license for the code and some art.
+ ;; The rest of the licenses are for the art exclusively, as listed in
+ ;; data/LICENSES.
+ (license (list license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0
+ license:cc-by-sa4.0
+ license:gpl2+
+ license:gpl3+))))
+
(define-public xshogi
(package
(name "xshogi")
--
2.13.0
Kei Kebreau wrote 8 years ago
(address . 27190-done@debbugs.gnu.org)
8737arsoj9.fsf@openmailbox.org
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (74 lines)
> * gnu/packages/games.scm (retux): New variable.
> ---
> gnu/packages/games.scm | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 57 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 60d885500..aaae1e54b 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -331,6 +331,63 @@ Chess). It is similar to standard chess but this variant is far more complicate
> "PrBoom+ is a Doom source port developed from the original PrBoom project.")
> (license license:gpl2+)))
>
> +(define-public retux
> + (package
> + (name "retux")
> + (version "1.3.4")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "mirror://savannah/retux/"
> + (version-major+minor version) "/retux-"
> + version "-src.tar.gz"))
> + (sha256
> + (base32
> + "1wgvh3q96kfgymb2jpd58xsms9hmckhhc4fq7v2k61gh2l11cvdj"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f ; no check target
> + #:phases
> + (modify-phases %standard-phases
> + ;; no setup.py script
> + (delete 'build)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (bin (string-append out "/bin"))
> + (data (string-append out "/share/retux"))
> + (doc (string-append out "/share/doc/retux")))
> + (mkdir-p bin)
> +
> + (substitute* "retux.py"
> + ;; Use the correct data directory.
> + (("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
> + (string-append "\"" data "\","))
> + ;; Use Python 3 so the patch-shebangs phase works properly.
> + ((".*python2.*") "#!/usr/bin/python3"))
> +
> + (copy-file "retux.py" (string-append bin "/retux"))
> +
> + (copy-recursively "data" data)
> +
> + (install-file "COPYING" doc)))))))
> + (inputs `(("python-sge-pygame" ,python-sge-pygame)
> + ("python-six" ,python-six)
> + ("python-xsge" ,python-xsge)))
> + (home-page "http://retux.nongnu.org")
> + (synopsis "Action platformer game")
> + (description
> + "ReTux is an action platformer loosely inspired by the Mario games,
> +utilizing the art assets from the @code{SuperTux} project.")
> + ;; GPL version 3 or later is the license for the code and some art.
> + ;; The rest of the licenses are for the art exclusively, as listed in
> + ;; data/LICENSES.
> + (license (list license:cc0
> + license:cc-by3.0
> + license:cc-by-sa3.0
> + license:cc-by-sa4.0
> + license:gpl2+
> + license:gpl3+))))
> +
> (define-public xshogi
> (package
> (name "xshogi")

Noting the lack of commentary, this package is pushed to master as
519bfc656c680067c902f12b9db32fa8a0ec7c2a.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAllMNcoACgkQ5qXuPBlG
eg36tw//blCGOIJ7FTIJraDApEyb9eDR8NgRX7btputn+D2i8nXP0R1gi5dy0qmV
tJWWLp3nnBWGw0PE8Eyn9q8l2sBUiujowkLwluvzpqxtscBLZG/qoru+yAtR4hBJ
bM8DcpIHMXDIb2Y31XTWL6druCPcao6e9qWvhpC8X0GzfAleMZbyXh4cN2PY1QTe
HAcle92VGSNYlOGynU5+YMPV2spJ9TL4VIqEeuy0+N0JZeUrfHSSaEP3VveKbAt7
Hk2G/bpQ30jre/SjVqAKh5zL7UayGPnPtzpV+XCYDx88fkm2uEUIGnDGNrS5oYHr
Wpq+HKzlzOt5W52QXo4sxlwzMAt6aEjQPyG+7lQ8PQsGJfvej80SVYeKHkD0SonT
JaNBLayol7WKHxiEkg1q99DnY2NpZmInga+cfa8VSIYu0eVX6sK5NsZ0kvrbRWyb
dmUpS33XaVUeSAmJ2XpCslXKjQ0eqi16OiJzr5WSIvBuegK2EttExeCpgk+t9Cob
+bQKI5bEOFl0H6eSJUyZmlSZs5uUQp9R2R9GCU3VShntdwZQwFZxJrYSQf+5Lof0
eU6bT7R7/eeuiuaHMVZUtAS4PceYXi0igXqprxLK9w7ZXd2Igf0lZ5iXf2OV6su1
EGmL46AGBC1/DpnWAfrlSPJ2lH7HZ9+S+Sazcz6q4zWQWIYeaXQ=
=PPat
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27190@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27190
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help