[PATCH] gnu: Add python-xsge.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170531215744.587-1-kei@openmailbox.org
* gnu/packages/game-development.scm (python-xsge, python2-xsge): New
variables.
---
gnu/packages/game-development.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b7bcdee94..80f56b245 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -249,6 +249,43 @@ levels.")
`(("python2-pathlib" ,python2-pathlib)
,@(package-propagated-inputs python2-tmx))))))
+(define-public python-xsge
+ (package
+ (name "python-xsge")
+ (version "2017.04.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/xsge/xsge-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "04il5yx0py6kchxxw6ydbbx0wpiyjf9dgkwsdynirpkczlnid3am"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero?
+ (system* "python" "setup.py" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--root=/")))))
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-sge-pygame" ,python-sge-pygame)
+ ("python-pygame" ,python-pygame)
+ ("python-six" ,python-six)
+ ("python-tmx" ,python-tmx)))
+ (home-page "http://xsge.nongnu.org")
+ (synopsis "Extensions for the SGE Game Engine")
+ (description
+ "xSGE is a collection of modules that make doing certain tasks with the SGE
+Game Engine easier.")
+ (license license:gpl3+)))
+
+(define-public python2-xsge
+ (package-with-python2 python-xsge))
+
(define-public tiled
(package
(name "tiled")
--
2.13.0
Danny Milosavljevic wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 27176@debbugs.gnu.org)
20170601004138.0f6aab03@scratchpost.org
Toggle quote (7 lines)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (zero?
> + (system* "python" "setup.py" "install"
> + (string-append "--prefix=" (assoc-ref outputs "out"))
> + "--root=/")))))

What's the difference to what the python-build-system does?

Toggle quote (2 lines)
> + #:tests? #f))

Why?

Toggle quote (4 lines)
> + (description
> + "xSGE is a collection of modules that make doing certain tasks with the SGE
> +Game Engine easier.")

Like what? :)

Otherwise LGTM!
Kei Kebreau wrote 8 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 27176-done@debbugs.gnu.org)
87efv4msyu.fsf@openmailbox.org
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (9 lines)
>> + (replace 'install
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + (zero?
>> + (system* "python" "setup.py" "install"
>> + (string-append "--prefix=" (assoc-ref outputs "out"))
>> + "--root=/")))))
>
> What's the difference to what the python-build-system does?

The python-build-system also uses "--single-version-externally-managed"
which is unsupported by xSGE's setup.py script for some reason. I've
added a comment stating this.

Toggle quote (6 lines)
>
>> + #:tests? #f))
>
> Why?
>

I forgot the "no check target" comment, but I've since added it.

Toggle quote (6 lines)
>> + (description
>> + "xSGE is a collection of modules that make doing certain tasks with the SGE
>> +Game Engine easier.")
>
> Like what? :)

I added details from the list on the xSGE about page.

Toggle quote (3 lines)
>
> Otherwise LGTM!

Pushed to master as e99039b5da6dfbc49a2f8cf0fb523a8049fe5ef8!
Thanks for the review.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlkvZNkACgkQ5qXuPBlG
eg0EOxAAxXRz1uT1fox4GaxHP7Pj5iftI8qWFoS+58bH3GSTXCJenFVnjXSVa6ZQ
yhknRkLopCi3b4XAV/2h4/oLkphVv8wMN/Qnp8EwMijbFmdAd4+CK0JcnHJuZdDG
tCxHbSFrMYSrX4uAAWrwpGXxne4zUeEgXlCl76Hj5QYxsj1rcTh2SGlCwt+JF9Ht
20SxXFOyZYRkXleSm1uV+g0fSZSea4uawjE6O6GL92CdFP7GScITdijD+10P80mM
XwKzBHQFJFLvt/jq6uL96fUtX8ZoMm/3PuBk08vNIT44eHt2YubpGcIpVaCshFmo
Md7MoGTfCaFTXUYVUxQKCeEAMQ0SPwTGnUYSYRuXw0O3+v57e1TRBHa5/gkRtg40
wa5+hOWYmPvMynAWW7O972UmcSLhq3Nz2JjeARzhNGmKnLbZ6FBZxNZbmkyJY0Z0
n+AHCjUuSltI4V3+3wGsFbEjytlIqdaSjgWq5d8dhICVoPZmBk1hcbClCd8zMB96
/CaO+VvLokZC6054sJjM57D5y0+GADm3cGd8qseVwNLdrimoXTlUZaL0TiGNKXbJ
DblPJVXyaJnclmm0itbfpNU2JLPf3npQmcNk/rj3G6og0YjxprM+q2lqyAW1S/aV
0mKP+oMttHXPGThK+7DyrlUXv8b+D/kc+x7WNi5IuCNfCiDP5Zo=
=K22t
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 27176@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 27176
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help